Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

I deleted my history and now I can't get into my gmail because my cookies are turned off, but they're turned on.

  • 11 ответов
  • 14 имеют эту проблему
  • 2 просмотра
  • Последний ответ от Livlandis

more options

So my computer was running really slow, and I decided to clear my history. Once that was done, I went to log into my gmail but I keep getting "Your browser's cookie functionality is turned off. Please turn it on. [?] " Funny thing is, everything is turned on. I've went through everything and I still can't fix this. This is the first time it's happened, and I even reset Firefox. I need help. :(

Все ответы (11)

more options

Does using the instructions in the Websites say cookies are blocked - Unblock them article help?

more options

Firefox does allow site-specific exceptions, so that's worth checking. When viewing a page on google.com, you can open the Page Info dialog using either:

  • right-click and choose View Page Info > Permissions
  • Tools menu > Page Info > Permissions
  • click the padlock or globe icon in the address bar > More Information > Permissions

This panel should show whether you are allowing Google cookies.

more options

I did everything in that article and it still won't work.

more options

I did that, I am allowing them. And it still won't work.

Изменено Livlandis

more options

Note that a reset tries to import cookies and this makes a reset less suitable in case of issues with cookies.

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

Изменено cor-el

more options

Nope, it still isn't working.

more options

You can delete the permissions.sqlite file (or rename: permissions.sqlit.sav) to reset all stored exceptions.
If this doesn't help then you can undo the rename to restore (overwrite) the previously stored settings file.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can check for problems with preferences.
Rename or delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value.

more options

I did that, and I'm in safe mode. Still won't work. How do I get out of safe mode? Or am I just stuck in it now?

more options

Hi Livlandis, when you exit Firefox and start it again, you'll be in normal mode. At least, that's what's supposed to happen.

more options

Which security software (firewall, anti-virus) do you have?

Make sure that it isn't blocking cookies.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.