X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

TinyMCE 4.0.8 icons not displaying in OSX Firefox

Размещено

I am building a system that uses the latest version of TinyMCE 4.0.8. When viewing the page in ALL other browsers (even IE) and also Firefox on a PC the icons for formatting text show up perfectly. However, when I view the same page on my Mac running OSX 10.6.8 and Firefox 23.0.1 these icons do not show up.

I have tried updating my Firefox but your site says that I am already using the most recent version.

Most of our company who are going to use this system are using Macs with Firefox as a browser so this problem is going to effect everyone.

I will look forward to any help you can offer on this matter.

Regards

Paul

I am building a system that uses the latest version of TinyMCE 4.0.8. When viewing the page in ALL other browsers (even IE) and also Firefox on a PC the icons for formatting text show up perfectly. However, when I view the same page on my Mac running OSX 10.6.8 and Firefox 23.0.1 these icons do not show up. I have tried updating my Firefox but your site says that I am already using the most recent version. Most of our company who are going to use this system are using Macs with Firefox as a browser so this problem is going to effect everyone. I will look forward to any help you can offer on this matter. Regards Paul

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.69 Safari/537.36

Дополнительная информация

jscher2000
  • Top 10 Contributor
8801 решений 71984 ответов
Размещено

It seems TinyMCE uses a downloaded font to render those icons. In the style sheet served on Windows, I have:

@font-face{
  font-family:'tinymce';
  src:url('fonts/icomoon.eot');
  src:url('fonts/icomoon.eot?#iefix') format('embedded-opentype'),url('fonts/icomoon.svg#icomoon') format('svg'),url('fonts/icomoon.woff') format('woff'),url('fonts/icomoon.ttf') format('truetype');
  font-weight:normal;
  font-style:normal
}

If you open the Browser Console (Cmd + Shift+ j), click Clear, then reload the page, do you find any entries for Firefox trying to retrieve any of those font files? You can use the filter box in the upper right corner and enter ico to drill down to the relevant entry(ies) if any.

(Edited to add second screen shot)

It seems TinyMCE uses a downloaded font to render those icons. In the style sheet served on Windows, I have: @font-face{ font-family:'tinymce'; src:url('fonts/icomoon.eot'); src:url('fonts/icomoon.eot?#iefix') format('embedded-opentype'),url('fonts/icomoon.svg#icomoon') format('svg'),url('fonts/icomoon.woff') format('woff'),url('fonts/icomoon.ttf') format('truetype'); font-weight:normal; font-style:normal } If you open the Browser Console (Cmd + Shift+ j), click Clear, then reload the page, do you find any entries for Firefox trying to retrieve any of those font files? You can use the filter box in the upper right corner and enter ico to drill down to the relevant entry(ies) if any. (Edited to add second screen shot)

Изменено jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
17591 решений 159130 ответов
Размещено

Make sure that you allow pages to choose their own fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"
Make sure that you allow pages to choose their own fonts. *Firefox > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

Изменено cor-el