Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Hide "A plugin is needed to display this content" box

  • 12 ответов
  • 139 имеют эту проблему
  • 5479 просмотров
  • Последний ответ от Wesley Branton

more options

Since a few versions, the grayish "A plugin is needed to display this content" box is displayed independently of the z-index of the actual plugin. Since FF24 this rectangle now additionally has become opaque, so it completely covers the complete web site content. This is a huge problem for me as I have to look at web sites using plugins that are not available for FF and I cannot read the actual content anymore, even though the web page is written in a way that the plugin is only shown as some kind of background image. Is there any way to remove this gray box or at least put this box in the background where it should be according to the DOM?

Все ответы (12)

more options

Do you have Adobe Shockwave/Flash Player installed on your computer?

more options

yes Adobe Shockwave/Flash Player installed in my system but still getting this error. Tied resetting and downgrading FF

more options

@Wesley: Regarding the original question I posted: No, no shockwave/flash player is installed. And I don't want to install any flash on my PC, I have no problem with flash not working. I have a problem that the remaining page becomes unreadable because the "missing plugin" box covers the complete screen. Previously (pre FF24), the message was transparent, but now it is opaque, so I cannot read the text that is under this box. I would really appreciate some kind of setting that allows me to make this box be transparent again or simply remove the whole box from my screen.

Again: I don't flash to be working, I just don't want to see this disturbing gray box anymore...

more options

@krai: Most probably you installed the wrong flash. You need to install flash for firefox, not for IE. Go to http://get.adobe.com/de/flashplayer/

If it still does not work, please open a separate question, as the original question does not have anything to do with your problem. Thanks.

more options

Can you post a screenshot please?

more options

Sorry, but that is not possible.

If the webpage contains Adobe Flashplayer content, such as an ad, you must install Adobe to view the page.

Sorry for any inconvenience.

If installing Adobe doesn't solve the issue, you can easily remove it from your computer.

more options

Hi mitxp, if the message is inserted into the page, it probably can be hidden with a custom CSS rule, applied using either a userContent.css file or the Stylish extension.

To develop such a rule, one would need to view a couple examples and determine the selectors Firefox is using. As a first step, is it possible to right-click > Inspect Element(Q) on the message?

more options

@jscher2000: Thanks for the hint, that was a great idea.

I added the following line to my userContent.css and now everything is fine: object[type="application/x-shockwave-flash"] { opacity: 0.01 !important; }

Nevertheless, I think it would be a good idea for mozilla to provide some kind of settings for this...

more options

If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. (You'll need to be on the latest version of Firefox to submit feedback). Your feedback gets collected at http://input.mozilla.org/, where a team of people read it and gather data about the most common issues.

more options

I am attempting to use Google Chat to talk w/another party. We can see and hear our party but they are unable to see of hear us. My OS is Windows 7 Home edition and I am utilizing a Microsoft Life Cam. When I verify my video settings I receive an opaque video icon that includes the statement "need plug-in to display content" but there is no specific plug-in identified. I installed and re-installed Google Chat but continue to receive the same message. Do I need to sign out of FF and install Chrome to utilize Google Chat? Does anyone have any idea what plug-in is needed?

more options

Hi Bfuddled49, is it the old Google Chat (Gmail) or the new Google Hangouts (Google+) chat?

Old Google Chat uses Flash. Usually you would have problems on countless sites if Flash is not installed and enabled. You can check the current status on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash". If it is disabled, it will be toward the bottom on a gray background. Change its status from "Never Activate" to either "Ask to Activate" or "Always Activate". If you can't enable it, then it probably is a very old version that needs to be updated.

Google Hangounts has its own plugin: https://support.google.com/chat/answer/161993

more options

@Bfuddled49

If the above information does not resolve your issue, please consider creating a new thread containing the specific details of your issue.

Doing so will allow the Mozilla volunteers to give you solutions that are more helpful to you. This may help them to solve your problem faster and more efficiently.

Please, feel free to post the link to your thread on this thread for volunteers interested in assisting you.

Thank you.