Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

for a couple of days, firefox doesn't show all of the buttons on msn.com, but iexplorer does...

  • 17 ответов
  • 22 имеют эту проблему
  • 2 просмотра
  • Последний ответ от boomer57

more options

now running firefox 24 on a Sony Vaio, running Win 7

For a couple of days, when we go to msn.com in Firefox, the buttons on page, just below the navigation bars, are covered with a white rectangle, and unavailable to see or click. The buttons are for Outlook, Skype, Bing, etc.

When we go to msn on iexplorer, page shows as normal.

I did just update firefox (not sure which version was running) and have rebooted the computer a couple of times.

Все ответы (17)

more options

This seems to be going around. Could you try the recommendations in these recent threads:

more options

You can also check for font (size) issues.

If you have made changes to Advanced font settings like increasing the minimum/default font size then try the default minimum setting "none" and the default font size 16 in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"
more options

No change that i am aware of was made to the fonts.

The rest of the MSN page displays and operates normally.

The rectangle can be right-clicked on and selected, but I have not been able to move or delete it yet. It remains covering the Bing search box and the other buttons near top of page.

And I don't know if there is any connection, but the little settings cogwheel for favorites which has been in the upper bars of my screen has also gone away...

more options

and all other pages still seem to display and operate normally.

more options

Which element is selected if you right-click in this white area and open the built-in Inspector via Inspect Element?

more options

A big list comes up when I right click on the box, but this highlighted part may be a relevant portion?

<img width="972" height="118" alt="" src="http://col.stb01.s-msn.com/i/65/CDAB2F44A1591D2B308C20C6C15375.jpg"></img>

Изменено cor-el

more options

...thought it would show the code rather than the box, but yes, that is the box which is covering up the top portion of the msn page when i look at it via firefox.

more options

Hi filbertius, the forum interprets some HTML tags...

That image seems to be part of the normal page, nothing alien. Whether I'm logged in or logged out, it isn't blocking the other content. But it is strange that it's inserted using <img> instead of being a background image. I wonder whether it's not being pushed into the background as it should be??

Изменено jscher2000

more options

If I click around in the Inspector and set display:none for various items, I found one that creates a similar display to yours (see attached).

Both the section I hid and the sharing controls that I missed have similar designations in the class attribute:

<div id="tg" class="co6b1 cf co coa2 coc1 headerbar_us">...
<div id="fbtwh2" class="co2b1 cf co coa2 coc1 m3 en-us1">...

I suspect that an add-on is targeting one or more of those class names for hiding. If this is true, then that area of the page should look normal in Firefox's Safe Mode. As for which add-on it might be, an ad blocker is always a logical suspect.

more options

My brother's computer so I am only now becoming familiar with it. He does not appear to have adblocker added in.

Have not yet tried to boot up firefox in safe mode, but will try now...

Changing (or even reliably finding) things in Inspector is well beyond my current computer geek level - I am sadly out of date, and have mostly been a Mac user as well.

more options

safe mode seems to make no difference.

I did un-click the hardware graphics acceleration - made no difference.

The white box does appear to be the normal top of MSN's page, but ends up laying on top of the buttons we need. With the box in place, we cannot see the buttons, and in addition, the mouse cannot detect that a button is under the blank white.

This problem was occurring with previous version of FF as well. Part of the upgrade to FF 24.0 was to see if that was part of problem.

Изменено filbertius

more options

Your screen shot is almost exactly what we get, except ours is completely blank, without the FB and other buttons in shot. - In our case, that image is certainly NOT being pushed to the back.

Изменено filbertius

more options

Hi filbertius, if you use any ad blockers or other content-altering extensions (e.g., Nuke Anything Enhanced), make sure you aren't blocking anything on YahooMSN.

(Sorry, Yahoo on the brain from other threads.)

Изменено jscher2000

more options

I'm running into a similar problem except mine is occurring on Yahoo Mail. I've tried using IE and everything is normal there. Also tried disabling Ad Block and that didn't help. If I click on the rectangles with the 4 digit letter/number code in them they work but I sometimes have to guess at what action I'm initiating. I'm not sure but I think this only started after I updated to FF24.0 last week. I've made no changes to FF either after the update or for many weeks before it. Screenshot is attached.

more options

Hi dzahary, the boxes with the 4 digits indicate a problem loading a font. Most likely, it's a font that gets downloaded from one of Yahoo's sites.

One peculiar thing about your screen shot is that you are not on https:// when accessing your mail. I'm not why that is; if you manually edit the URL by adding http:// https:// in front, does that affect what loads into the page?


More generally, when you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Изменено jscher2000

more options

jscher--You were right, it was apparently a missing font problem. I went into FF content options and checked the box allowing sites to choose their own fonts instead of those I select and all of the buttons now appear. Thank you (cor-el, who posted the same solution earlier) for your help.

Изменено dzahary

more options

I had the same problem, and was able to immediately get the page to render properly solely by clicking the FF Options | Content | Advanced and enabling the "allow pages to choose their own fonts" checkbox.