Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Touch scrolling in Aurora 26.02a makes screen go black (ModernUI on Win8)

  • 10 ответов
  • 64 имеют эту проблему
  • 17 просмотров
  • Последний ответ от th_om_as_hcli

more options


I have a Dell XPS 12 touch-enabled laptop running Windows 8 using Aurora 26.02a in the Modern UI (Metro). It works great, except for scrolling on webpages using touch. This does not work at all. The result when scrolling using touch is that only the original part of the web-page that is currently visible will scroll. If there is more content, then it just scrolls to a complete black screen.

Using the keys on the keyboard to scroll makes the entire webpage appear again and scrolling works fine. If you scroll again using touch, any part of the webpage currently not visible will be black. This behavior happens on all web-pages, so when i put the laptop into tablet mode (by rotating the screen) making the keyboard unavailable, Aurora can't really be used.

Все ответы (10)

more options


Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

Thank you.

more options

Hi! Just a short note on this.

Since I am using Aurora and Firefox side-by-side, I guess I should uninstall both Firefox and Aurora? And then only reinstall Aurora? Or?

I need Firefox because I require Silverlight support in desktop-mode and I use Aurora because I would like to have a friendly Modern-UI browser as well (without having to use IE).


more options

Did you try to disable hardware acceleration in Firefox?

more options

"Since I am using Aurora and Firefox side-by-side..."

Did you create a new Profile for Aurora when you installed it?

If you didn't, you are using the same Profile for both versions. And with the Metro differences in Aurora vs a Firefox release version you may have bOrked the Profile.

more options


I can confirm this issue with the latest Aurora version on my Samsung Smart PC Pro currently running Windows 8.1 Pro RTM.

I also had both, Aurora and FF (23), installed at the same time, just made a clean uninstall of both and a reinstall of just Aurora. Still the same problem like before and described by Ingar.

My tab has an i5-3317U with Intel HD Graphics and the error could be reproduced with the latest vendor, Intel and Intel Beta for Windows 8.1 drivers. Hardware acceleration was temporarily disabled but as this function seems to be a desktop-mode-only function it had no effect (the issue ONLY appears in the metro ui app).

The black screen appears always and on every site whenever I scroll down (at least the 20 sites I've tried ;)). So there seems to be no correlation to the content of the website. In snap mode it also happens when I scroll sideways. I have attached two screenshots for a visual impression. If I have my keyboard attached and I use the trackpad scrolling works fine. Same situation with an USB-mouse. Just scrolling via (display) touchscreen doesn't work. Maybe Ingar can confirm this by just plugging in a mouse to test it.

Additionally to the scroll-black issue I have noticed that I have no zoom functionality, not sure if this is important.

//edit: I can not scroll at all when tapping the black part of the screen, just fyi

Изменено Sw0rd

more options

Hi! The screenshots Sw0rd uploaded exactly match my issues and I've had no luck fixing them at all. Perhaps this is a known bug in Aurora?

more options

No news on this one, apparently. Also experiencing the exact symptoms described and illustrated by Sw0rd.

Now using Aurora 27.0a2 on Acer W700 (Intel Core i3-2365M, HD 3000 graphics), Windows 8.1 RTM. None of the suggestions seem to help.

more options

I have 27.0a2 (2013-11-14) installed on 2 devices: Dell XPS 12 and Standard PC both with 8.1. No change in the behaviour as described before: Using touch the screen "scrolls" in black, using keyboard and mouse everything is fine. Does someone know how to highlight this subject to the devolopment team? I like to use touch based working on ModernUI and I want to get rid of the IE as quick as possible - but this issue disables the change to Firefox on ModernUI.

more options

With the today released nightly build 28 it seems to be working (fine). Fine in brackets as it isn't really as smooth as other mobile browsers (or metro IE) and you have to wait until the site has completed loading. No reaction to touch gestures when the webpage is still loading.

But at least it works and might become smoother in the near future :)

more options

Hello Sw0rd, thanks for the feedback. This version works quite good on the Dell XPS 12 - only small but no disturbing delays and better than using IE.