Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Citrix access gateway website -- the application frame does not load properly

  • 17 ответов
  • 94 имеют эту проблему
  • 184 просмотра
  • Последний ответ от huggibear

more options

Goal - use remote desktop via citrix website; Did work in FF in July; now (Aug) it doesn't

Problem: Application frame with link to RDP is blank

I log into website OK - three frames should be present: 1) fileshare - I don't use this & it appears to load OK; 2) websites - I don't use this & it appears to load OK ; and 3) Applications - This frame is blank but it should load a collection of links including a link to remote desktop

Behavior: If I have just cleared the history then the application frame will "clock" (this is normal) but instead of showing the links a blank frame appears; If I have NOT just cleared the history, the application frame shows the "clock" but it is frozen; slightly different but still results in blank application frame.

I have tried: 1. clear history before logging in (change in "clocking" but still results in blank application frame 2. IPV6- disable by set to true; No impact on problem; toggle back to false 3. network DNS disable prefetch; disable by set to true  ; no impact on problem; toggle back to false 4. preference named plugins.load_appdir_plugins; change its value to true; no impact - set back to false

One significant change I have made "around" the time of the problem is I uninstalled norton that came preinstalled, installed adaware, and removed/ disabled the adaware browser toobar ;

I will appreciate any suggestions from the community.

Изменено FFuser4444

Все ответы (17)

more options

can you try to add a new profile and test there?

more options

Thank you for the good suggestion

I set up a test profile to continue my testing (note same behavior observed in the test profile)

Изменено FFuser4444

more options

Does this work in other browsers?

more options

Is this with a secure connection?

If content is missing or otherwise not working when a secure https connection is used then check if there is a shield icon to the left of the "Site Identity Button" (globe/padlock) on the location bar indicating that content is blocked.

more options

It does work in IE (that is, all three panes load with links) and it worked in FF about a month ago.

I've added an image of the blank frame and an image of the frame from IE

more options

It is a secure connection (HTTPS)

I did not see a shield, I did check the padlock including the "more information" screens and did not find anything identified as an error.

more options

Do you see any unusual errors in the Net log in the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K)?

more options

Yes I also have the exact same problem since a recent FF update and I have been using the Citrix Access Gateway via FF for months without issue.

I haven't installed or removed anything in the last month apart from the recent FF update.

In the Web Dev (Ctrl+Shift+K) I'm getting 2 continuous errors, one on JS - [22:19:24.078] TypeError: can't watch non-native objects of class Proxy @ https://[mydomain]/vpns/cookie_watch.js:153 and Net - https://[mydomain]/Citrix/XenApp/auth/silentDetection.jsp [HTTP/1.1 200 OK 25ms]

more options

Same Exact Problem here, With same errors in the Web Dev.

Can someone suggest any solutions or workarounds? This is affecting multiple production Citrix Users.

more options

I get very similar errors, The errors repeats endlessly

Request URL:  https://[my domain]/cvpn/ ... /Citrix/XenApp/auth/silentDetection.aspx

Request Method:     GET  Status Code:      HTTP/1.1 200 OK

[22:28:32.066] TypeError: can't watch non-native objects of class Proxy @ https://[mydomain]/vpns/cookie_watch.js:153

The following code is apparently related to the cookie_watch.js:153
if (document.watch) {
	document.watch('cookie',function (id,ov,nv) {
	var $r = new XMLHttpRequest();
	return nv;

My Co IT originally indicated that windows 8/ie10 would not work with citrix site and recommended FF. Now, FF does not work but IE10 does. It is certainly possible that IT applied change to citrix site to enable IE and (inadvertently?) broke FF. Unfortunately Co IT provides close to zero support for BYOD.

Luckily, I've found that ie10 works. Have not tried chrome yet.

Изменено cor-el

more options

Выбранное решение

more options

It appears that the FF authorities are working on this issue - good news.

more options

Great news - I've advised our service desk and app deployment teams so they hold off any further investigations pending the bugzilla evaluation.

more options

does anybody know any time line or any specific version that FF authorities are going to resolve this issue?

more options

FYI: Same behavior on 8/31 (still on latest 23.0.1)

more options

FYI: The problem persists as of 9/20 with version 24.0

more options

Hi I've just come across the same issue where after authenticating to my work Citrix Access Gateway I just get a blank application pane.

Whilst on my wife's laptop it works perfectly fine.

Appreciate if someone could provide a resolution for this.

Note - version 25.01