Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

flash plugin runs up multiple times

  • 5 ответов
  • 20 имеют эту проблему
  • 3337 просмотров
  • Последний ответ от cor-el

more options

When opening a page wit flash on it Firefox slows down, has some redrawing glitches. Task manager shos several flash plugins running(5-20) Upgraded from 11.7 to 11.8 with no difference.

Any thoughts?


Все ответы (5)

more options

The Protected Mode feature of Flash 11.3 and higher spawns multiple isolated Flash processes to improve security. You could disable that feature and test whether Firefox performs better. (The feature is associated with a wide range of peculiar issues and just is not fully debugged yet.)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

more options

Turned protected mode off but still get the same problem. Firefox occasionally redraws up and to the left so I get multiple copies of the status bar (which I could explain that better;)) Currently got 6 running although only one is consuming memory; no actually flash playing as far as I can see.

more options

For the graphical glitches:

Try disabling Firefox's use of hardware graphics acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches, particularly when drivers get updated.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved (or at least improved)?

Flash has its own acceleration setting as described in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

Not sure whether that is relevant here.

more options

Thanks for that suggestion. Still getting the issue but less frequently.

Изменено Simon Heffer

more options

Did you try to disable hardware acceleration in the Flash player as well?