Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How to intercept the Adobe Flash plugin block by firefox checking for vulnerabilities?

  • 1 ответ
  • 4 имеют эту проблему
  • 19 просмотров
  • Последний ответ от philipp

more options

The trouble is the grey block, that asking to update Adobe Flash because the version is vulnerability. If the block of Flash object is smaller, then 100px height - there is an empty space, but not gray block with talking about version. I need to intercept the moment using JavaScript, when Firefox checking the version of plugin to make changes in my HTML code to make a GIF, but not flash.

How to intercept the Adobe Flash plugin block by Firefox checking for vulnerabilities from JavaScript code?

The trouble is the grey block, that asking to update Adobe Flash because the version is vulnerability. If the block of Flash object is smaller, then 100px height - there is an empty space, but not gray block with talking about version. I need to intercept the moment using JavaScript, when Firefox checking the version of plugin to make changes in my HTML code to make a GIF, but not flash. How to intercept the Adobe Flash plugin block by Firefox checking for vulnerabilities from JavaScript code?

Изменено Userball

Все ответы (1)

more options

hello, i don't think that this would be possible (but i'm not sure). what you could do is try to sniff the version of flash that is installed & the firefox useragent and just assume that old versions of the plugin will be blocked in this combination.

if you need more help about that, i'd recommend posting in a forum that is more specialized & knowledgeable in web development like http://forums.mozillazine.org/viewforum.php?f=25, since we here on the firefox support forums are primarily focused on support for end-users...