Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Эта тема была закрыта и архивирована. Если вам нужна помощь, задайте новый вопрос.

Can't copy and paste from Firefox 22.0 anymore other than ctrl c & v

  • 92 ответа
  • 115 имеют эту проблему
  • 135 просмотров
  • Последний ответ от GP49

more options

Normally I would select/wrap text in Firefox and right click and choose copy from the top of menu, click and go to Word,Notepad etc. and go to paste but nothing there paste item in menu greyed out.

It works ok ctrl v and c but is frustrating because the built-in function is so much cleaner

  • UPDATE - Downloaded Firefox 23.0 Beta1 - problem is gone - works again - Thanks all!!
Normally I would select/wrap text in Firefox and right click and choose copy from the top of menu, click and go to Word,Notepad etc. and go to paste but nothing there paste item in menu greyed out. It works ok ctrl v and c but is frustrating because the built-in function is so much cleaner *UPDATE - Downloaded Firefox 23.0 Beta1 - problem is gone - works again - Thanks all!!

Изменено jimmy-d

Выбранное решение

The developers have created a fix for this problem for future versions of Firefox (Firefox 23+). Unfortunately, there's no immediate solution for Firefox 22.

The current beta of Firefox 23 does not yet contain the fix. It is included in beta 6, but that is not yet available through the "all beta" page.

Update: The main beta page now offers beta "8" which has the fix. The file you download should have 23.0b8 in the file name.

Note: Firefox 23 is scheduled for release on August 6th, but it isn't pushed out to everyone all at once. You might need to visit the main install page to get it if your Firefox doesn't detect the new version on the 6th or 7th.

Прочитайте этот ответ в контексте 👍 3

Все ответы (20)

more options

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

I notice that you have the "Copy Plain Text 2 1.2" extension.

Are you using or trying to use that extension to copy data to the clipboard?

more options

Ever since the change that introduced HiDPI that has made Firefox ugly as sin, I have had this problem too. Copying highlighted text works infrequently - it SOMETIMES works, but usually not.

I think it might be something to do with Firefox losing focus of the frame you are trying to highlight in, and thus failing to copy. But that might just be a guess.

This problem exists in safe mode; and I did a FULL RESET in the course of trying to fix the HiDPI pixel-density issues without remedying this problem.

It's making the web-browser worthless.

more options

I've found a work-around, make of it what you will:

If I highlight some random text from a Facebook status update, right-click then copy - nothing goes to clipboard.

If I highlight it > view selection source > and copy the text from the pop-up it *SEEMS* to work ok. Will keep you posted if that is just another intermittent success...

more options

jimmy-d & Ace42, I think it's unacceptable that you have to suffer thru this annoying bug.

Please download Firefox 21 (the working version before this one):

And continue to use that one until this problem is resolved.

Although I do ask that you guys help me out by telling me exactly what antivirus software you have installed and what version number it is and if you have any other famous/popular programs running in the system tray (the area of little icons to the left of the clock in the taskbar). Like Skype, Advanced System Care 5 from IOBIT software, CCleaner, etc.

Also if you could check to see if any of you have any extensions appearing in the Addons area. To get there, click the Firefox button then Help > Troubleshooting Information. Then click the "Copy to Clipboard" button and paste it here to this thread however you can, right-click > Paste or Ctrl+V. Hopefully that will work.

Thanks for your help. I'm a volunteer trying to get people to fix this bug and all the info I can get would really help me out.

Изменено NoahSUMO

more options

Try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

I'm using Avast! anti-virus (8.0.1489), but not its other internet security gubbins - JUST the antivirus.

ZoneAlarm Free Firewall version: Vsmon version: Driver version:

Xfire Copyright (C) 2003-2012 Version 1.155 Build 46139 Mar 20 2013 at 20:10:09 XFIRE_LANG_US Build 46139 XFIRE_GAMES.INI Version 46157 XFIRE_TOUCAN Build 46139 DEV_GAMES.INI Not loaded Xfire Codec (XFR1) Installed

The current build of Steam (Jun 6 2013)

MSI Afterburn 2.3.1

My Extensions are: Adblock Plus 2.2.4 eBay Sidebar 2.5.7 IEviewLite 1.3.5 Menu Editor 1.2.7 Smart Video For Youtube 0.977 Status-4-Evar 2013.02.16.23 TimelineRemove.com 1.5.1

Currently disabled are: avast! Online Security 8.0.1489 DivX Plus Web Player HTML5 [video] noscript Zonealarm Security Engine 1.5.393.22

As I pointed out - as part of trying to get the HiDPI fix working I ended up resetting firefox, so this is a problem that, IIRC, occurred before I reloaded all of these add-ons.

Hope this helps narrow down the problem.

Изменено Ace42

more options

Hi Ace42, do you want to try two other settings related to how site scripts interact with right-click and the clipboard:

(1) Some sites may have "anti-copying" scripts that change what happen when you right-click. To prevent sites from preempting Firefox's normal context menu, try the third "Advanced JavaScript" setting described in this article: JavaScript settings and preferences for interactive web pages (uncheck the third box).

Does that make any difference?

(2) To try to block sites from interfering with the copy action, you can switch a setting under the covers.

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the filter box, type or paste clipb and pause while the list is filtered

(C) Double-click dom.event.clipboardevents.enabled to switch its value from true to false.

(If that doesn't help, you can switch it back to true again in case there are sites that you WANT to be able to mess with your clipboard.)

more options

I thought it might be java blocking pop-ups at first; but not only have I disabled JS in the options and still had the problem - but it also occurs on a ton of sites which aren't using JS clipboard modification (Confirmed on everything from Facebook to Google to this page to random VBulletin forums and the like).

Currently reverted to 21.0 and "copy" is working fine again; I could re-update to 22.0 if further testing is critical...

more options

I am also having a problem copying and pasting from Firefox. I cannot copy or paste with the mouse or keyboard. When I try there is nothing in the clipboard. I looked through several threads on the Firefox help forum and this one SEEMS to be the closest match to the problem I'm experiencing.

I have v 22.0, Windows 7 Premium with Service Pack 1, avast Antivirus v 8.0.1489, ZoneAlarm Free Firewall v, and Adblock Plus v 2.2.4.

Is this issue a bug with v 22.0? How do I fix this problem?

more options

I can very rarely copy text from FF's main window. (kybd or mouse, makes no difference)

Work around: highlight and drag text to address bar, copy from address bar.

Problem exists in FF22, FF23 beta, and FF23 beta with add-ons off.

Problem not present in SWIron, Thunderbird, or Notepad.

Win7 64 ultimate. No AV running.

Other apps running: KXmixer, Zonealarm. I don't suspect them, they've never caused this problem before.

I tried to cure the problem by installing Outertech Clipboard History, but no luck. Though it's nice to watch things get added to the clipboard, or see no change.

more options

After the Firefox update from 19.0 to 22.0 I got this problem with copy and paste in Firefox for days now. It happens only in Firefox, nowhere else. Sometimes it works, sometimes not... at specific places it works always.

See the video for details: http://youtu.be/IuUvV7ohJbY

Same problem with safe mode (no addons/extensions). Same problem after GPU Update. Same problem as Administrator + safe mode. Same problem with copy & paste within Firefox (I forgot to show that in the video).

Изменено himox

more options

Same problem running FF22 in OS X 10.8.4 with no AV. CTRL C,V does not work +90%, however right click copy/past does work.

more options

Hi himox, if I could summarize the video based on watching about half of it:

  • Copying selected text from web pages fails a significant percentage of the time (right-click > Copy = clipboard is cleared)
  • Copying from form fields such as the Google search box works normally

Is that the pattern you observed?

more options

Hi DennyD, sorry if some of the posts for Windows users were misleading, but on MacOS X, the shortcuts use the Command key:

  • Copy: command + c
  • Paste: command + v
  • Cut: command + x
more options

@jscher2000: Indeed, this is the case.

more options

I've experienced this problem after upgrading to 22.0 as well. After upgrading from 21.0 to 22.0, my appearance for my browser reverted back to default which prompted me to change it back to my preferred appearance, "Black Gray Whte FF."

As I continued using 22.0 on my 64-bit Win8 Sony Vaio, I began to notice that pasting was no issue. Assuming I was copying from a different program (ex: Notepad) and pasting that information into Firefox. This worked great! However, copying information from Firefox was impossible.

Running AVG Anti-Virus and ZoneAlarm firewall, disabling these programs as a test gave no success or fix.

At this point, I'm considering a downgrade to 21.0 or an upgrade to 23.0 beta (X?). What's the current beta version and build? Additionally, what is Aurora -- is that the working name currently for the 23.0 beta?

more options

quite a few zonealarm users have reported the same issue, which is reportedly disappearing when zonealarm is uninstalled.

more options

In my case, I merely disabled ZoneAlarm. I didn't uninstall it, however. I won't abandon software I've been loyal to for over a decade and have no reason to (same with Firefox loyalty alignments). It's a bug in Firefox and that's cool, I can just wait for it to be banged out.

While I wait for the Firefox community to issue a fix, I'll contemplate a downgrade back to 21.0 vs. an upgrade to Firefox Beta.

- Is Firefox 23.0 Beta "Aurora"? If not, what is Aurora? - What is the current build of Firefox 23.0 Beta?

Thanks for the guidance! :D

more options

aurora is one version ahead of beta, so that would be firefox 24 at the moment. here you'll get an overview of the different channels: https://www.mozilla.org/en-US/firefox/channel/

however i think that your problem might be slightly different than that of the original poster, so updating might not help. you could also try reporting the issue to zonealarm's support though...

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5