X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Firefox doesn't prompt to authenticate proxy settings

Размещено

After entering my proxy settings, I am never prompted to enter my login info and thus nothing loads but Firefox's "Unable to connect" error page. I've tried restarting with addons disabled (safe mode), but still no luck.

After entering my proxy settings, I am never prompted to enter my login info and thus nothing loads but Firefox's "Unable to connect" error page. I've tried restarting with addons disabled (safe mode), but still no luck.

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

Дополнительная информация

Michael Verdi 128 решений 857 ответов
Размещено

Double-check your proxy settings. If everything seems right, try clearing your cookies and cache:

  1. Go to Firefox > History > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Double-check your proxy settings. If everything seems right, try clearing your cookies and cache: #Go to Firefox > History > Clear recent history. #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the ''Clear now'' button. Further information can be found in the [[Clear your cache, history and other personal information in Firefox]] article.
Размещено

Задавший вопрос

Still no luck after clearing everything, Verdi. I'm also certain the settings are correct and are verified working with other programs.

Still no luck after clearing everything, Verdi. I'm also certain the settings are correct and are verified working with other programs.

Изменено frank_r

Michael Verdi 128 решений 857 ответов
Размещено

Ah - if you've set the proxy in Windows, make sure you tell Firefox to use the system proxy. You can do that in the Network settings.

  • Open the options window: Firefox > Options
  • Select the Advanced panel and then the Network tab.
  • Click the Settings button.
  • Make sure "Use System Proxy settings" is selected.

If that still doesn't work, there could be a problem with your profile. The quickest way to get a fresh profile (while saving your bookmarks, history, passwords, cookies and form data) is to use Firefox Reset .

If you don't want to commit to resetting Firefox (it will remove you add-ons and not save your open tabs), you can create a second profile to use for testing this fix with the instructions here - Profile Manager - Create, remove, or switch Firefox profiles

Ah - if you've set the proxy in Windows, make sure you tell Firefox to use the system proxy. You can do that in the [[Advanced settings for accessibility, browsing, system defaults, network, updates, and encryption#w_network-tab|Network settings]]. *Open the options window: Firefox > Options *Select the Advanced panel and then the Network tab. *Click the Settings button. *Make sure "Use System Proxy settings" is selected. If that still doesn't work, there could be a problem with your profile. The quickest way to get a fresh profile (while saving your bookmarks, history, passwords, cookies and form data) is to use [[Reset Firefox – easily fix most problems|Firefox Reset]] . If you don't want to commit to resetting Firefox (it will remove you add-ons and not save your open tabs), you can create a second profile to use for testing this fix with the instructions here - [[Use the Profile Manager to create and remove Firefox profiles]]
cor-el
  • Top 10 Contributor
  • Moderator
17526 решений 158463 ответов
Размещено

How do you set the proxy setting?

Are you entering the IP address and port number in the settings or do you use one of the other to let Firefox detect the setting?

You can try to disable the automatic login prefs and set this pref to false on the about:config page.

  • signon.autologin.proxy -> false
  • network.automatic-ntlm-auth.allow-proxies -> false
  • network.auth.use-sspi -> false
  • network.proxy.share_proxy_settings -> false
How do you set the proxy setting? Are you entering the IP address and port number in the settings or do you use one of the other to let Firefox detect the setting? You can try to disable the automatic login prefs and set this pref to false on the <b>about:config</b> page. *signon.autologin.proxy -> false *network.automatic-ntlm-auth.allow-proxies -> false *network.auth.use-sspi -> false *network.proxy.share_proxy_settings -> false *http://kb.mozillazine.org/about:config

Изменено cor-el

Размещено

Задавший вопрос

Verdi, the proxy isn't set through Windows. The other programs are using it successfully are using it through their own settings as well. Creating a new profile did not solve the issue either.

cor-el, yes, I'm setting the address and the port provided by my VPN service specifically for Socks5. I've already disabled those configs after Googling this issue before making the thread. They did not help.

Verdi, the proxy isn't set through Windows. The other programs are using it successfully are using it through their own settings as well. Creating a new profile did not solve the issue either. cor-el, yes, I'm setting the address and the port provided by my VPN service specifically for Socks5. I've already disabled those configs after Googling this issue before making the thread. They did not help.
Cheng Wang 34 решений 435 ответов
Размещено

Have you seen this post:

https://support.mozilla.org/en-US/questions/926378

It seems that with some proxy services/protocols, you may need to change the following preferences in about:config

  • network.automatic-ntlm-auth.allow-proxies
  • network.negotiate-auth.allow-proxies

This extension may also help: https://addons.mozilla.org/en-US/firefox/addon/proxy-authentication/

Have you seen this post: https://support.mozilla.org/en-US/questions/926378 It seems that with some proxy services/protocols, you may need to change the following preferences in about:config * network.automatic-ntlm-auth.allow-proxies * network.negotiate-auth.allow-proxies This extension may also help: https://addons.mozilla.org/en-US/firefox/addon/proxy-authentication/
Размещено

Задавший вопрос

Yes Cww, I have already tried that to no avail.

Yes Cww, I have already tried that to no avail.
cor-el
  • Top 10 Contributor
  • Moderator
17526 решений 158463 ответов
Размещено

Does it work if you go to the proxy login page and use http://username@xxxx.com or the IP variant http://username@xxx.xxx.xxx.xxx

Does it work if you go to the proxy login page and use http://username@xxxx.com or the IP variant http://username@xxx.xxx.xxx.xxx
jedibrat 0 решений 1 ответов
Размещено

This is a really nice try, but after changing these settings in about:config and restarting I still get the prompts of the type:

The proxy moz-proxy://XXX is requesting a username and password. The site says: "moz-proxy://xxx".

...that will repeat infinitely until I hit cancel.

I have tried a few other about:config changes but nothing has yet worked.

This is a really nice try, but after changing these settings in about:config and restarting I still get the prompts of the type: The proxy moz-proxy://XXX is requesting a username and password. The site says: "moz-proxy://xxx". ...that will repeat infinitely until I hit cancel. I have tried a few other about:config changes but nothing has yet worked.