Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

logos in the bookmarks toolbar keep reappearing when i save an image

  • 16 ответов
  • 1 имеет эту проблему
  • 322 просмотра
  • Последний ответ от alan_r

more options

I have removed all logos from my bookmarks toolbar (which is way too complicated to do btw) Since installing the new Firefox, whenever I save an image from a site (which is part of my job) all these stupid logos pop-up in my bookmarkbar. When I quit and restart firefox they are gone, but as soon as I save another image they're back again.

I thought this was bc of that stupid animated download arrow you added in the toolbar but I have removed that and these stupid logos still reappear whenever I save an image.

Help would be much appreciated.

Выбранное решение

I can only test on Windows, and both cor-el's rule and the 3-rule set from the other thread work for me. Maybe it would help to download the userChrome.css file and save it into that folder?? Here's a link if you want to try that: http://jeffersonscher.com/res/userChrome.css

Прочитайте этот ответ в контексте 👍 0

Все ответы (16)

more options

Whenever you load the webpage the logo's are loaded from the website server.

more options

Thanks, but is there a way i can stop this from happening?

(btw didn't mean to sound so grumpy, but the site was giving me a hard time to register)

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

Did you set these prefs to false on the about:config page?

  • browser.chrome.favicons
  • browser.chrome.site_icons

more options

Sorry for the late reply. I made a screenshot of firefox when i start it up and a second one of what happens when i save an image.

As you probably can imagine i don't need the websites logos taking up place in my toolbar. Any help is very much appreciated!

more options

What method are you using to suppress the icons on the Bookmarks Toolbar?

Is that done via an extension that may have been broken or via other means like code in userChrome.css?

more options

For the record, those logos, or site icons, are known as "favicons".

Due to the changes with private windows in Firefox 20, the Bookmarks Deiconizer extension isn't working properly any more. However, the extension's author has a page describing how to create a style rule to achieve the same effect. While it's a challenge to set up, it should then work from that point forward and not have to be repeated. http://antennasoft.net/robcee/2012/04/20/bookmarks-deiconizer-userchrome-edition/

We've had similar suggestions here in the past, too, such as: How to fix bookmark icons from reappearing in new browser windows despite having bookmark deiconizer enabled (Mac Snow Leopard/Firefox 20.0).

more options

You can use this code if you want to keep the icons for folder items.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#personal-bookmarks .bookmark-item:not([container]) .toolbarbutton-icon{
 display:none !important;

Add the code to the userChrome.css file below the default @namespace line.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

more options

Wow, I guess this is getting a bit too complicated for me. I'm not sure how I initially managed to disable the flavicons (thanks jscher2000, I always keep forgetting what those things are called) I googled the roblem and found an answer that worked.

Now I am trying to do what is suggested by ~robcee in jscher2000's link but in my profiel there is no folder called "userChrome.css" I'm really quite surprised there isn't an easier way to turn this off.

more options

Hi aapstra, you can create the file userChrome.css, it's just an ordinary text file. (A blank userChrome.css file isn't included with Firefox because all the style rules are built into the product.)

more options

Okay, so I've opened a new file in Tex edit, I saved it as userChrome.css in my Firefox profile folder and inserted the text:

"scrollbox#PlacesToolbarItems > toolbarbutton.bookmark-item > .toolbarbutton-icon {

 display: none;


As suggested in ~robcee's article you linked to. But the flavicons are still reappearing whenever I save an image, did I do something wrong? (I did restart firefox after doing this, still no luck)

(I'm sorry if I sound ignorant, I'm really not a tech-oriented guy but man these flavicons annoy me!)

more options

Two things come to mind:

  • You might not have created the additional folder, which needs to be named chrome. So inside your profile folder, a new folder named chrome, then the userChrome.css file inside it.
  • At the top of the file, you need a namespace statement. cor-el included that in the rule a few replies up but I just noticed that the article does not mention it.
more options

Hmmm, you are right I didn't create that folder. But now I did. So in my profile folder, I now have a folder named chrome (in my actual profile folder, right? The one that has a lot of items including (e.g.) healthreport) and in that chrome folder I have my userChrome.css file.

I have copy-pasted the information from cor-el's post in to my userChrome.css. (all of it, so I have replaced robcee's info) it now reads:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

  1. personal-bookmarks .bookmark-item:not([container]) .toolbarbutton-icon{
display:none !important;


I saved it, quit Firefox and restarted. And the flavicons keep reappearing...

more options

Выбранное решение

I can only test on Windows, and both cor-el's rule and the 3-rule set from the other thread work for me. Maybe it would help to download the userChrome.css file and save it into that folder?? Here's a link if you want to try that: http://jeffersonscher.com/res/userChrome.css

more options

Are you using the default theme?

(note that Safe Mode disable userChrome.css and userContent.css)

more options

@cor-el, yes I am using the default theme. But my problem has now been solved by downloading that link from jscher2000! Not sure why it didn't work initially, it's probably me.

Thank you guys so much, it's just this stupid little thing but it was really bothering me. Thanks for all your time and support!

more options

You might be familiar with the following or have not chosen this path. Others could be interested.

Just some basic ideas that would help give you more toolbar space -

  • Where you are familiar with the favicon you can use that instead of the name. (Right click on the bookmark and in Properties abbreviate or delete the name.) Many of your favicons are obvious and this would give you a big gain in space.
  • You can group bookmarks in folders with a short name.(Right click on the toolbar and create a new folder. Move bookmarks into a relevant folder). You don't seem to use folders - an extra click but another big gain in space.
  • I presume you realise that the full toolbar spills over down the right side of the screen. Click on the chevrons(arrowheads >>) at the end of the toolbar. I have no idea what the limit of this overflow is but it's quite a lot.

Again an extra click but more space. You can use folders and use full names with your favicons in this area.