Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Эта тема была закрыта и архивирована. Если вам нужна помощь, задайте новый вопрос.

Can't download files because Firefox keeps asking for consent and there isn't an ALLOW button anywhere

  • 87 ответов
  • 469 имеют эту проблему
  • 187 просмотров
  • Последний ответ от the-edmeister

more options

Everytime I try to download a "large" file Firefox keeps asking me:

Firefox needs your consent to download large files. Please click ALLOW to continue your transfer.

If you cannot see the request, please click on the icon next to the address bar.

I didn't have this kind of troubles before until the new version, I'm so frustrated that I'm really thinking to switch to Chrome instead.

And in case someone wonders, there isn't a request icon at ALL.

Изменено NoahSUMO

Выбранное решение

Все ответы (20)

more options

2nd image above

Изменено brownieb

more options

Hello to you all,

I have the same problem, this "solution" is not working for me, so I think I better go with Chrome, I'm very tired of Firefox 21 problems...Firstly they changed the download mode, now this problems with Mega (Previous versions of Firefox worked fine, what has happened with this version?).

Sorry but this is my last problem with Firefox, I'm going to install and use Chrome. Ok, installed and tested, no problems at all, where Firefox is unable to work (with Mega), Chrome is working with no errors. Until Firefox don't solve those problems, I will be a Chrome user.

Good luck Firefox, hope to see you soon.

more options

Hello jscher2000,

Can't be a Quota problem as I never fixed a HD quota and I have the same problem.

I'm going to reinstall a previous version version of Firefox in order to see if this solves the problem... And I'll come back asap to posts the results.

more options

Hello to you all,

As I promised, I'm here with the solution (at least for me). I have checked my "Maintain offline storage" and neither with this option checked or uncheked worked...So I went to my "Options" menu and put an eye on my options...Well I limited my cache to 50MB and tried again...Didn't work but the error message lasted a few seconds more to pop-up and then I can close it (before I changed my configuration, this message can't be closed).

This gave me an idea and I unchecked:"Tell websites I do not want to be tracked" and "Always use private browsing mode". Then goto "Advanced" and check that "Tell me when a website asks to store data for offline use" is checked, so it will force Mega to ask you about to store those 50 MB's again, the first time after changing your config, this error will pop-up again, but also the message asking for permission to store the 50 MB's answer "Allow" and this problem will be history.

Hope this will be of any help for you.

Best regards to you all.

more options

You can also inspect the permissions in "Tools > Page Info > Permissions" when a tab with the Mega site is selected.
That would show that the offline cache is used and you can clear that data to make Firefox prompt you the next time.

more options

Hi Cor-el,

I did it many times with no results, that's why I started a complete check, it was a little bit harder, as you have to check everything, but it finally worked.

Best regards.

more options

Ok.. so i hope it is very funny for you to lie to all those people.. for me not and thats the reason to make you a super great advert to all people.. started posting on Faceook with "FAN" page showing how incompetent people you are and why to NOT use your browser.. many of my friends asked me all the day if i foun something and all of them deleted this s*itty not working product..

Spent almost 2 hours (fu*king expensive 2 hours) trying to find out how to repair this stupid imbecile BUG (maybe somebody of you will call this BUG a security addon) and nothing helped.. so.. deleting the s*ited-non-working + hundrets of MB RAM stealing Firefox and goin to Chrome probably..

Die you all.. close the company and let the worl forget youve ever existed...

3) On the "Maintain Offline Storage" section, leave 'Use Default' clicked and 'Allow' radio button selected, but click the "Clear Storage" button.

- No.. theres really NONE of those clear buttons.. so make a jokes from somebody else.. - No.. no matter what Ill do there.. every time i open download page again the settings is again on its default - Changes in DB size dont help either.. cant download even 1MB file..

Изменено Maxtor_EU

more options

Hi Maxtor_EU, first of all, I don't appreciate you wishing all the participants in this thread to die. Really, it's just a web download. Please have a sense of proportion here.

Second, I'm sorry to hear this site isn't working for you despite trying the solution. A later posted noted that private browsing may not work with this site. Can you check that suggestion as well? https://support.mozilla.org/questions/960444?page=2#answer-449236

Or, just use a different browser for mega.co.nz until this is solved.

more options

OK.. sry for that.. but FF really got me angry this time.. why have every company theese days got to destroy their SW products as most as possible with things called updates. Updates have to update the application.. not complicate everything to users and not to block their services..

And like I said.. spent almost 2 hours reading almost everything that google and this forum found without a chance to repair this BUG (or lets say update).. Private browsing off.. I tryied almost everything written here and no chance to move on (half of this resolutions is totaly wrong for me, cause i cant see buttons that should be here - advanced settings changes didnt help either)..

The other thing is, that I want to use a web browser.. not 10 web browsers cause of services I use.. dont try to tell me this is a functionality.. all those services using this way of downloading will really not change cause of FF want to do it other way.. :/

Изменено Maxtor_EU

more options

Hi Maxtor_EU, this is a very "cutting edge" way to download files, but there's a good chance more sites will use this method in the future, so we should try to figure it out. Maybe over the weekend I can experiment with the site some more and try to figure out the right combination of settings.

more options

OK.. :) Like I said.. sorry for the first agression, but I got really angry after those 2 hours without a resolution of this problem.

It was like everything in las few months/years. Nero is now a crazy multimeda slowing down app instead of DVD burner, PowerDVD the same.. instead of few MBs and great DVD playback app Its a crazy big annoying pack of everything that you will never use.. now it looks like it starts with FF too.. :)

OKOK.. sry for my first post and Ill wait if something will change in future..

Изменено Maxtor_EU

more options

Hi again Cor-el,

With the Mega page loaded, nothing worked for me (I don't know why), that's why I have to did it with the Mega page closed and "playing" with the "Options" menu. But it doesn't matter the only important thing is the fact that I can again download from Mega. On the other hand, there's a new version of Firefox available (Firefox 22) perhaps this version solve this problem but if it's not, why have two methods (at least) to solve it ;-) . So... No worries at all !!!!

Hello Maxtor_EU,

You are allowed to say what you're saying now, but you're not allowed to say they are lying, wishing people to die, or such kind of things, they are trying to give an answer, a solution, the least that you can do, is to be grateful for that. They are persons like you or me, who have a private life (a life out of this forum, you know), but kindly they pass their time helping others, don't forget that.

Did you see my solution? The solution they gave, didn't work for me, but instead of saying:"All of you are lying, and...." I went into positive, and tried to find a solution by myself, and I managed to do it.

Ok, it's very irritating trying to download a file and can't do it, but you can accept that it's only an error that can be solved (all that fails can be repaired) and try to do it, or you can waste your time with no positive actions and comments, it's a personal election.

Read my last post before this, there, you can see how to solve this problem, it worked for me, try it, please, and then say if this worked for you too or if it's not, ok? If it's not we'll try to find another solution for you, right?

Best regards to you all.

Изменено Noobsaibot73

more options


No chance.. nothin happened.. I cant close the window even with the hammer.. :) Ive updated to v22 right at the moment it was released.. now Im a bit suprised youre saying that about versions because all those problems started right after the v22 update on my side.

The second thing is, that there are really only few people having a private life.. really, no matter how secure will FF be.. getting into an ordinary PC of an ordinary user is just a matter of minutes.. :)

Idont mean it in some bad way now, but most of those SW securities integrated into everything in last years are just waistless things complicating customers life.. it will not help to anybody because most of the users have many other insecurities in their PCs with much more easier way to get in.

On the other side.. yeah.. the truth is, that backround downloads and web sites are often used to inject and tracking users but on the other side, those guys knowing nothing about security will click and open sites and buttons they should not anyway.. and thats why Im saying that no securities will help.. most of injected PC are here because of user incompetence or how to say it.. no matter how secure products are used in their PCs.. :(

Изменено Maxtor_EU

more options

Hi Maxtor_EU,

Ok, try this, go back to V21, and then just do what I did...This should solve the problem.

You can use this link or this other:

Link 1:


Link 2:


Download the previous version that worked for you and do what I said, your Firefox should now download from Mega with no problems.

On the other hand this could be a problem for the V21 and V22 versions...If Firefox take care of this and should take, I think this problem will soon be gone.

I don't think so, it's true that many security options implemented in actual software could mean a great problem (many times), but by the way, the times those security options protect your computer are by far, more.

Problems arises, it's life, if we have personal problems and computers (and software) are made by humans, it's very clear that problems will arise, perhaps not today or tomorrow, but one day will come, the only thing you can do it's to accept that and be ready as much as you can, and put a smile on you face instead of getting angry and frustrated.

Try that, go back to V21 and do what I did and take it easy, I'm here and I will help you as much as I can.

Best regards.

more options

If ill go back one version i dont need to do anythin, cause Mega works for me without any problem.. so thats what ill do probably.. wait on 21 till another update and well see what happen..

more options

Hi again,

Really? I was on 21 but one day, no way to download from Mega...I reinstalled and changed those options and this works for me again.

I'm going to upgrade to V22 to see if the problem arises again and if I can solve it again.

Well perhaps is not the best possible solution, but it's a solution and if it works for you, it's a good one ;-)

Best regards to you all.

more options

I don't know who pick the "solution" but I'm sure as hell it wasn't me, the problem IS NOT SOLVED, the so called "solution" DOESN'T WORK AT ALL, and the problem IS STILL THERE, so please stop trying to mislead people and actually give us a real working solution, I post this more than a month ago and I'm still waiting for a fix.

more options

Hello Redsteel can you pass me a "Mega" link, I'm now on version 22 and I want to test if the problem persists.

Best regards.

more options

I have this problem since I upgrade to version 22.0, and nop, I don't have at the moment a mega link that I can share for now...

more options

Had this problem until I took it off of "private browsing mode" Then I have the allow option. Then I was allowed to download with no issue. When I was done, I turned the private back on. A bit of an irritation but I like FF better than any of the others.

This is all form MEGA of course. I've not had any issue with any other site. But taking FF out of PRIVATE mode I was allowed to get all of the files I needed.

Just too see, I turned PRIVATE back on, tried to get the same 3 files and was denied. So it seem to be the fix for getting stuff from MEGA

Изменено JJ

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5