Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

The down key doesn't scroll the page on some web sites. How can I make it scroll on all web sites?

  • 14 ответов
  • 13 имеют эту проблему
  • 15951 просмотр
  • Последний ответ от davidmaxwaterman

more options

Viewing these pages at suppose.mozilla.org in firefox 21, I can use the down key to scroll the down. However, this is not true for some web pages. For example, github pages :

<https://github.com/bower/bower>

pressing the down key no longer seems to scroll the page down. I've not tested it, but I'm fairly sure I used to be able to scroll with just the keyboard.

Изменено davidmaxwaterman

Выбранное решение

The problem was solved by patching the Pentadactyl add-on. The patch is here :

http://code.google.com/p/dactyl/issues/detail?id=992

but I guess it'll find its way into a released version of Pentadactyl at some point.

Прочитайте этот ответ в контексте 👍 0

Все ответы (14)

more options

They work for me, but you can make a Greasemonkey script to make it work.

Make a Greasemonkey script and put this piece of code in it:

window.addEventListener('keydown', function( e ) { if( e.keyCode == 40 ) { window.scrollTo( window.scrollX, window.scrollY + 25 ) } });

Increase 25 if you want it to scroll a longer distance.

http://alwaysbetonjs.com/

Hope it helps. :D

more options

Click the orange Firefox button, go to Options | Options | Advanced and in the General menu, checkmark the option called "Use smooth scrolling".

If it's already checked, but doesn't appear to improve matters, install this add-on: https://addons.mozilla.org/en-US/firefox/addon/smoothwheel/ It should make a difference even though you have a laptop.

more options

It seems there is a bug in this forum code so it includes a '>' in the URL :/

Let me post it without the *standard* URL delimiters :

https://github.com/bower/bower

@Mahdi: Does the above 'work for you'?

@Mahdi: I'm not interested in using greasemonkey, sorry.

@GeekInside: You seem to be assuming I'm using Microsoft Windows? I should have mentioned that I am using ubuntu. I don't have any 'orange firefox button' on Ubuntu....but I've tried looking at the same option in ubuntu and it is already enabled. I'm not interested in using an addon.

@all - all I want is the same behaviour as before the upgrade to v12 - ie to be able to use the up button for all web pages.

more options

@david: I'm also on Ubuntu, I don't know why it doesn't work for you, up and down buttons work well for me on GitHub and / or any other web page.

Some suggestions:

Options -> Advanced -> General:

Uncheck 'Always use cursor keys to navigate withing pages'

Open about:config and search for scrollbox, check if toolbox.scrollbox.verticalScrollDistance is more than 0, something like 3.

Изменено Mahdi Dibaiee

more options

Ha, interesting...I went to the Advanced/General tab, and 'always use cursor keys...' option wasn't checked, so I checked it and closed. No change in behaviour. I went to the Advanced/General tab again, and it was again unchecked....seems the setting hadn't 'stuck'.

odd.

verticalscrolldistance is 3, yes.

I'm starting to think this is a bug in the latest version...you're using the latest, right? It only updated this morning.

...or perhaps an unexpected interraction with one of my extensions.

more options

Now that's the point, yes, I updated it today morning.

Did you let Firefox check comptability of your add-ons with this version?

As I read, you can enable / disable 'Always use ursor keys to navigate within page' with F7, too, if that doesn't work, too, open up about:config and search for 'caret'

set accessibility.browsewithcaret to 'false', the last hope! :D

more options

You may have switched on caret browsing.

You can press F7 (Mac: fn + F7) to toggle caret browsing on/off.

  • Edit > Preferences > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages"

more options

Sorry, but it seems not to be this caret browsing thing.

Note that I can scroll up/left/right, just not down, and even with down, it is only for some web pages and not even consistent on those.

Facebook is another page that seems to show the problem, most of the time. However, github is the most consistent, imo.

more options

Reading that 'scrolling with arrow keys no longer works' page, I notice that 'page down'. 'home' and 'end' also don't work - 'page up' works though.

more options

The browsewithcaret option is already set to false.

I retried setting the 'always use the cursor keys to navigatr withing pages' option, again. This time it seemed to 'stick' - that is, when I went straight back into the options, it was still set. However, if I click on this page, and then look back at the options, it is disabled again.

I think this is some odd interaction with one of my extensions - probably pentadactyl. I'm going to try launch ff with them disabled and then enable them one-by-one, starting with pentadactyl.

more options

Yes, as I suspected (eventually), the problems disappear when I disable pentadactyl, so I guess there is some issue with it and the new version of ff. I'll see if there's an issue already for pentadactyl and open one if there isn't.

more options

I found other people with similar/same problems, so I'll take this to the pentadactyl issues page - there are a couple, but here's one :

http://code.google.com/p/dactyl/issues/detail?id=972

thanks for all your help, all of you...

Изменено davidmaxwaterman

more options

Are you using code in userContent.css?

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used (localstore-safe.rdf)
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
more options

Выбранное решение

The problem was solved by patching the Pentadactyl add-on. The patch is here :

http://code.google.com/p/dactyl/issues/detail?id=992

but I guess it'll find its way into a released version of Pentadactyl at some point.