Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

How do I stop Firefox from redirection to my ISPs website when I enter my own website's URL?

  • 4 ответа
  • 6 имеют эту проблему
  • 2061 просмотр
  • Последний ответ от PaulMy

more options

On new computer with Windows 8 Firefox works fine for all URLs except when I enter one of my own websites - 'www.komokaweather.com' which is redirectsed to my ISPs site 'http://www.rogers.com/web/Rogers.portal'. It is ok when I enter as 'www.komokaweather.com/index' as well as 'www.komokaweather.ca' and all other addresses but not as just 'www.komokaweather.com'. I have tried on making 'www.komokaweather.com' as Home Page but that does not work either.

I have also upgraded to v.19.0.2 but no change. Paul

Выбранное решение

You can remove all stored data from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar) or via the about:permissions page.

Using "Forget About This Site" will remove everything like bookmarks, cookies, passwords, cache, history, and exceptions from that domain, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks. You can't recover from that "forget" unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


You may have an ISP that automatically redirects you to a search page if a DNS look up fails.
That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.
In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.
You can also check if there is a link on the search results page to go to your ISP and opt-out.

Прочитайте этот ответ в контексте 👍 2

Все ответы (4)

more options

is this happening with other browsers on the same machine too?

more options

No, IE explorer works fine. Only on FF and for that one particular URL

more options

Выбранное решение

You can remove all stored data from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar) or via the about:permissions page.

Using "Forget About This Site" will remove everything like bookmarks, cookies, passwords, cache, history, and exceptions from that domain, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks. You can't recover from that "forget" unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


You may have an ISP that automatically redirects you to a search page if a DNS look up fails.
That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.
In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.
You can also check if there is a link on the search results page to go to your ISP and opt-out.

more options

Thank you for the responses. Now it is working ok.