Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Awesome Bar: auto-complete suggestion does not remember port number from URL

  • 2 ответа
  • 6 имеют эту проблему
  • 18 просмотров
  • Последний ответ от noregistrationplease

more options

I visit URLs with non-standard ports all the time such as http://localhost:8080.

When I start typing "localhost" into the address bar, the Awesome Bar suggests only "http://localhost" - i.e. WITHOUT the port 8080 - instead of suggesting the full URL including the port.

I never visit "localhost" without port 8080 so that entry should not even be in my history at all.

The Awesome Bar should always remember port numbers when making suggestions.

Все ответы (2)

more options

hello, as a workaround you could try to bookmark those addresses & see if they will be included in the auto-complete suggestions this way.

more options

Unfortunately that doesn't work. Even with the URL bookmarked, typing "local" to begin the autocomplete still results in the URL being auto-completed without a port number.

Typing the name of the bookmark itself results in no auto-complete at all, meaning you still have to press the down arrow before hitting "return" to get to the correct URL. So you're back at square one.

I filed a bug here: https://bugzilla.mozilla.org/show_bug.cgi?id=853898

Which turned out to be a duplicate of: https://bugzilla.mozilla.org/show_bug.cgi?id=764062