Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Why is the 'Stay Signed In' check box always checked by default before I sign into my Gmail account?

  • 10 ответов
  • 9 имеют эту проблему
  • 9020 просмотров
  • Последний ответ от mathjo20

more options

Hi there,


I have a major/minor pet peeve that's been bothering me for years now. Too bad that it's only now that the idea of asking for help online crossed my head today. I guess that says something about me.


Well, you see, I always check my mail (Gmail) everyday after entering "private browsing". After I enter my username & password, I always uncheck the 'Stay signed in' box, before I press ENTER.


Yes, yes, I know that 'cause I'm in private browsing mode, that there's really no need for me to do that. But you see, it bugs me for no reason. That is why I admitted beforehand that I had a PET PEEVE.


So is there anyway for me to play with my account settings so that the box is unchecked automatically for me by default from now on?

Thank You!


I've asked this same question in the Google Help Forum and they've suggested that it could be due to anyone of the firefox addons that I've installed

Well, atleast here's the link to that discussion... http://productforums.google.com/forum/#!topic/gmail/7m2LlSN6Aag/discussion


Somebody please help me!  :-(

Все ответы (10)

more options

hello, the default setting of this checkbox is determined by google in the source-code of the webpage - see screenshot.

more options

So, would you know about a permanent solution to fix this?

Is there any way I can set it up so that the check box is always blank by default?

more options

as an alternative i would have suggested to set firefox to keep cookies only until you close the browser in the privacy options - but when you're already using private browsing mode it will make no difference whatsoever. when the checkbox on the log-in page is unchecked then google will only set cookies that expire at the end of the session, in private browsing mode you're already doing the same for all pages.

this is a merely cosmetic issue. if you really that bugged by it, i'd use adblock plus to hide this element by adding the filter:

accounts.google.com#label(class=remember)

http://adblockplus.org/en/filters

more options

You can do the same with code in userContent.css or Stylish

@-moz-document domain(accounts.google.com){ label.remember { display:none!important; } }

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder.

more options

Ooh, I can see the finish line!


So by creating that filter in AdBlock Plus, am I setting the Google Sign In Box to always remain unchecked by default? Or is ABP just making such a box non-existant (disappear), in other words, I wont see such a box at all (checked or unchecked)?

Also see, I want the settings to be the same for regular and/or private browsing. Say in case I accidently checked my email forgetting to view it under "Private Browsing"


And lastly, (jeez, I feel like such a newbie)...

...could you please give me baby steps as to how I set up the filter you provided using AdBlock Plus? I'd read the link you provided. It totally went past my head. I even tried selecting "Filter Preferences", copied that specific filter and pasted it under "Custom Filters". No Good.


I'm literally 10 feet away from crossing the rope.

Help!!!

more options

adding the filter in adblock will just hide the whole "stay signed in" checkbox. when you have the extension installed press ctrl+shift+f this will open the filter box for adblock - in there change to custom filters & add filter group (in case you have never added a custom filter before). you can assign this new group any name you like - on the right end of it click actions > show/hide filters and then add filter on the top right. in there enter the line

accounts.google.com#label(class=remember).

for the case you once forget to enter private browsing mode you can take the following precaution: while your on the login page, right-click the page & select view page info > permissions where you can set the cookie preferences for the google site to only allow for session.

more options

Thank you so much for the help madperson.

You're not mad at all.

more options

you're very welcome ;-)

more options

I'm having the same problem, except I don't use Private Browsing. I have my FF set to delete absolutely everything every time I close Firefox, (and I'm fairly trigger-happy with the Ctrl-Shift-Del too), so I don't think it's a cookie or cache issue.

I tried going to Gmail in IE too (which I never use), and the checkbox was still checked by default. I think it's a Gmail thing.

I followed the steps in Adblock Plus mentioned by madperson and now I don't see the "stay signed in" checkbox at all. If I'm interpreting your post correctly, I think this is what's supposed to happen. I just have one question. Is the (now invisible) checkbox behaving as though it's checked or behaving as though it's unchecked? I'd like the default behavior to be "unchecked", regardless of whether the box is visible.

Thanks.

more options

Well, isn't that the catch?

If I haven't misunderstood, the check box will be checked. But the AdBlock Plus route will just make the box "invisible" to you.

This is totally a cosmetic issue to be honest.

In the end, just make sure that you're either private browsing or set-up your Firefox options to delete all caches, cookies, history after closing the browser.