Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

why has firefox started assuming i am requesting secure connections for all websites and disabled scripting and styling on the ones I can access?

  • 4 ответа
  • 3 имеют эту проблему
  • 1 просмотр
  • Последний ответ от terrell-miller

more options

I have happily been a user of firefox for six months. after downloading the beta version, several "bad" things have been happening. Most web page requests (eg, to firefox help, google.com) result in the message that I have requested a secure connection and the site does not have a valid certificate. When I then add that site to the exceptions sites, the page loads but only the html -- no script no styles- just like the old days. Further, after uninstalling (plus erasing all personal data in the process) and reinstalling version 18 I get the same behavior plus in the only case I have attempted my log ins to wsj.com's subscriber site hang-presumably from scripting issues. Furthermore, I could not access this and previous help pages while on firefox -- this query is utilizing the evil ie9 to gain access.

Выбранное решение

For ESET see:

  • ESET setup -> advanced setup -> extend web and email tree -> SSL
  • SSL protocol: Do not scan SSL protocol

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

Прочитайте этот ответ в контексте 👍 2

Все ответы (4)

more options

This Firefox support site and the default Google search plugin do indeed use SSL connections. It's for privacy and to reduce impersonation risks.

When you have certificate errors on many different sites, there are a few possible system-wide issues to check.

First, time and date, since those are used in checking certificates.

Second, security software that filters secure connections. If you run Bitdefender, see: this connection is untrusted.

Third, new/changed/unexpected proxy services. You can check for these here:

orange Firefox button or classic Tools menu > Options > Advanced > Network > "Settings" button

more options

thanks for trying but still looking for help. 1) date and time on my computer match naval time from boulder as per my "atomic" clock. 2) I don't have Bitdefender -- I use ESET internet security. 3) I changed the settings to "automatically detect" to be the same as in ie9. Nothing changed; but a question about that. what should i set them on (i am on a dsl line with att) if that is not right?

more options

Выбранное решение

For ESET see:

  • ESET setup -> advanced setup -> extend web and email tree -> SSL
  • SSL protocol: Do not scan SSL protocol

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

more options

Ok checked ESET and this is the case. So how do I fix the problem. What makes this confusing is that none of this happens on another machine that I have on the network, both are HP's, one a desktop (the problem one) and one a laptop. Both are windows 64 home premium systems; have ESET loaded; and Mozilla 18.01. As near as I can tell the security settings are the same. The one thing that is different that I know of is that the desktop had the beta test version loaded at one time(and that is when the problem began). Still looking for ideas and thanks for helping.