X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Enabling Cookies doesnt work

Размещено

Every time I enable cookies (set it to custom enable) and I press ok, it didnt change. I go back into options and the information didnt change. I thought that the plugins had something to do with this so I tried browsing in the same site with all of the plugins disabled but that didnt work. Every time I press ok to change the cookies information, it just goes back to default whenever i go back into the options menu.

Every time I enable cookies (set it to custom enable) and I press ok, it didnt change. I go back into options and the information didnt change. I thought that the plugins had something to do with this so I tried browsing in the same site with all of the plugins disabled but that didnt work. Every time I press ok to change the cookies information, it just goes back to default whenever i go back into the options menu.

Дополнительные сведения о системе

Установленные плагины

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Pando Web Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • NPWLPG

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

Дополнительная информация

dumdidadida 155 решений 1440 ответов
Размещено

Hi,

Please see Preferences not saved.

Hi, Please see [https://support.mozilla.org/en-US/kb/Preferences%20are%20not%20saved Preferences not saved].
thetechlady 2 решений 18 ответов
Размещено

Basically it doesn't work, and Mozilla obviously doesn't think it's important enough to fix it. I deleted all my cookies and flushed the cache with no effect. Thanks for nothing, Mozilla.
However, I may have found a workaround. I go to "Tools" then "Options" and choose "Privacy." If I just change it to "use Custom Settings," it doesn't work. "Remember history" always shows, no matter how many times I change it. However, I found, if I make a change within "Use custom settings," such as specifying "Keep until : Ask me every time," Then my new setting stays.
Unfortunately, some web sites still get cranky about Firefox cookies, especially Amazon, which does not recognize the change no matter how many times I do it. Because I like to buy things from Amazon, I'm switching to Chrome. I've waited long enough for Mozilla to fix this.

Basically it doesn't work, and Mozilla obviously doesn't think it's important enough to fix it. I deleted all my cookies and flushed the cache with no effect. Thanks for nothing, Mozilla. <br> However, I may have found a workaround. I go to "Tools" then "Options" and choose "Privacy." If I just change it to "use Custom Settings," it doesn't work. "Remember history" always shows, no matter how many times I change it. However, I found, if I make a change within "Use custom settings," such as specifying "Keep until : Ask me every time," Then my new setting stays.<br> Unfortunately, some web sites still get cranky about Firefox cookies, especially Amazon, which does not recognize the change no matter how many times I do it. Because I like to buy things from Amazon, I'm switching to Chrome. I've waited long enough for Mozilla to fix this.

Изменено thetechlady

cor-el
  • Top 10 Contributor
  • Moderator
17578 решений 159011 ответов
Размещено

If you see "(Never) Remember History" then that means that all history and cookie settings are set to the default values and thus cookies are enabled.
The "Use custom settings for history" choice allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings.
Firefox shows the "Use custom settings for history" selection as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.
If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".

If you see "(Never) Remember History" then that means that all history and cookie settings are set to the default values and thus cookies are enabled.<br /> The "Use custom settings for history" choice allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings.<br /> Firefox shows the "Use custom settings for history" selection as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.<br /> If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".<br />