X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

How to disable video file (mkv) preview preview in firefox?

Размещено

Before update i was able to click on link then just push "enter" and it was downloading, now i cannot do that, i need to use mouse save url.

How to disable video file preview in new firefox?

Before update i was able to click on link then just push "enter" and it was downloading, now i cannot do that, i need to use mouse save url. How to disable video file preview in new firefox?

Изменено kolorafa

Дополнительные сведения о системе

Установленные плагины

  • Shockwave Flash 11.5 r502
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.10411.0

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0

Дополнительная информация

dumdidadida 155 решений 1440 ответов
Размещено

Hi,

You can try setting plugins.click_to_play to true in about:config for media rendered by plugins ('Tools (Alt + T) > Add-ons > Plugins.)

about:config Entries

The Config Descriptions add-on adds helpful source comments in about:config.

Hi, You can try setting '''plugins.click_to_play''' to '''true''' in [http://kb.mozillazine.org/About:config about:config] for media rendered by plugins ('''Tools'' ('''Alt''' + '''T''') > '''Add-ons''' > '''Plugins'''.) [http://kb.mozillazine.org/About:config_entries about:config Entries] The [https://services.addons.mozilla.org/en-US/firefox/discovery/addon/config-descriptions/ Config Descriptions] add-on adds helpful source comments in about:config.
Размещено

Задавший вопрос

No luck :| but it only occurs with .mkv files, not with .avi or .mp4

My only plugins that are active are: flash, silverlight, java

No luck :| but it only occurs with .mkv files, not with .avi or .mp4 My only plugins that are active are: flash, silverlight, java
dumdidadida 155 решений 1440 ответов
Размещено

Please also try setting media.autoplay.enabled to false.

Please also try setting '''media.autoplay.enabled''' to false.
cor-el
  • Top 10 Contributor
  • Moderator
17697 решений 160138 ответов
Размещено

You can set the Boolean pref browser.altClickSave to true on the about:config page.

This will allow to always save a link if you hold down the Alt key and left-click the link.


Try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions.


You can set the Boolean pref <b>browser.altClickSave</b> to <i>true</i> on the <b>about:config</b> page. *http://kb.mozillazine.org/about:config This will allow to always save a link if you hold down the Alt key and left-click the link. * https://developer.mozilla.org/en/Mozilla/Preferences/Preference_reference/browser.altClickSave ---- Try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions. *http://kb.mozillazine.org/mimeTypes.rdf *http://kb.mozillazine.org/File_types_and_download_actions#Resetting_download_actions ---- *https://support.mozilla.org/kb/change-firefox-behavior-when-open-file
Размещено

Задавший вопрос

media.autoplay.enabled Doesn't change anyting, just doens't start playing (but it even cant ;)

i did also disable all media.* but that affected only with that when i click on media url (*.mkv) browser just reacts and he don't try to play it and don't try to download, just nothing :|

in FileTypes (in options) there are any media file switches, only flash and podcast/rss.

Removing mimeTypes.rdf did not change anything.

browser.altClickSave - when i hold alt it will download it, but i don't want to download it using FF but i want to get that "Open using/save" window (where i have "download using FDM")

media.autoplay.enabled Doesn't change anyting, just doens't start playing (but it even cant ;) i did also disable all media.* but that affected only with that when i click on media url (*.mkv) browser just reacts and he don't try to play it and don't try to download, just nothing :| in FileTypes (in options) there are any media file switches, only flash and podcast/rss. Removing mimeTypes.rdf did not change anything. browser.altClickSave - when i hold alt it will download it, but i don't want to download it using FF but i want to get that "Open using/save" window (where i have "download using FDM")
dumdidadida 155 решений 1440 ответов
Размещено

If FDM is an Extension in Firefox Tools (Alt + T) > Add-ons, you can try to adjust it's Options to intercept .MKV files. If it is an external application you can try to adjust it's options for .MKV via the Windows start menu and run FDM along with Firefox and check. Alternatively you can also try to set browser.download.hide_plugins_without_extensions to false in about:config, and change the Action for all instances of matroska in Firefox Tools (Alt + T) > Options > Applications.

Managing file types

If FDM is an '''Extension''' in Firefox '''Tools''' ('''Alt''' + '''T''') > '''Add-ons''', you can try to adjust it's '''Options''' to intercept .MKV files. If it is an external application you can try to adjust it's options for .MKV via the Windows start menu and run FDM along with Firefox and check. Alternatively you can also try to set '''browser.download.hide_plugins_without_extensions''' to '''false''' in about:config, and change the '''Action''' for all instances of '''matroska''' in Firefox '''Tools''' ('''Alt''' + '''T''') > '''Options''' > [https://support.mozilla.org/en-US/kb/Options%20window%20-%20Applications%20panel?as=u Applications]. [https://support.mozilla.org/kb/Managing+file+types Managing file types]
Размещено

Задавший вопрос

FDM is a program, but i use "xThunder" Add-On that puts selection in Download dialog.

In "Tools (Alt + T) > Options > Applications. " i only have 10 rows, and every one is on "always ask", none of them is mkv, matroska o even media/video

I did change browser.download.hide_plugins_without_extensions to false but only shockwave/java/silverlight mime appear

FDM is a program, but i use "xThunder" Add-On that puts selection in Download dialog. In "Tools (Alt + T) > Options > Applications. " i only have 10 rows, and every one is on "always ask", none of them is mkv, matroska o even media/video I did change browser.download.hide_plugins_without_extensions to false but only shockwave/java/silverlight mime appear
dumdidadida 155 решений 1440 ответов
Размещено

You can reset Firefox and check. If you would like to take a listing of the add-ons, changed preferences/settings etc. to quickly replicate the previous profile, please Copy all to clipboard (on the left of the reset button), and paste it into MS Office Excel, or OpenOffice/LibreOffice Calc, or notepad. However, it would be a good idea to check for the existence of the issue immediately after the reset.

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

You can reset Firefox and check. If you would like to take a listing of the add-ons, changed preferences/settings etc. to quickly replicate the previous profile, please '''Copy all to clipboard''' (on the left of the reset button), and paste it into MS Office Excel, or OpenOffice/LibreOffice Calc, or notepad. However, it would be a good idea to check for the existence of the issue immediately after the reset. The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: ''This will cause you to lose any Extensions, Open websites, and some Preferences.'' To Reset Firefox do the following: #Go to Firefox > Help > Troubleshooting Information. #Click the "Reset Firefox" button. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. Further information can be found in the [[Reset Firefox – easily fix most problems]] article. Did this fix your problems? Please report back to us!
slicky 0 решений 5 ответов
Размещено

I had this same exact problem and discovered it was the Inline Disposition addon causing it. After disabling it I could download .mkvs again.

I had this same exact problem and discovered it was the Inline Disposition addon causing it. After disabling it I could download .mkvs again.
Rafael_C_V 2 решений 4 ответов
Размещено

Same problem with me, already reseted, and continues the same...

Same problem with me, already reseted, and continues the same...