Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

Is it possible that Firefox prevents serverside includes (SSI) from functioning?

  • 2 ответа
  • 1 имеет эту проблему
  • 649 просмотров
  • Последний ответ от jerryerp

more options

I am no doubt asking in the wrong place, but...I have Apache2 running on a linux locally. I believe I have set it up to support server-side includes. I have a cgi-bin perl script, hell.pl:

#!/usr/bin/perl

print "Content-type: text/html\n\n";
print "Hello, world\n";
exit;

Under Firefox, I can generate the Hello World page through the url

xxx.xxx.xxx.xxx/cgi-bin/hell.pl

where xxx.xxx... is the apache2 server address.

But if I try to do that via the html file:

<HTML>
<HEAD></HEAD>
Test:<BR>
<BODY>
<!--#include virtual=/cgi-bin/hell.pl" -->
</BODY></HTML> 

All I get is page which is blank except for the "Test:" on line 1. The apache error and access logs show no relevant problems, as if the browser treats the serverside include as a comment.

I realize that the fault no doubt lies with the apache2 configuration, but I have studied and studied... and am now clutching at straws.

Изменено cor-el

Выбранное решение

jerryerp wrote:

Is it possible that Firefox prevents serverside includes (SSI) from functioning?

I don't see how. A browser can only botch client-side scripting like Javascript.

jerryerp wrote:

I realize that the fault no doubt lies with the apache2 configuration [...]

By default, SSI is only interpreted for special file extensions like .shtml. See the “Configuring your server to permit SSI” section of the Apache tutorial for details on how to change this.

Прочитайте этот ответ в контексте 👍 1

Все ответы (2)

more options

Выбранное решение

jerryerp wrote:

Is it possible that Firefox prevents serverside includes (SSI) from functioning?

I don't see how. A browser can only botch client-side scripting like Javascript.

jerryerp wrote:

I realize that the fault no doubt lies with the apache2 configuration [...]

By default, SSI is only interpreted for special file extensions like .shtml. See the “Configuring your server to permit SSI” section of the Apache tutorial for details on how to change this.

more options

But not entirely. In the first instance, I tried the .shtml route suggested in the docs section by adding the Options, Addtype, and AddOutputFilters lines to the .htaccess file in /.htdocs and renamed hello.html to hello.shtml. At first, this simply created a page listing the hello.shtml file. Then I moved the configuration changes to the httpd configuration file and restarted apache. The result was the same as I reported earlier. Changing the hell.pl reference in hello.shtml and the file name in the cgi-bin directory to hell.shtml gave the same result.

Next I tried the XBitHack method to yield the result I reported earlier. It seems then that something hidden in my configuration file is the problem. Thanks anyway.