Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Windows 8 and CSS problems (FF 16 & 17)

  • 74 ответа
  • 112 имеют эту проблему
  • 98 просмотров
  • Последний ответ от anzelina

more options

I just got a brand spanking new Win 8 computer (intl English). The only things installed on it are Adobe Master's Collection, Steam, Office and Firefox. In addition I tried installing adblocker, because that's a must for me and if this problem is resolved by removing it I will have to switch to another browser.

Now, the problem is that FF is having problems loading pages with CSS. Occasionally, this results in a pages with nothing at all (except background color, it seems) or with just unformatted text. Most of the time this is fixed by doing a shift+reload, but not always. Some times it's just partially fixed and some elements don't load still.

I've tried disabling all extensions and plugins and I've also tried resetting FF. The problem always comes back. I've even tried resetting my hosts file.

Do you have any more ways of fixing it? I believe I've done everything in my power, except change browsers (which I really don't want to do unless it's my only option).

The only thing I haven't tried, which I'll try now, is unpin all my app tabs and see if that fixes anything. I'll update this if I can...

Pages affected: Facebook (some of the time), Couch Potato (installed on my server - never seen this on other computers or even other browsers on my computer, always), MyFitnessPal (occasionally), and some low-tech dating page I'm on.

Cheers, Lars

Все ответы (20)

more options

Nope. Didn't help unpinning the app tabs...I'm stuck, and I've spent four days experimenting :S

more options

So, it still happens with a new an clean profile without extensions?

In that case you may have security software (firewall, anti-virus) that block some content.

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)

You can also try to use the Web Console (Web Developer > Web Console;Ctrl+Shift+K) to see if you can identify network related issues.

more options

Yes, it happens with a clean profile. As for the security software, the first thing I did when I got the computer was removing the Symantec bloatware. The only security software now is Windows Defender. I guess I could try disabling the built-in windows software firewall...

The reload option isn't always an option. For one it's just irritating having to do it all the time for some pages and for a couple, like couch potato, it doesn't even work.

I'll have a look at the web console after work - thanks :)

more options

Hmmm...no change when disabling the firewall, and nothing really bad in the web developer log.

This is what I'm getting from Facebook:

[06:16:51.006] Error in parsing value for 'cursor'.  Declaration dropped. @ https://s-static.ak.fbcdn.net/rsrc.php/v2/yV/r/0nKkGtZi1qv.css:44
[06:16:51.014] Unknown property 'zoom'.  Declaration dropped. @ https://s-static.ak.fbcdn.net/rsrc.php/v2/yV/r/0nKkGtZi1qv.css:697
[06:16:51.015] Unknown property '-moz-border-radius'.  Declaration dropped. @ https://s-static.ak.fbcdn.net/rsrc.php/v2/yV/r/0nKkGtZi1qv.css:753
Couch Potato:
[06:16:46.921] ReferenceError: Class is not defined @ http://x.y.z.w:p/api/55adfc6addff41e1b55f5a30411934b5/static/wizard/wizard.js:1
[06:16:46.959] TypeError: window.addEvent is not a function @ http://x.y.z.w:p/:67
[06:16:46.998] Unknown pseudo-class or pseudo-element '-webkit-input-placeholder'.  Ruleset ignored due to bad selector. @ http://x.y.z.w:p/:43
[06:16:46.999] Error in parsing value for 'text-align'.  Declaration dropped. @ http://x.y.z.w:p/:309
[06:16:47.002] Unknown property '-moz-border-radius'.  Declaration dropped. @ http://x.y.z.w:p/:94
[06:16:47.007] Error in parsing value for 'cursor'.  Declaration dropped. @ http://x.y.z.w:p/:362
[06:16:47.064] Error in parsing value for 'vertical-align'.  Declaration dropped. @ http://x.y.z.w:p/:136

"The other page":

[06:16:50.787] ReferenceError: jQuery is not defined @ https://sukker.no/login:216

So, there's nothing that really screams out "this is going to fail!" as far as I can see...These logs are taken from pages that failed to load.

Изменено cor-el

more options

One more update - just to be sure, I ran the symantec removal tool in case there was something left behind the scenes (as there used to be) after uninstalling their software. Still no go.

more options

I have the same problem here. I just have windows defender installed. I am attaching a screenshot of facebook. It happens for a lot of websites though. I hardly have any add-ons installed. I am currently running FF 16.0.2

I have tried the solution of pressing the Shift key and left clicking the reload button and it worked for me.

more options

Wish I could help you, but it seems I may have "solved" my problem after a frentic fit I had last night. Ran the Symantec removal tool three times in a row, uninstalled FF, deleted all FF files (but kept my profile), reinstalled FF and copied back my profile. Now it seems to work - knock on wood.

My best bet would be that the deletion did more than the uninstall and that fixed it.

more options

I'm having this same exact problem. Just got a new laptop with Windows 8 and firefox has been acting strange on it (CSS problem but also sites seem to be loading slowly in general). I did what you did Tiwas and uninstalled it and deleted all the firefox files on my computer, and it was running fine for a short period of time but the issues started popping up again. I think I'm going to have to switch to chrome for now, which sucks because I've been using firefox for years but I don't know what else to do. Maybe firefox just has some sort of compatibility issues with Windows 8 right now since it's so new, I can't think of any other explanation.

more options

Firefox 17 not loading images november 2012 Firefox 16 not loading images 2012 Firefox 17 css not loading

I came in and registered to say that I'm having the same problem as well , even with the new beta v17b0.6, v16, and v17 stable. Running new and clean OS. Mac OSX Moutain lion 10.8.2. Pages look like Silent1ucidity's image. Please fix this, I really like Firefox but now I'm looking at Chrome. Running on Chrome before this post and no errors/ no css errors/ no page loads with just text. It has to be the browser! OS is fresh install and browser has been used with fresh profile and also with plugins installed. Same error regardless.

Adblock Betterprivacy Noscript Downthemall Ghostery

Thanks for reading.

PS: did run on Windows 7 and same error or bug.

Изменено jefrotone

more options

Temp Solution: https://addons.mozilla.org/en-US/firefox/addon/css-reloader/

F9 the page to Reload the CSS.

more options

Also have the same issue.

Has someone created bugzilla issue for that???

more options

Well, turns out the same exact thing is happening in chrome. I uninstalled Norton as I've never used it in the past (my laptop came installed with it) and I've heard that it can cause problems with browsers sometimes. Still having the same issue in both firefox and chrome. I've tried all sorts of google searches and have not been able to find any solutions to this problem (other than shift refreshing, which I basically have to do anytime I go to a page now thus isn't really a solution). As I said before the only explanation I can think of is that it has something to do with Windows 8, and maybe I just haven't been able to find anything about this problem via google because it's so new. It sucks because I'm trying to enjoy my brand new laptop and I'm constantly annoyed from having to refresh multiple times every single time I go to a website. So if anyone else out there with Windows 8 is having similar problems and has possibly found a solution, let us know.

more options

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

You can also consider to reset Firefox:

Изменено cor-el

more options

I urge you people to try the same I did. For one, I uninstalled and made sure it was installed on my system drive. I only have 128GB on that one (SSD), but it seems it was necessary. I also ran the symantec tool several times.

As for the other solutions:

  • reload: One, it doesn't always work and it still sucks. Especially when trying to submit forms.
  • reset FF: As I stated in the original post, that doesn't help one iota.
more options

I have a clean install of Win 8 and Firefox 17, no additional Anti Virus Software installed. Also did a uninstall, delete profile and reinstall of Firefox. Nothing helped.

more options

I am having the same problem too and it's driving me bonkers. I have tried the following:

- Re-installing FF and creating a new profile (did not resolve the issue) - Disabling all add-ons to FF (did not resolve the issue) - Using Chrome instead (did not resolve the issue, still happens in Chrome)

The "shift" refresh trick does work (sometimes) but this is not a long term viable solution.

This is only happening to me since upgrading to Windows 8, does not happen on my Win 7 PCs.

Any solution (permanent, not temporary or work-around) would be appreciated. Given this happens in Chrome and Firefox, this is probably the wrong forum for this error, but thanks anyway.

more options

Same here on my (freshly installed) Samsung Windows 8 64 bit and using Firefox 17.0.1. Reinstall without success, also disabled all Add-Ins, no Chance.

I uninstalled the default installation of Norton Anti Virus. However, I don't see any problems with the deinstallation.

My Windows 7 machines have not this problem, must be something with Windows 8.

Изменено TheAncient

more options

I have samsung notebook with Win 8 and norton antivirus as well. It seems that css styles are not loaded from time to time (several times per hour). Chrome has same issue. I uninstall norton but it occured again after reboot. Very annoying :-(

more options

Does it only happen on Samsung machines? Might be an issue of some Samsung driver?

  1. 1
  2. 2
  3. 3
  4. 4