Search Support

Rounded corners do not work in Firefox 13.0

  • 31 ответ
  • 136 имеют эту проблему
  • 10912 просмотров
  • Последний ответ от Phil Middlemass

more options

When trying to style css with the 'moz' rounded corner CSS it does not display correctly in Firefox 13.0 it shows it as a box rather than being rounded.

Выбранное решение

I have tested it in firefox 12 and nightly. I have got perfect results. It shows rounded corners. could you send your code and please check you code once. it works fine without adding -moz- also.

Прочитайте этот ответ в контексте 👍 1

All Replies (20)

more options

Same problem here.

more options

Glad I am not the only one then.

more options

Hi, it works fine for me. I have tested. Please update your beta version.

more options

I upgraded to Firefox 15 and still the same issue.

more options

Выбранное решение

I have tested it in firefox 12 and nightly. I have got perfect results. It shows rounded corners. could you send your code and please check you code once. it works fine without adding -moz- also.

more options

.custom-background { background-color: #cadceb; padding: 4px; border: 1px solid #105289; -moz-border-radius: 3px; -webkit-border-radius: 3px; }

more options

increase your border-radius to 10px you can see perfect curve. And your code works fine for me. If you can see the helpful and not helpful buttons they have rounded corners. message area is also consist of rounded corners. If you can see rounded corners in this website then rounded corners are working perfectly. post reply also consist of rounded corners :)

more options

I removed both '-moz-border-radius: 3px;' and '-webkit-border-radius: 3px;' and replaced it with 'border-radius: 20px;' and it works perfectly now.

more options

perfect ;)

more options

Theres a lot of websites that had before rounded corners, but not anymore

more options

I use "border-radius: 5px 5px 0 0" for all top rounded corner 0 represent not rounded

more options

You may leave in the -moz-border-radius rule to have support for visitors with older Gecko based browsers.

more options

So what was changed in 13.0.1 that this is now broken and how does it get fixed. I have 3rd party themes on my wordpress. Do I now have to wait to see if they change their theme?

more options

The proper usage of particular border radiuses CSS definition according to the W3C specification are as follows:

  • border-radius
  • border-top-left-radius
  • border-bottom-left-radius
  • border-top-right-radius
  • border-bottom-right-radius

I suppose these are working in 13.0.1.

more options

The following does work with version 12.0 and previouses, but it does not with version 13.0:

-moz-border-radius-topright: 20px; -webkit-border-top-right-radius: 20px; -moz-border-radius-bottomright: 20px; -webkit-border-bottom-right-radius: 20px; -moz-border-radius-bottomleft: 0px; -webkit-border-bottom-left-radius: 0px;

more options

i would rather not be spammed. the question was already answered.

more options

Hi FB92, so sorry about the annoying emails. When you start or reply in a thread, you are automatically subscribed to all replies. Next time you visit the thread, look for "Stop email updates" to the right of your original post. That should take care of it.

more options

Done that. :)

Thanks.

more options

Rounded corners are not working for me. This is a big problem in FF 13.

Изменено ThiagoSMoraes

more options

Hi ThiagoSMoraes, you probably have found the solution by now in other threads, but just in case they did not come up in a search: Delete the -moz prefix (unless you want to support Fx3.5/3.6 in which case use both). See https://developer.mozilla.org/en/CSS/border-radius

  1. 1
  2. 2