Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

open link in new tab next to original tab?

  • 7 ответов
  • 15 имеют эту проблему
  • 15511 просмотров
  • Последний ответ от SafeBrowser

more options

I've noticed since updating to FF12 that now when I click to get "open link in new tab," the new tab opens on the far right of my tabs rather than next to the tab I clicked from, as it did in FF3.6. Is there any way to get it to work the old way?

Thanks, Ellen

Выбранное решение

On my XP system, new tabs open next to the current tab with these settings

  • the pref browser.tabs.insertRelatedAfterCurrent set to false
  • in Tab Mix Plus Options, Events > New Tabs, I have checked "Open new tabs next to current one"


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Прочитайте этот ответ в контексте 👍 2

Все ответы (7)

more options

Have you tried or checked this hidden Firefox preference in about:config......

You can change a preference to make tabs open

  1. at the end of all open tabs
  2. immediately after the current tab.

See: http://kb.mozillazine.org/About:config

  • Type about:config in the URL bar and press the Enter key.
  • If you see the warning, accept it (promise to be careful).
  • Search = browser.tabs.insertRelatedAfterCurrent
  • Look at the "Value" column (false=open at end, true=open after current tab); Value = true is the default.
  • Double-click that preference to toggle the value from true to false, or false to true
  • Restart Firefox (File > Restart Firefox)

See: http://www.mydigitallife.info/2010/02/01/change-firefox-to-open-new-tab-at-far-right-end-of-tabbar-disable-insert-next-to-current-active-tab/


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

Изменено SafeBrowser

more options

Unfortunately, whether I have it set to true or false, it opens at the end. Very puzzling.

Ellen

more options

Have you tried restarting Firefox after setting the pref and verify that your change "sticks"?

Do you have tab-related Add-ons/Extensions (like Tab Mix Plus, Tab Utilities, etc.)? If so, have you checked the settings in those extensions?

You should always copy/paste the list from Help > Troubleshooting Information > Copy all to clipboard then paste in the "Troubleshooting Information" section when posting a new question. That information may help us to better analyze your problem.

You can also try Firefox Safe Mode. If it works properly in Firefox Safe Mode, then the problem is being caused by one of your Extensions or Plugins.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Изменено SafeBrowser

more options

OK, I disabled Tab Mix Plus and found that that was what was causing the problem. But I have looked at all the options over and over, but I can't find anything that affects where a new tab opens. You wouldn't happen to know?

Thanks, Ellen

more options

Выбранное решение

On my XP system, new tabs open next to the current tab with these settings

  • the pref browser.tabs.insertRelatedAfterCurrent set to false
  • in Tab Mix Plus Options, Events > New Tabs, I have checked "Open new tabs next to current one"


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Изменено SafeBrowser

more options

OK, that fixed it. Thanks again.

more options

ellenelle:

To help other users find solutions, please return and sign-in to the forum with your user name and password:

  • click on "Solved It" to the right of one of my replies ABOVE that BEST solved your question
  • DO NOT click "Solved It" next to this reply

Thanks