X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

My firefox is constantly showing page source(HTML code lines) insted of loading page, the only thing I tried was making my browser work faster, could this be connected to my problem?

Размещено

I provided all the details in the question, the problem is simple and random, few sites open as a plain text, instead of loading the full content the way it should be. (followed these steps http://www.forevergeek.com/2004/12/make_firefox_faster/ and http://www.wikihow.com/Make-Firefox-Load-Pages-Faster)

I provided all the details in the question, the problem is simple and random, few sites open as a plain text, instead of loading the full content the way it should be. (followed these steps http://www.forevergeek.com/2004/12/make_firefox_faster/ and http://www.wikihow.com/Make-Firefox-Load-Pages-Faster)

Дополнительные сведения о системе

Это случилось

Каждый раз при открытии Firefox

Это началось когда...

Two days ago.

Установленные плагины

  • Next Generation Java Plug-in 10.2.0 for Mozilla browsers
  • Shockwave Flash 11.1 r102
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.0"
  • Pando Web Plugin
  • Google Update
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Fun Web Products Plugin Stub for 32-bit Windows
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Unity Player 3.3.0f4
  • Nexon Game Controller
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Version 1.0.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • DRM Netscape Network Object

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

Дополнительная информация

Programmas pamatinformācija
Nosaukums
Firefox
Versija
9.0.1
Lietotāja aģents
Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Profila direktorija
Atvērt saturošo mapi
Aktivizētie spraudņi
about:plugins
Būvējuma konfigurācija
about:buildconfig
Avārijas ziņojumi
about:crashes
Atmiņas izmantojums
about:memory
Papildinājumi
Nosaukums
Versija
Ieslēgts
ID
Html Validator
0.9.5.1
true
{3b56bcc7-54e5-44a2-9b44-66c3ef58c13e}
Personas
1.6.2
true
personas@christopher.beard
Afterglow Options
4.0.5
false
afterglow_options@www.theme-oasis.org
Java Quick Starter
1.0
false
jqs@sun.com
Microsoft .NET Framework Assistant
0.0.0
false
{20a82645-c095-46ed-80e3-08825760534b}
Modificētie iestatījumi
Nosaukums
Vērtība
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20111220165912
browser.startup.homepage_override.mstone
rv:9.0.1
browser.tabs.warnOnClose
false
dom.disable_window_flip
false
extensions.lastAppVersion
9.0.1
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
11144
places.history.expiration.transient_optimal_database_size
17828904
privacy.sanitize.migrateFx3Prefs
true
Grafika
Ierīces apraksts
NVIDIA GeForce 6600 GT
Ražotāja ID
10de
Ierīces ID
0140
Ierīces RAM
Unknown
Ierīces draiveris
nv4_disp
Draivera versija
6.14.12.8558
Draivera datums
10-7-2011
Ierīces RAM (GPU #2)
Unknown
Ierīces draiveris (GPU #2)
Unknown
WebGL renderētājs
Google Inc. -- ANGLE (NVIDIA GeForce 6600 GT) -- OpenGL ES 2.0 (ANGLE 0.0.0.809)
Grafiski paātrināti logi
1/1 Direct3D 9

Размещено

Задавший вопрос

http://ufaq.org doesn't wrok, all I see is html codes.. ="top" width="1" style="background-image: url(themes/fisubice/images/7px.gif)"> (and so on)

http://ufaq.org doesn't wrok, all I see is html codes.. ="top" width="1" style="background-image: url(themes/fisubice/images/7px.gif)"> (and so on)
Размещено

Задавший вопрос

http://ufaq.org doesn't work, all I see is html codes(plain text)

http://ufaq.org doesn't work, all I see is html codes(plain text)
JayGarcia 30 решений 273 ответов
Размещено

Try contacting your ISP support, this may be a DNS issue on their end. I have some other minds working on this as well, we'll see what they come up with.

Try contacting your ISP support, this may be a DNS issue on their end. I have some other minds working on this as well, we'll see what they come up with.
JayGarcia 30 решений 273 ответов
Размещено

Obviously you are seeing this site properly, so we have to figure out why other sites don't render or why this one does. Try your banking site which is a secure site prepended by "https".

Obviously you are seeing this site properly, so we have to figure out why other sites don't render or why this one does. Try your banking site which is a secure site prepended by "https".
John99 971 решений 13138 ответов
Размещено

Have another look at the image posted,

What is the image supposed to represent other than a frog in an ice cube? 

When I open http://imageshack.us/photo/my-images/171/adfafaf.png/ I get a frog and a screenshot of firefox under it. The screenshot (ice-cube) is not high quality but apparently is NOT of firefox homepage.

So the primary problem may not be with how the page renders but what it redirects to.

The URL shown in the image looks something like http://staff.bumblr.com (NO it must be a T) {and I note the lowercase NOWIKI markup does not seem to function)

In fact the detail seems to match the sourcecode of http://staff.tumblr.com

Have another look at the image posted, What is the image supposed to represent other than a frog in an ice cube? When I open http://imageshack.us/photo/my-images/171/adfafaf.png/ I get a frog and a screenshot of firefox under it. The screenshot (ice-cube) is not high quality but apparently is '''NOT''' of firefox homepage. ''' So the primary problem may not be with how the page renders but what it redirects to. ''' The URL shown in the image looks something like <nowiki>http://staff.bumblr.com</nowiki> (NO it must be a T) {and I note the lowercase NOWIKI markup does not seem to function) In fact the detail seems to match the sourcecode of http://staff.tumblr.com

Изменено John99

JayGarcia 30 решений 273 ответов
Размещено

One opinion from another source I contacted on this is that somehow the output from the ISP is requesting text/text instead of text/html. I would still suggest contacting the ISP support.

One opinion from another source I contacted on this is that somehow the output from the ISP is requesting text/text instead of text/html. I would still suggest contacting the ISP support.
Размещено

Задавший вопрос

Thanks for yur advices, I'll contact my ISP support and see what happens. I think this could be due packet losses(foregin pages don't fully load/or load as plain text).

Thanks for yur advices, I'll contact my ISP support and see what happens. I think this could be due packet losses(foregin pages don't fully load/or load as plain text).
JayGarcia 30 решений 273 ответов
Размещено

Thanks, let us know. What is still a bit puzzling is why does this support site render ok for you and not the others.

Thanks, let us know. What is still a bit puzzling is why does this support site render ok for you and not the others.
Размещено

Задавший вопрос

No changes yet, this problem isn't caused by my firewall/antivirus/modem/router/ISP, this is a browser sided error, but I still can't figure out on why this is happening, pages on random show as plain text, and it seems with all the modification I had to make to make my Firefox worlk properly, it only runs slower.

No changes yet, this problem isn't caused by my firewall/antivirus/modem/router/ISP, this is a browser sided error, but I still can't figure out on why this is happening, pages on random show as plain text, and it seems with all the modification I had to make to make my Firefox worlk properly, it only runs slower.
JayGarcia 30 решений 273 ответов
Размещено

You mentioned you tried Opera and the same thing happens. Did you also try IE? And there is no answer yet as to why this forum site renders properly and other sites don't. Do you see regular html rendering as well on other sites?

What you need to answer before we continue:

  • Does it happen with IE
  • Does it happen on some but not all pages, please provide us with URL's where it happens and where it doesn't happen
  • Have you rebooted your computer
  • What is loading in the system tray at bootup time
  • Have you tried disabling ALL running programs other than what is necessary to maintain OS integrity
You mentioned you tried Opera and the same thing happens. Did you also try IE? And there is no answer yet as to why this forum site renders properly and other sites don't. Do you see regular html rendering as well on other sites? What you need to answer before we continue: * Does it happen with IE * Does it happen on some but not all pages, please provide us with URL's where it happens and where it doesn't happen * Have you rebooted your computer * What is loading in the system tray at bootup time * Have you tried disabling ALL running programs other than what is necessary to maintain OS integrity

Изменено JayGarcia

Размещено

Задавший вопрос

No IE has no such problems, it only happens on Opera and Firefox(all vesrions). This inproper rendering happens on all http sites(except https). I'm not home right now, but I'll call a friend that's a bit more smarter than me in Web Development.

No IE has no such problems, it only happens on Opera and Firefox(all vesrions). This inproper rendering happens on all http sites(except https). I'm not home right now, but I'll call a friend that's a bit more smarter than me in Web Development.
Размещено

Полезный ответ

I found the problem, my Firefox browser sometimes can't load CSS files(it's properties), so instead of trying to load it again it just shows the page as plain text. Is there a way to fix this?

I found the problem, my Firefox browser sometimes can't load CSS files(it's properties), so instead of trying to load it again it just shows the page as plain text. Is there a way to fix this?
JayGarcia 30 решений 273 ответов
Размещено

Полезный ответ

Ah, an important clue. The addon AdBlock is known to cause this problem. If installed and enabled then disable it in Firefox and in Opera.

Also, in Firefox, make sure that View => Page Style that "Basic Page Style" is selected.

Ah, an important clue. The addon AdBlock is known to cause this problem. If installed and enabled then disable it in Firefox and in Opera. Also, in Firefox, make sure that View => Page Style that "Basic Page Style" is selected.

Изменено JayGarcia

Размещено

Задавший вопрос

I just found a partial solution, all you need is CSS updater/CSS reloader/Firebug/Greasemonkey https://addons.mozilla.org/en-US/firefox/addon/css-reloader/?src=search https://addons.mozilla.org/en-US/firefox/addon/cssupdater/?src=search https://addons.mozilla.org/en-US/firefox/addon/firebug/?src=search https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/?src=search This is just a partial solution because some sites(for me tumblr) don't fully load with these add-ons, but a simple refresh makes it render correctly

I just found a partial solution, all you need is CSS updater/CSS reloader/Firebug/Greasemonkey https://addons.mozilla.org/en-US/firefox/addon/css-reloader/?src=search https://addons.mozilla.org/en-US/firefox/addon/cssupdater/?src=search https://addons.mozilla.org/en-US/firefox/addon/firebug/?src=search https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/?src=search This is just a partial solution because some sites(for me tumblr) don't fully load with these add-ons, but a simple refresh makes it render correctly
JayGarcia 30 решений 273 ответов
Размещено

A "partial solution" is not a solution, only a band-aid and could make things worse. Did you follow my instructions pertaining to AdBlock, etc in my last reply?

A "partial solution" is not a solution, only a band-aid and could make things worse. Did you follow my instructions pertaining to AdBlock, etc in my last reply?
Размещено

Задавший вопрос

I tried all of the above solutions, and they didn't help, my problem was a bit more tricky(I explained it above), and no, I had no AdBlocker, I tried multiple times running firefox without any add-ons/extensions and CSS preferences weren't rendered(on few sites) so it loaded pages as plain text, but as I said above, I'm happy with this band-aid, and hopefully the next Firefox browser will have no such problems with CSS reading/loading.

I tried all of the above ''solutions'', and they didn't help, my problem was a bit more tricky(I explained it above), and no, I had no AdBlocker, I tried multiple times running firefox without any add-ons/extensions and CSS preferences weren't rendered(on few sites) so it loaded pages as plain text, but as I said above, I'm happy with this band-aid, and hopefully the next Firefox browser will have no such problems with CSS reading/loading.
JayGarcia 30 решений 273 ответов
Размещено

Ok then, good luck.

Ok then, good luck.
Размещено

Задавший вопрос

I was wrong, pages still open up as plain text, instead of loading the CSS/html properties.

I was wrong, pages still open up as plain text, instead of loading the CSS/html properties.
Vivek 289 решений 2084 ответов
Размещено

I think you may also be able to find important info in Tools (Alt + T) > Web Developer > Web Console. You have to open it and then start browsing. Clicking on the GET requests would open a new mini window. You can check for the Content-Type:text/html in the Response Headers among others.

I think you may also be able to find important info in '''Tools''' ('''Alt''' + '''T''') > '''Web Developer''' > '''Web Console'''. You have to open it and then start browsing. Clicking on the GET requests would open a new mini window. You can check for the '''Content-Type:text/html''' in the '''Response Headers''' among others.

Изменено Vivek