Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

When I open a second tab it does not use my home page; instead it uses "search.babylon.com. How do I get rid of this?

  • 9 ответов
  • 164 имеют эту проблему
  • 3 просмотра
  • Последний ответ от AcciAcce

more options

Recently I googled for a foreign language translation. That worked well. In the process I also ended up at Answer.com which now shows up as an option for a search engine. That does not bother me. But search.babylon.com also showed up as a search engine and as the default web page. (Babylon also has a translation service.) I removed a babylon program from the computer (now search.babylon.com no longer appears as a search engine), reset my old home page, but when opening a second tab on Firefox, I get

"http://search.babylon.com/?babsrc=NT_bb" as the page. How can I get rid of it?
Recently I googled for a foreign language translation. That worked well. In the process I also ended up at Answer.com which now shows up as an option for a search engine. That does not bother me. But search.babylon.com also showed up as a search engine and as the default web page. (Babylon also has a translation service.) I removed a babylon program from the computer (now search.babylon.com no longer appears as a search engine), reset my old home page, but when opening a second tab on Firefox, I get "http://search.babylon.com/?babsrc=NT_bb" as the page. How can I get rid of it?

Выбранное решение

JUST GO TO ADD REMOVE PROGRAMS AND UNINSTALL BABYLON APPLICATION . I had same issue

Прочитайте этот ответ в контексте 👍 0

Все ответы (9)

more options

A new tab opens by default as a blank tab (about:blank).

If that isn't the case then an extension has changed that behavior.

more options

I have deleted this site, blocked it, removed all traces of it and even re-installed firefox and yet, babylon keeps coming back. Must be some sort of virus?

more options

Выбранное решение

JUST GO TO ADD REMOVE PROGRAMS AND UNINSTALL BABYLON APPLICATION . I had same issue

more options

Uninstalling the babylon application does not help. The problem is the extension noted in cor-el's solution. It is not removed by the "uninstall" utility.

more options

If the extension cannot be removed in the addons dialog then it is probably locked.

Help => Restart with addons disabled => do NOT check anything, select "Continue in Safe Mode". Now try to use the "Remove" button.

more options

In addition to removing Babylon using Windows Control Panel, remove it from the Firefox Add-ons by starting Firefox and navigating t0 Firefox>Add-ons>Extensions. From the list of installed Add-ons select the option to remove Babylon. Restart Firefox.

You may also want to remove the Babylon entries in the Windows registry as the Control Panel uninstall program does not remove them all. Also note all the Babylon folder and file locations mentioned in the registry and confirm they have been deleted. As always, be careful when working with the registry and don't edit it if you are not confident about doing so.

Good luck.

more options

I also have this problem with this pestilence. I uninstalled it, cleaned up all references to it in the registry, did a search on my hard disk and removed anything with Babylon in it. In Firefox I opened "about:config" and set all the values that referred to Babylon to blank (unfortunately I cannot remove them). In the add-ons section I cannot uninstall Babylon, just disable it.

more options

i also encounter with the same problem. You first remove babylon from ADD or Remove Program in the control panel. In addition to removing Babylon using Windows Control Panel, remove it from the Firefox Add-ons by starting Firefox and navigating t0 Firefox>Add-ons>Extensions. From the list of installed Add-ons select the option to remove Babylon. Restart Firefox. if it is windows xp then it appear in the tools menu>options>manage Add-ons>extensions. In Firefox I opened "about:config" and set all the values that referred to Babylon to blank

more options

it isn't useful!!!