Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

On every Firefox5 startup, there is a always a compatibility check and then the browser always opens with the 'Welcome to Firefox' page in a tab. How can I regain the smooth function I had back with Firefox4?

  • 8 ответов
  • 127 имеют эту проблему
  • 8 просмотров
  • Последний ответ от Zoberraz

more options

Each and every time I open Firefox, there is this small window which pops up - it's usually short-lived and appeared to run a compatibility check for plug-ins, extensions and add-ons - my PC then hangs for a few seconds before the browser finally opens.

By contrast, Firefox 4 opened near instantly and without a fuss. Whatever add-ons and plug-ins I had worked perfectly well with it.

Each time Firefox5 is opened, I have the 'Welcome to Firefox' window which shows up everytime there is a new install or an update. There is no way I could find to get rid of it - it's always there, everytime I start the browser.

Все ответы (8)

more options
more options

Checked the links in cor-el's answer. Unfortunately, following the instructions in them did not help with this issue.

  • Homepage settings are correct (set to Yahoo.ca by being on that page and using the 'user current page as your homepage' option).
  • Editing/removing the prefs.js files did not help. Removing related files (prefs-1, invalidprefs...) did not work. Preferences appear to be saved (as the prefs.js file comes back).
  • Advanced SystemCare is the application I currently use for malware protection (IObit Malware Fighter). Tweaking the protection settings (and turning the application off) has not improved matters - also note that Firefox4 had no problem there.
more options

Same issue for me, no settings or options config changes this

I also tried a roll back to 3.16 and the problem is there too now, so its something in the general mozilla files

dont fancy a full uninstall and delete of anything mozilla, but i wont be using this if it continues

Изменено onlyevg

more options

It is either a problem with the prefs or a problem with the extension registry.

Delete the files extensions.* (extensions.sqlite, extensions.rdf, extensions.cache, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. New files will be created when required.

See "Corrupt extension files":

If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to do a compatibility check or see if there is an update.


Create a new profile as a test to check if your current profile is causing the problems.

See:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

more options

did not work, and deleting the compatibility ini causes firefox to not even run so i wouldnt suggest that

switch back to chrome i guess

more options

Yes same for me I posted this question before in forms. No doubt in my mind its a problem. Maybe they should of backed off 5.0 and kept going with 4.xx.xx for awhile instead pushing it to us with no fanfare in your face take it. Gives me a bad taste.

more options

I am a Windows XP user and had firefox5 installed automatically by the auto-update system. From then on my problems started. I eventually found that the quickest, cleanest way to solve this problem was to save my bookmarks as a html file. Then FULLY uninstall firefox5 and delete the folders in C:\Program Files\Mozilla Firefox and C:\Documents and Settings\"username"\Application Data. I then did a clean, fresh installation with Firefox 5.0.1 (which is now available) and reloaded my bookmarks from the saved html file.

more options

That's about what I did too. I exported my bookmarks, uninstalled, launched a 'Deep Care' sweep using Advanced SystemCare 4, and then reinstalled Firefox5.

I appreciate cor-el's effort, but it they didn't really work out.

On the bright side, I've no problem with Firefox5 at present.