Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

After Win7 SP1 firefox gets a User Account Control prompt everytime I open it.

  • 6 ответов
  • 38 имеют эту проблему
  • 2 просмотра
  • Последний ответ от landsailor

more options

After installing the windows 7 service pack 1 update, anytime Firefox is launched I am prompted with the UAC (User Account Control) prompt asking for my permission since it will try to make changes. My UAC setting is on default and reinstalling the latest version of Firefox (3.6.13) doesn't alleviate the issue.

Выбранное решение

Check that you do not run Firefox as Administrator.
Right-click the Firefox desktop shortcut and choose "Properties".
In the Compatibility tab, make sure that Privilege Level: "Run this program as Administrator" is not selected.
You also need to check the Properties of the firefox.exe program in the Firefox program directory.

Прочитайте этот ответ в контексте 👍 4

Все ответы (6)

more options

Did Firefox work fine before when you were using Windows 7 without Service Pack. If yes, lower the User-Account level.

more options

Выбранное решение

Check that you do not run Firefox as Administrator.
Right-click the Firefox desktop shortcut and choose "Properties".
In the Compatibility tab, make sure that Privilege Level: "Run this program as Administrator" is not selected.
You also need to check the Properties of the firefox.exe program in the Firefox program directory.

more options

Changing the firefox.exe from running as an administrator solved my problem. Thank you for the help.

more options

Arethius, please mark this issue as solved. cor-el's solution is right.

more options

I had this issue too. But when I changed the compatibility mode (where you can also remove "Run as Administrator", the prompt changed. Mine was set for XP, I changed to Win Vista Service Pack 2. Now, the prompt is gone. Bing a Boom.

more options

Depends on the configuration of your machine's other settings. In my case, and with a Dell Vostro laptop, all I had to do was disable the "Digital Persona Extension" in Tools -> Add-ons -> Extensions section. There was no need to adjust anything else with UAC or the firefox.exe or its shortcut properties. :)