X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

FF does not display XML page content

Размещено

I'm running a web application written in XQuery (mostly) that returns XML data. For months that has been displaying as hierarchical XML structure, the same as if I opened an XML document with FF. Now, it just displays only the text content of the structure, and that's all run together. I have to View Page Source to see the XML.

Opening an XML document directly still gives me the desired structure display.

Running the same app in IE still displays the XML structure, so it's not a change in the app.

I assume it's just a setting somewhere, but I can't find it.

I'm running a web application written in XQuery (mostly) that returns XML data. For months that has been displaying as hierarchical XML structure, the same as if I opened an XML document with FF. Now, it just displays only the text content of the structure, and that's all run together. I have to View Page Source to see the XML. Opening an XML document directly still gives me the desired structure display. Running the same app in IE still displays the XML structure, so it's not a change in the app. I assume it's just a setting somewhere, but I can't find it.

Дополнительные сведения о системе

Это случилось

Каждый раз при открытии Firefox

Это началось когда...

(not sure) -- maybe when I updated to FF 3.6.12.

Установленные плагины

  • Shockwave Flash 10.1 r102
  • Office Plugin for Netscape Navigator
  • Coupons, Inc. Coupon Printer DLL
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • ActiveTouch General Plugin Container Version 105
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Foxit Reader Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • Google Update
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Приложение

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)

Дополнительная информация

The XQuery app defines its return type this way:
let $head := response:set-header("Content-Type", "application/xml")

romeen 0 решений 1 ответов
Размещено

Полезный ответ

I guess you are using Firebug. When you disable Firebug -I know; it's not a solution... - you will probably see your XML structure again. So, it's a Firebug thing, not Firefox.

I guess you are using Firebug. When you disable Firebug -I know; it's not a solution... - you will probably see your XML structure again. So, it's a Firebug thing, not Firefox.
WombleDog 0 решений 1 ответов
Размещено

Полезный ответ

Disabling Firebug does not make any difference as evidenced on this page that displays properly whether I have Firebug activated or not: http://www.w3schools.com/xml/note.xml

If you are creating the XML then you need to format the output header so that the browser knows what it is expected to display. Add this line before you echo your XML:

header( 'Content-Type: text/xml, charset=utf-8' );

This works for me! OS X 10.6.6 / FF 3.6.13

Disabling Firebug does not make any difference as evidenced on this page that displays properly whether I have Firebug activated or not: http://www.w3schools.com/xml/note.xml If you are creating the XML then you need to format the output header so that the browser knows what it is expected to display. Add this line before you echo your XML: header( 'Content-Type: text/xml, charset=utf-8' ); This works for me! OS X 10.6.6 / FF 3.6.13

Изменено WombleDog

bbbbbb 0 решений 3 ответов
Размещено

I have exactly the same problem.

This problem consistently appears on some of my servers, but not others. FF4 consistently shows XML structure for unstyled XML responses on my local dev instance (Paster with no compression) but a blank screen (or a screen with just body content) for my remote Apache instance (compression enabled) and my remote IIS instance.

Setting the Content-Type header does not help. Toggling Firebug does not help.

Here are the headers for two identical, valid XML documents.

The first response, served locally with a simple Paster instance, renders as its source along with the standard gray warning at the top of the page about no style, the way FF3.6 always did. Here is its header:

HTTP/1.0 200 OK Server: PasteWSGIServer/0.5 Python/2.7.1+ Date: Tue, 10 May 2011 17:01:03 GMT Pragma: no-cache Cache-Control: no-cache Content-Type: text/xml; charset=utf8 Content-Length: 429


The second response, served remotely from Apache with gzip enabled, renders as a blank screen because there is no "body" text in this XML doc. Here is its header:

HTTP/1.1 200 OK Date: Tue, 10 May 2011 16:51:34 GMT Server: Apache/2.2.16 (Ubuntu) Pragma: no-cache Cache-Control: no-cache Vary: Accept-Encoding Content-Encoding: gzip Content-Length: 268 Keep-Alive: timeout=15, max=100 Connection: Keep-Alive Content-Type: text/xml; charset=utf8

The response content is identical. Both open and show the XML source if I save them to my desktop.

Since I write XML-RPC protocol implementations all day, this is a real drag.

To facilitate search, this is the warning I get when FF displays the XML source the way I expect;

"This XML file does not appear to have any style information associated with it. The document tree is shown below."

I have exactly the same problem. This problem consistently appears on some of my servers, but not others. FF4 consistently shows XML structure for unstyled XML responses on my local dev instance (Paster with no compression) but a blank screen (or a screen with just body content) for my remote Apache instance (compression enabled) and my remote IIS instance. Setting the Content-Type header does not help. Toggling Firebug does not help. Here are the headers for two identical, valid XML documents. The first response, served locally with a simple Paster instance, renders as its source along with the standard gray warning at the top of the page about no style, the way FF3.6 always did. Here is its header: HTTP/1.0 200 OK Server: PasteWSGIServer/0.5 Python/2.7.1+ Date: Tue, 10 May 2011 17:01:03 GMT Pragma: no-cache Cache-Control: no-cache Content-Type: text/xml; charset=utf8 Content-Length: 429 The second response, served remotely from Apache with gzip enabled, renders as a blank screen because there is no "body" text in this XML doc. Here is its header: HTTP/1.1 200 OK Date: Tue, 10 May 2011 16:51:34 GMT Server: Apache/2.2.16 (Ubuntu) Pragma: no-cache Cache-Control: no-cache Vary: Accept-Encoding Content-Encoding: gzip Content-Length: 268 Keep-Alive: timeout=15, max=100 Connection: Keep-Alive Content-Type: text/xml; charset=utf8 The response content is identical. Both open and show the XML source if I save them to my desktop. Since I write XML-RPC protocol implementations all day, this is a real drag. To facilitate search, this is the warning I get when FF displays the XML source the way I expect; "This XML file does not appear to have any style information associated with it. The document tree is shown below."
bbbbbb 0 решений 3 ответов
Размещено

Update:

There are two ways to disable Firebug. The first way, which I tried, is to disable it for a specific page. That makes no difference for this bug.

The second way is to disable the entire Add-on and restart FF4. When I do that, this bug disappears. So the earlier responder was correct: this is likely a Firebug issue, and I'll be taking this bug to the Firebug forums.

Update: There are two ways to disable Firebug. The first way, which I tried, is to disable it for a specific page. That makes no difference for this bug. The second way is to disable the entire Add-on and restart FF4. When I do that, this bug disappears. So the earlier responder was correct: this is likely a Firebug issue, and I'll be taking this bug to the Firebug forums.
bbbbbb 0 решений 3 ответов
Размещено

Update:

Firebug claims they fixed their bug (3961), and re-enabling Firebug and restarting FF4 *after* disabling it and restarting FF4 "fixed" this problem. At the moment, the pages display as colorized XML source. However, past experience suggests this bug will return -- soon.

Therefore it is not yet certain that the blame is on Firebug, because it is difficult to deconvolve the effects of restarting FF4 vs. toggling the Firebug add-on.

Update: Firebug claims they fixed their bug (3961), and re-enabling Firebug and restarting FF4 *after* disabling it and restarting FF4 "fixed" this problem. At the moment, the pages display as colorized XML source. However, past experience suggests this bug will return -- soon. Therefore it is not yet certain that the blame is on Firebug, because it is difficult to deconvolve the effects of restarting FF4 vs. toggling the Firebug add-on.
Edwin Krisnha 0 решений 1 ответов
Размещено

I also have this problem too.. First I try to disable the Firebug, but it still the same, the XML tag won't show up unless I view the source. Then I disable my add-ons called Fastest Fox, and voila... this problem solved.

I also have this problem too.. First I try to disable the Firebug, but it still the same, the XML tag won't show up unless I view the source. Then I disable my add-ons called Fastest Fox, and voila... this problem solved.
anderci 2 решений 20 ответов
Размещено

History: With FireFox 3.6, Mozilla 1.7.13 and IE 6 I can view my xml report files utilizing their xsl files. I recently upgraded to FireFox 5 and lost that capability! Update: I was finally getting FireFox 5.0 to display xml files using their xsl stylesheets on my desktop PC. I tried to upgrade my laptop PC from Firefox 3 to 5.0 but it insisted on upgrading to 6.02 Now FireFox 6.02 refuses to display the xml files using their xsl stylesheets, What is wrong?

More History: I have developed several applications for nonprofit use that depend on viewing and printing reports via web browsers. I choose this approach because nonprofit organizations would all have web browsers on their PCs. My xml report files each have their xsl stylesheet files FireFox has been my default browser since it superseded Mozilla 1.7.

With FF5 before it started working as expected, I was able to drag and drop the .xml file and it would be displayed using its .xsl stylesheet. This does NOT work with FF6!

If I change the directory structure: ..\Templates to ..\Reports\Templates so that the .xml file references .\Templates\stylesheet.xsl I can drag and drop the .xml file in FF6 to achieve the appropriate display

I have no idea what 'Firebug', mentioned in this thread is.

At some other site, I saw mention of 'search plugins', 'XPI files', unpack flag ... install.rdf'. I do not know if these items are relevant or what they are.

When I try to specify, from Windows Explorer ... Open With... I cannot find FF6, nor can I successfully Browse... to select FF6 on my harddrive and have FF6 open the .xml file.

I will sincerely appreciate your help.

History: With FireFox 3.6, Mozilla 1.7.13 and IE 6 I can view my xml report files utilizing their xsl files. I recently upgraded to FireFox 5 and lost that capability! Update: I was finally getting FireFox 5.0 to display xml files using their xsl stylesheets on my desktop PC. I tried to upgrade my laptop PC from Firefox 3 to 5.0 but it insisted on upgrading to 6.02 Now FireFox 6.02 refuses to display the xml files using their xsl stylesheets, What is wrong? More History: I have developed several applications for nonprofit use that depend on viewing and printing reports via web browsers. I choose this approach because nonprofit organizations would all have web browsers on their PCs. My xml report files each have their xsl stylesheet files FireFox has been my default browser since it superseded Mozilla 1.7. With FF5 before it started working as expected, I was able to drag and drop the .xml file and it would be displayed using its .xsl stylesheet. This does NOT work with FF6! If I change the directory structure: ..\Templates to ..\Reports\Templates so that the .xml file references .\Templates\stylesheet.xsl I can drag and drop the .xml file in FF6 to achieve the appropriate display I have no idea what 'Firebug', mentioned in this thread is. At some other site, I saw mention of 'search plugins', 'XPI files', ''unpack flag ... install.rdf'. I do not know if these items are relevant or what they are. When I try to specify, from Windows Explorer ... Open With... I cannot find FF6, nor can I successfully Browse... to select FF6 on my harddrive and have FF6 open the .xml file. I will sincerely appreciate your help.
colinyal 0 решений 1 ответов
Размещено

I have similar problem with FF6.0.2 when I start Netobjects Fusion 9 I now get error ' your browser does not support XML document objects'. With previous FF versions there was no problem & no problem currently with other browsers.

I have similar problem with FF6.0.2 when I start Netobjects Fusion 9 I now get error ' your browser does not support XML document objects'. With previous FF versions there was no problem & no problem currently with other browsers.
anderci 2 решений 20 ответов
Размещено

I upgraded my laptop PC from FireFox 6.02 to FireFox 7.0. It is an improvement. I can open (menu->File/Open_File...) and display the .xml documents that are referencing their .xsl stylesheets. BUT, I cannot set FF7 as the default or even a valid application to open the .xml document directly. I browse and select FireFox.exe but it it is not recognized!!!

What is wrong?

Additional comment: I install FireFox on my D: partition with other programs, trying to reserve my C: partition for the OS -

 D:\Program Files\Mozilla Firefox
I upgraded my laptop PC from FireFox 6.02 to FireFox 7.0. It is an improvement. I can open (menu->File/Open_File...) and display the .xml documents that are referencing their .xsl stylesheets. BUT, I cannot set FF7 as the default or even a valid application to open the .xml document directly. I browse and select FireFox.exe but it it is not recognized!!! What is wrong? Additional comment: I install FireFox on my D: partition with other programs, trying to reserve my C: partition for the OS - D:\Program Files\Mozilla Firefox

Изменено anderci

anderci 2 решений 20 ответов
Размещено

I upgraded my laptop PC from FireFox 6.02 to FireFox 7.0 to FireFox 8.0. I install FireFox on my D: partition with other programs, trying to reserve my C: partition for the OS -

 D:\Program Files\Mozilla Firefox

I can open FireFox and Drag-Drop or I can open (menu->File/Open_File...) and display the .xml documents that are referencing their .xsl stylesheets.

 e.g.:  

BUT, I cannot set FF8 as the default or even a valid application to open the .xml document directly. I browse and select FireFox.exe but it it is not recognized!!!

FireFox 5.0 works as expected on my desktop PC!

What is still wrong?

I upgraded my laptop PC from FireFox 6.02 to FireFox 7.0 to FireFox 8.0. I install FireFox on my D: partition with other programs, trying to reserve my C: partition for the OS - D:\Program Files\Mozilla Firefox I can open FireFox and Drag-Drop or I can open (menu->File/Open_File...) and display the .xml documents that are referencing their .xsl stylesheets. e.g.: <?xml-stylesheet type='text/xsl' href='.\Templates\SurveyResultsStatistics.xsl'?> BUT, I cannot set FF8 as the default or even a valid application to open the .xml document directly. I browse and select FireFox.exe but it it is not recognized!!! FireFox 5.0 works as expected on my desktop PC! What is still wrong?

Изменено anderci

žełvik 3 решений 38 ответов
Размещено

This problem in a nutshell:

  1. Create display.xml containing an XSLT style sheet.
  2. Create test/test.xml referring to "../display.xml" for display.
  3. Tell Firefox to open "test/test.xml" and observe how the style sheet is not applied.

This affects local content but does not affect documents served over HTTP.

This problem in a nutshell: # Create display.xml containing an [[XSLT]] style sheet. # Create test/test.xml referring to "../display.xml" for display. # Tell Firefox to open "test/test.xml" and observe how the style sheet is not applied. This affects local content but does not affect documents served over [[HTTP]].
keeganwitt 0 решений 4 ответов
Размещено

I found that the troublesome addon was actually InvisibleHand (though this might not be the case for everyone that's experienced this issue). I've sent a note to them.

I found that the troublesome addon was actually InvisibleHand (though this might not be the case for everyone that's experienced this issue). I've sent a note to them.
jason2048 0 решений 1 ответов
Размещено

Huh, FastestFox (4.7.8) does the same thing. Disabling it shows the XML as expected, with no other tricks or workarounds.

Huh, FastestFox (4.7.8) does the same thing. Disabling it shows the XML as expected, with no other tricks or workarounds.

Изменено jason2048