Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

About:config. I could use a tip here

  • 13 ответов
  • 12 имеют эту проблему
  • 67 просмотров
  • Последний ответ от Eireann

more options

Please can someone tell me where I have to adjust FF about:config so that the Indian character sets are switched on.

Right now all character sets, Japanese, Thai, Chinese and what not are being displayed fine. The only ones that are not displayed are all Indian letters although I have them all in my Arial Unicode MS character set.

Все ответы (13)

more options

Make sure that you have installed support for complex scripts.

Can you post a link?

There are a lot of Indian sites that use embedded fonts that do not work in Firefox.

See also Padma: https://addons.mozilla.org/firefox/addon/873 - http://padma.mozdev.org/

more options

It worked fine until I have upgraded to this version of FF. 3.5.12 Ladst time I had to tweak about:config, but this time its not working. Maybe some other setting they have changed.

more options

Which prefs did you change in the past?

font.default encoding prefs or font.name prefs?

more options

I wished I knew which preferences in about:config I have changed....with the help of one member here. The installation of the latest FF version has messed it all up.

Last time I did mention problem solving details here in this forum, but searching this forum for my old post did not yield any result. Seems old things were deleted. I think they should not delete old solutions to problems because one day they can be helpful to others.

more options

Firefox has font.default prefs for some Indic encodings, but there are no name prefs for serif and sans-serif.

font.default.x-devanagari
font.default.x-geor
font.default.x-gujr
font.default.x-guru
font.default.x-khmr
font.default.x-knda
font.default.x-mlym
font.default.x-orya
font.default.x-sinh
font.default.x-tamil
font.default.x-telu


So you can try to add font.name.sans-serif.* and font.name.serif.* prefs for the one that you need.

more options

Thanks Cor-el, I will see what I can do with that info. These definitions must have been there for previous versions of firefox because in older versions the Indian character sets worked without any problem.

more options

Cor el, just checked. preferences for - font.name.sans-serif - and - font.name.serif - were set, With the standard values it didnt work. I have added "Arial Unicode MS" to all preferences, just as I did last time, but it still doesnt work. Attached the current settings for devanagari which should give me Hindi letters.

more options

Don't you see any Devanagari script?

http://en.wikipedia.org/wiki/Devanagari

more options

I dont see any Indian script. Chinese, Thai, Korean, Cyrillic etc... all are OK

Sorry I cant open the wikipedia pages because then the firefox hangs. The last two versions of FF have problems with wikipedia and google. But, my IE doesnt hang with wikipedia and there the Indian character sets work.

more options
more options

Does that mean that xterm came with previous firefox versions and has been taken out in the latest versions?

mentioned here: http://en.wikipedia.org/wiki/Devanagari is the Lipikar writing tool to write hindi. For me its about viewing. When I can see it on firefox then I can write it. But as long as a placeholder shows instead the letter I cant do anything.

For the second link: I dont have xterm. I looked at the page with my InternetExploder because FF doesnt work well with wikipedia pages. The wikipedia page sais: "This will work only on Firefox compiled with ctl support." I dont know why previous versions of Firefox worked well.

It should actually work if I set the serif and sans-serif valued to Arial Unicode MS but it doesnt....

See attachment how the last link looks in FF.

more options

As advised by one page I have activated the Indic option in Regional settings. That installed mangal.ttf and latha.ttf It seems that the latest FF does not address the Arial Unicode MS set at all. I have just set everything for zh-cn, which is the setting for Chinese characters, to Arial Narrow, and nothing happens. Chinese characters are shown as if I would have kept the default setting.

Besides, the activation of the indic set only shows hindi and tamil letters and it doesnt show them as they should be. All other Indian languages are left out

About:Config settings seem to have no influence whatsoever. I can fill in nonsense values for font.name.serif and font.name.sans-serif and it still shows the mangal writing. I think thats a BUG.

Изменено Eireann

more options

Just uninstalled FF3.5.12 and went back to FF3.5.3 Now modifying about:config changes things again and all my character sets work again. I should have doen that earlier. FF3.5.11 and 12 were just BAD.