X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

FF 4b5 Meu/Tab font does not follow Windows Settings

Размещено

Hi There !

I'm running Win 7 64bit but with changed default system font. I've modified system configuration so instead "Sagoe UI" (or something like this) - which Win 7 uses as default font, I'm using MS Sans Serif.

Everything worked well with all previous FF 4 betas (1-4) but since I've installed Beta 5 - Firefox started using Strange font (not Sagoe, not MS Sans) in menus (even Firefox text on this ugly Orange button is displayed with this strange font).

Not only menu and menu items but also; texts on tabs, texts used in settings, texts in About, address bar, search bar ... entire FF4b5 Interface. Pages are displayed correctly.

In FF4b4 - everything worked well and FF followed system font. Beta 5 messed this up.

Any ideas how to force FF 4b5 to follow Win7 settings?

Thanks in advance !

Hi There ! I'm running Win 7 64bit but with changed default system font. I've modified system configuration so instead "Sagoe UI" (or something like this) - which Win 7 uses as default font, I'm using MS Sans Serif. Everything worked well with all previous FF 4 betas (1-4) but since I've installed Beta 5 - Firefox started using Strange font (not Sagoe, not MS Sans) in menus (even Firefox text on this ugly Orange button is displayed with this strange font). Not only menu and menu items but also; texts on tabs, texts used in settings, texts in About, address bar, search bar ... entire FF4b5 Interface. Pages are displayed correctly. In FF4b4 - everything worked well and FF followed system font. Beta 5 messed this up. Any ideas how to force FF 4b5 to follow Win7 settings? Thanks in advance !

Выбранное решение

This change is due to using hardware acceleration, if you disable hardware acceleration it should revert to the old behaviour.

Open the Options dialog, go to the Advanced panel and then select the General tab for the setting to disable hardware acceleration.

Прочитайте этот ответ в контексте 4

Дополнительные сведения о системе

Установленные плагины

  • ActiveTouch General Plugin Container Version 105
  • Shockwave Flash 10.1 r82
  • GEPlugin
  • Picasa plugin
  • 4.0.50826.0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

Дополнительная информация

TonyE
  • Moderator
1044 решений 8863 ответов
Размещено

Выбранное решение

This change is due to using hardware acceleration, if you disable hardware acceleration it should revert to the old behaviour.

Open the Options dialog, go to the Advanced panel and then select the General tab for the setting to disable hardware acceleration.

This change is due to using hardware acceleration, if you disable hardware acceleration it should revert to the old behaviour. Open the Options dialog, go to the Advanced panel and then select the General tab for the setting to disable hardware acceleration.
Размещено

Задавший вопрос

Thanks TonyE !

Your method did the trick.

Btw, Is there a way to work this around with HW Acceleration on? Is there a way to force particular font in accelerated mode?

Best regards and thanks once again.

Thanks TonyE ! Your method did the trick. Btw, Is there a way to work this around with HW Acceleration on? Is there a way to force particular font in accelerated mode? Best regards and thanks once again.
TonyE
  • Moderator
1044 решений 8863 ответов
Размещено

I don't know of any other workaround, maybe somebody else will.

I don't know of any other workaround, maybe somebody else will.
Размещено

Задавший вопрос

Just to show you what is the difference (problem)

See attached image. All settings are the same with only difference - HW acceleration is OFF on the left hand side. On Right hand side - HW acceleration is ON.

Thanks anyway TonyE

Just to show you what is the difference (problem) See attached image. All settings are the same with only difference - HW acceleration is OFF on the left hand side. On Right hand side - HW acceleration is ON. Thanks anyway TonyE