Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

FireFox shows swf twice in browser when swfobject is used to display alternate content. Is there a fix for this?

  • 4 ответа
  • 20 имеют эту проблему
  • 105 просмотров
  • Последний ответ от the-edmeister

more options

I'm using swfobject to display alternate html content on a Flash site. In FireFox only it loads the site's swf twice. It does not happen with any other browser. You can view the site I'm testing at http://www.turntwomedia.com/index-altContent.html

This happened

Not sure how often

== I was testing the site in all browsers.

Все ответы (4)

more options

Try posting at the Web Development / Standards Evangelism forum at MozillaZine. The helpers over there are more knowledgeable about web page development issues with Firefox. http://forums.mozillazine.org/viewforum.php?f=25 You'll need to register and login to be able to post in that forum.

more options

You have both an EMBED and an OBJECT without a classid that is displayed by Firefox in addition the the OBJECT with a classid for IE. You need to remove one of them. Either use the EMBED or the object with the conditional code () that hides it from IE.

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="955" height="775" id="myFlashContent"> <param name="allowScriptAccess" value="sameDomain" /> <param name="allowFullScreen" value="false" /> <param name="movie" value="TurnTwoMedia_web.swf" /><param name="menu" value="false" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" />

<embed src="TurnTwoMedia_web.swf" menu="false" quality="high" bgcolor="#ffffff" width="955" height="775" name="TurnTwoMedia_web" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer" />

<!--[if !IE]>--> <object type="application/x-shockwave-flash" data="TurnTwoMedia_web.swf" width="955" height="775">

more options

Thanks for your response, but I had already tried that and when I remove the one for IE, which is a fix for IE, then FireFox displays both the swf and the alternate html content on the same page.

Also, when I remove the if statement for IE, it doesn't display correctly in IE.

more options

You need to remove the EMBED. You already have an object for Firefox.