Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

keep browser open after closing last tab

  • 5 ответов
  • 0 имеют эту проблему
  • Последний ответ от dee_veloper

more options

I want to keep browser open after closing last tab. I changed the boolean parameter "browser. tabs. closeWindowWithLastTab" to "false" but the browser still closes with closing of last tab.

What else is required ?

I want to keep browser open after closing last tab. I changed the boolean parameter "browser. tabs. closeWindowWithLastTab" to "false" but the browser still closes with closing of last tab. What else is required ?

Все ответы (5)

more options

Hi

With no tabs open, there is browser - you need at least one tab open.

Полезно?

more options

"With no tabs open, there is browser - you need at least one tab open."

There is a way to make it stay open when the last tab is closed. In effect what it does is replace the closed tab with an empty or new tab so the browser does not close. I've seen it operate that way.

I just need to know what the changes should be to make that happen

Полезно?

more options

UPDATE:

I found the problem....and the solution....

In the about:config file, while searching for the boolean parameter "browser. tabs. closeWindowWithLastTab" , I typed in the word "window" to find it.

When the list came up, I saw that the parameter is found two times in the list. Only one was set to "false". When I set the second one to "false" the desired browser behavior was achieved.

Полезно?

more options

Firefox should create a new blank tab when you close the last tab if you set browser.tabs.closeWindowWithLastTab to false. Firefox will close the window without asking if you use the close X to close the window and not the close X to close the tab.

EDIT: I see that you accidentally created a new pref with possibly spaces in its name. Note that pref names are case sensitive and shouldn't have spaces. You can click the trashcan on the line with the wrong name to remove this pref.

Полезно?

more options

Good eye. I see that there are in fact spaces included in one of them. I had cut and pasted it in from an article. I didn't know that I could create a new preference. Good to know.

I deleted the incorrect one and it still works as I want it to.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.