Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Authentication failure with SMTP-server

  • 10 ответов
  • 0 имеют эту проблему
  • Последний ответ от kompak

more options

I've been running Thunderbird for years on Gentoo which has version 115.10.1 as the most recent. I don't send much mail so I'm not exactly sure when this problem occurred, but I'm unable to authenticate with my SMTP server. I have not changed any configuration. Some weeks ago a changed my password on the server, but I made the appropriate changes to Thunderbird password manager. All settings, username and passwords are 100% correct as I copy pasted all of them. IMAP on the same server (uses same credentials) works.

I have tried deleting and re-adding my accounts which did not help. I have also tried deleting my profile folder. All other mail clients (e.g. claws-mail, kmail, mailspring) with the same SMTP server don't have any problems sending mail. This problem seems to only affect Thunderbird and Thunderbird forks such as Betterbird.

I have no firewall and am using SSL authentication with cleartext password on the SMTP server.

I get the following output to console on attempted sending of message:

console.error: (new Error("Server error 503 Service Unavailable", "resource://services-settings/Utils.sys.mjs", 390)) console.error: mailnews.smtp: "Command failed: 535 Incorrect authentication data; currentAction=_actionAUTHComplete" console.error: mailnews.smtp: "Authentication failed: Incorrect authentication data" console.error: mailnews.smtp: "Authentication failed: Incorrect authentication data" console.error: mailnews.send: "Sending failed; Unable to authenticate to Outgoing server (SMTP) mail.kapsi.fi. Please check the password and verify the 'Authentication method' in 'Account Settings | Outgoing server (SMTP)'., exitCode=2153066805, originalMsgURI="

I've been running Thunderbird for years on Gentoo which has version 115.10.1 as the most recent. I don't send much mail so I'm not exactly sure when this problem occurred, but I'm unable to authenticate with my SMTP server. I have not changed any configuration. Some weeks ago a changed my password on the server, but I made the appropriate changes to Thunderbird password manager. All settings, username and passwords are 100% correct as I copy pasted all of them. IMAP on the same server (uses same credentials) works. I have tried deleting and re-adding my accounts which did not help. I have also tried deleting my profile folder. All other mail clients (e.g. claws-mail, kmail, mailspring) with the same SMTP server don't have any problems sending mail. This problem seems to only affect Thunderbird and Thunderbird forks such as Betterbird. I have no firewall and am using SSL authentication with cleartext password on the SMTP server. I get the following output to console on attempted sending of message: console.error: (new Error("Server error 503 Service Unavailable", "resource://services-settings/Utils.sys.mjs", 390)) console.error: mailnews.smtp: "Command failed: 535 Incorrect authentication data; currentAction=_actionAUTHComplete" console.error: mailnews.smtp: "Authentication failed: Incorrect authentication data" console.error: mailnews.smtp: "Authentication failed: Incorrect authentication data" console.error: mailnews.send: "Sending failed; Unable to authenticate to Outgoing server (SMTP) mail.kapsi.fi. Please check the password and verify the 'Authentication method' in 'Account Settings | Outgoing server (SMTP)'., exitCode=2153066805, originalMsgURI="

Выбранное решение

I finally found the solution to this problem. Thunderbird seems to be not able to send passwords with non ASCII characters properly to SMTP-servers. Strangely this only is the case with SMTP. IMAP passwords can contain non ASCII characters.

This bug is marked resolved, but apparently it is not.

Прочитайте этот ответ в контексте 👍 0

Все ответы (10)

more options

Maybe if you post a screenshot of your smtp settings, it will present a more complete picture of your issue. Thank you.

Полезно?

more options

Of course here it is. These settings work perfectly fine in any other email client except Thunderbird.

Полезно?

more options

Are you including your full email id or just the prefix before the @?

Полезно?

more options

Just my username.

Полезно?

more options

Please try with full email address.

Полезно?

more options

It won't work as I have a specific username for the server.

Полезно?

more options

You mentioned that you changed settings to password manager. How was that done? My suggestion would have been to go to settings>privacy&security and delete both entries for the account and let Thunderbird then prompt for password.

Полезно?

more options

david said

You mentioned that you changed settings to password manager. How was that done? My suggestion would have been to go to settings>privacy&security and delete both entries for the account and let Thunderbird then prompt for password.

That is exactly what I tried first. Since then I have tried complete deleting all accounts and even deleting my whole profile folder.

Полезно?

more options

Ok, I'm lost. My only other thought would be whether you have more than one account, as that could be the issue if they're using the wrong smtp server. Do you get the same error when you use the full email address?

Полезно?

more options

Выбранное решение

I finally found the solution to this problem. Thunderbird seems to be not able to send passwords with non ASCII characters properly to SMTP-servers. Strangely this only is the case with SMTP. IMAP passwords can contain non ASCII characters.

This bug is marked resolved, but apparently it is not.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.