Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How can I directly open file links?

  • 3 ответа
  • 0 имеют эту проблему
  • 5 просмотров
  • Последний ответ от Toad-Hall

more options

In our company, we have recently updated Thunderbird from version 52.3.0 to 115.9.0. Now we have a problem with href links containing file URIs in our messages. We often receive file links pointing to files in our local intranet, which look like this: <a href="file://///intranet.local/dfs/output/movie.mp4" class="moz-txt-link-freetext" moz-do-not-send="true">movie.mp4</a> Up to Thunterbird version 98.0b3 it was possible to open these files by simply clicking the link. But since version 99.0b1 file links don't open any more. Instead, the error console displays the following message: Security Error: Content at mailbox:///C:/Users/username/AppData/Roaming/Thunderbird/Profiles/profilename/Mail/Local%20Folders/Inbox?number=12345 may not load or link to file://///intranet.local/dfs/output/movie.mp4. Fortunately, it is possible to open the link with "Open Link In Browser" from the context menu. But we would like to get rid of this extra click. I already followed the steps in this document: http://kb.mozillazine.org/Links_to_local_pages_do_not_work#Firefox_1.5.2C_Mozilla_1.8.2C_and_newer Interestingly, this document is older than the time, when our problem was introduced into Thunderbird. Consequently, when I follow these steps, file links still don't open in an external application. Instead, they open inside of Thunderbird which is not the desired effect. To put my question in a nutshell: How can I open file links by left-clicking on them, just the way they open, when I right-click on them and select "Open Link In Browser"?

Steps to reproduce: On a Windows computer create a new mail. Press Ctrl-K to insert a link. Enter the following path with username replaced by your windows logon name: file:///C:/Users/username/Documents Save and close the mail. Watch the mail in the drafts folder. Click the link. Nothing happens, but you can see a message in the error console. Right click the link and select "Open Link In Browser". This opens your windows explorer.

Any solution is welcome, even if it's potentially insecure, since our computers don't have any internet access and we can receive internal mail only.

In our company, we have recently updated Thunderbird from version 52.3.0 to 115.9.0. Now we have a problem with href links containing file URIs in our messages. We often receive file links pointing to files in our local intranet, which look like this: <a href="file://///intranet.local/dfs/output/movie.mp4" class="moz-txt-link-freetext" moz-do-not-send="true">movie.mp4</a> Up to Thunterbird version 98.0b3 it was possible to open these files by simply clicking the link. But since version 99.0b1 file links don't open any more. Instead, the error console displays the following message: Security Error: Content at mailbox:///C:/Users/username/AppData/Roaming/Thunderbird/Profiles/profilename/Mail/Local%20Folders/Inbox?number=12345 may not load or link to file://///intranet.local/dfs/output/movie.mp4. Fortunately, it is possible to open the link with "Open Link In Browser" from the context menu. But we would like to get rid of this extra click. I already followed the steps in this document: http://kb.mozillazine.org/Links_to_local_pages_do_not_work#Firefox_1.5.2C_Mozilla_1.8.2C_and_newer Interestingly, this document is older than the time, when our problem was introduced into Thunderbird. Consequently, when I follow these steps, file links still don't open in an external application. Instead, they open inside of Thunderbird which is not the desired effect. To put my question in a nutshell: How can I open file links by left-clicking on them, just the way they open, when I right-click on them and select "Open Link In Browser"? Steps to reproduce: On a Windows computer create a new mail. Press Ctrl-K to insert a link. Enter the following path with username replaced by your windows logon name: file:///C:/Users/username/Documents Save and close the mail. Watch the mail in the drafts folder. Click the link. Nothing happens, but you can see a message in the error console. Right click the link and select "Open Link In Browser". This opens your windows explorer. Any solution is welcome, even if it's potentially insecure, since our computers don't have any internet access and we can receive internal mail only.

Все ответы (3)

more options

re :I already followed the steps in this document: http://kb.mozillazine.org/Links_to_local_pages_do_not_work#Firefox_1.5.2C_Mozilla_1.8.2C_and_newer Interestingly, this document is older than the time, when our problem was introduced into Thunderbird. Consequently, when I follow these steps, file links still don't open in an external application. Instead, they open inside of Thunderbird which is not the desired effect.

Certain files can open in Thunderbird eg: PDF But they do this because you have settings for Files & Attachments to open in Thunderbird.

  • Settings > General
  • scroll down to 'Files & Attachments' section
  • Look for the Content type eg: Portable Document Format (PDF)
  • Change the action to use the desired program eg: Adobe Acrobat

Полезно?

more options

Thank you Toad-Hall, yes, I know how to associate an application with different content types. But the problem isn't about opening attachments. It's about opening links to files that aren't included with the mail but linked via href="file://///...". I'm sorry if that wasn't clear enough from my description. Btw, would you mind trying the few steps I described to reproduce the issue?

Полезно?

more options

Clemens said

Thank you Toad-Hall, yes, I know how to associate an application with different content types. But the problem isn't about opening attachments. It's about opening links to files that aren't included with the mail but linked via href="file://///...". I'm sorry if that wasn't clear enough from my description. Btw, would you mind trying the few steps I described to reproduce the issue?

The part you sorting out is 'Files and Attachments' not just Attachments.

When you want to open a link to a file and it needs to use the correct program then you must make sure it is already set up.

I've already tried the 'steps' you posted, but I'm assuming the link points to a file in that directory and not just a folder. eg: file:///C:/Users/username/Documents/family.pdf

In this instance as I have set up pdf to open using Adobe Acrobat in 'Files & Attachments' then Thunderbird opens that file link to pdf in Adobe Acrobat. In other words it works for me.

If you have something like this: file://///intranet.local/dfs/output/movie.mp4 Then in 'Files & Attachments' you need to have set up what Thunderbird uses for opening .mp4 documents. Have you already done this for all the various file types you need to open?

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.