Avatar for Username

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Power management

  • 6 ответов
  • 0 имеют эту проблему
  • 1 просмотр
  • Последний ответ от danu.tihonov

more options

Firefox doesn't work with power management. It essentially turns the screen off and then sends the laptop to sleep when watching videos (in full screen). I have tried to disable hardware acceleration, but it didn't fix my problem. I am on 124.0.1 version - flatpack version on fedora, as the actual fedora version from "discover" app center cannot play videos at all. I am running on fedora 39, kde plasma, wayland.

Firefox doesn't work with power management. It essentially turns the screen off and then sends the laptop to sleep when watching videos (in full screen). I have tried to disable hardware acceleration, but it didn't fix my problem. I am on 124.0.1 version - flatpack version on fedora, as the actual fedora version from "discover" app center cannot play videos at all. I am running on fedora 39, kde plasma, wayland.

Все ответы (6)

more options

Perhaps it's due to Screen Wake Lock API. Enter about:config in the address bar and switch dom.screenwakelock.enabled to true.

Полезно?

more options

Video content should create inhibitors automatically without requiring the Screen Wake Lock API. Flatpak fullscreen video playback creates the necessary inhibitors for me on Ubuntu GNOME.

danu.tihonov said

fedora version from "discover" app center cannot play videos at all

Fedora requires installing codecs, add the RPM Fusion repo then:

sudo dnf install ffmpeg


Flatpak also requires codecs for best results:

flatpak install org.freedesktop.Platform.ffmpeg-full//23.08

Полезно?

more options

zeroknight said

Video content should create inhibitors automatically without requiring the Screen Wake Lock API. Flatpak fullscreen video playback creates the necessary inhibitors for me on Ubuntu GNOME.

danu.tihonov said

fedora version from "discover" app center cannot play videos at all

Fedora requires installing codecs, add the RPM Fusion repo then:

sudo dnf install ffmpeg


Flatpak also requires codecs for best results:

flatpak install org.freedesktop.Platform.ffmpeg-full//23.08

the flatpack you mentioned was already installed and the fedora version still turns my screen off.

Изменено danu.tihonov

Полезно?

more options

TyDraniu said

Perhaps it's due to Screen Wake Lock API. Enter about:config in the address bar and switch dom.screenwakelock.enabled to true.

I have turned that on, but it didn't fix my issue.

Полезно?

more options

Does it still happen with the Mozilla build?

Полезно?

more options

zeroknight said

Does it still happen with the Mozilla build?

No, it doesn't happen with the Mozilla build. It isn't installable, isn't it? Is it just the executable?

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.