Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How to block Firefox translation pop-up

  • 5 ответов
  • 2 имеют эту проблему
  • 35 просмотров
  • Последний ответ от cor-el

more options

How do I stop getting this translation pop-up Firefox puts on my screen? I do not want this service, and I do not want Firefox to be putting ANY pop-ups on my screen, to include to tell me there's a new version available. Firefox has become the pop-up problem.

How do I stop getting this translation pop-up Firefox puts on my screen? I do not want this service, and I do not want Firefox to be putting ANY pop-ups on my screen, to include to tell me there's a new version available. Firefox has become the pop-up problem.

Все ответы (5)

more options

You can set this pref to false on the about:config page to prevent opening the translation pop-up panel.

  • about:config => browser.translations.automaticallyPopup = false

You can control this translation feature via:

  • browser.translations.enable = true|false

Note that you do not get the translation icon for pages that are in the preferred language for displaying pages list, in this case use the "3-bar" Firefox menu button.

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.

more options

Thank you for these responses, though when I type about:config in the address bar and press Enter., I end up in a sort of loop. I get to a page - Configuration Editor for Firefox - that tells me to type about:config, etc. So I'm back where I started. Am I missing something? I confess to neither being computer savvy nor wishing to be.

I have to say more generally that Firefox should not be putting pop-ups on my screen and making it so complex to be rid of them. Doesn't it realize that users are fighting tooth and nail against pop-ups?

If Firefox does not improve in this regard, I am going to try another browser.

more options

Firefox would normally show the warning page if you open the about:config page via the location bar.

Can you attach a screenshot, so we can see what is wrong ?

more options

I've got as far as changing "browser.translation.automaticallyPopup" to =false. I'm then instructed to click on Save to save this change. How? There is no save box to click on. Nothing is clear, I'm afraid. I do not want popups at all. Thank you.

more options

You can double-click a line on the about:config page to toggle a Boolean pref true/false. If you use the Edit icon, click the blue OK button or press Enter to confirm. Note that the value is either true or false (i.e. no '=').