Avatar for Username

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Подробнее

YouTube playback videos are flickering on Firefox regardless of hardware acceleration, but not on other browsers

  • 4 ответа
  • 0 имеют эту проблему
  • 1 просмотр
  • Последний ответ от alexcoats17

more options

Recently, when I try to play a video on YouTube on Firefox, there is a flickering brightness effect (some aspects of the video seem to flicker bright and dark quickly) which is distracting and makes it difficult to watch anything. The effect persists even when launching in troubleshooting mode, and disabling hardware acceleration and restarting appears to have no effect. I have also been unsuccessful refreshing Firefox. Nevertheless, this issue is absent on Safari and Chrome when watching the same video.

Watching a solid colored video like this helps see the issue best, if it is happening to your device: https://www.youtube.com/watch?v=hJmFYZEcpZA The brightness switch is visible even when pausing the video.

When I find the same video two different places (ex: the Apple Sept 12 Event on Apple's site, versus on YouTube) only the YouTube video has the issue. However, I can't find any settings to change on YouTube to help this.

Recently, when I try to play a video on YouTube on Firefox, there is a flickering brightness effect (some aspects of the video seem to flicker bright and dark quickly) which is distracting and makes it difficult to watch anything. The effect persists even when launching in troubleshooting mode, and disabling hardware acceleration and restarting appears to have no effect. I have also been unsuccessful refreshing Firefox. Nevertheless, this issue is absent on Safari and Chrome when watching the same video. Watching a solid colored video like this helps see the issue best, if it is happening to your device: https://www.youtube.com/watch?v=hJmFYZEcpZA The brightness switch is visible even when pausing the video. When I find the same video two different places (ex: the Apple Sept 12 Event on Apple's site, versus on YouTube) only the YouTube video has the issue. However, I can't find any settings to change on YouTube to help this.
Приложенные скриншоты

Выбранное решение

Updating the Sonoma Beta version in the Mac version completely resolves this issue! Discovered solution through https://bugzilla.mozilla.org/show_bug.cgi?id=1845766

Прочитайте этот ответ в контексте 👍 1

Все ответы (4)

more options

I also tried disabling WebGL. With or without hardware acceleration, that did not resolve the issue.

more options

Go to about:config in the address bar and try changing gfx.core-animation.specialize-video to false. then restart the browser.

more options

Sadly, changing the gfx.core-animation.specialize-video to false and restarting also didn't change anything :( Could it be related to running firefox on an M1 Mac? I just don't know what's wrong since the basic steps don't seem to change anything.

more options

Выбранное решение

Updating the Sonoma Beta version in the Mac version completely resolves this issue! Discovered solution through https://bugzilla.mozilla.org/show_bug.cgi?id=1845766