Avatar for Username

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

google.com won't load

more options

The google search bar on the homepage doesn't work, just does an infinite load, the same with google.com. The extensions I have are AVG Online Security, Malwarebytes, and AVG Anti-Tracking. The version is the latest version 116.0.1

The google search bar on the homepage doesn't work, just does an infinite load, the same with google.com. The extensions I have are AVG Online Security, Malwarebytes, and AVG Anti-Tracking. The version is the latest version 116.0.1

Выбранное решение

Apparently AVG Anti-track is the culprit. If I disable it, google.com loads. I guess it's because it changes the browser fingerprint periodically, I don't know.

Прочитайте этот ответ в контексте 👍 1

Все ответы (12)

more options

Hello! It looks like you're having trouble with Google not loading properly in Firefox. Don't worry, we can get this sorted out. The issue you're experiencing might be due to a conflict with your browser extensions. To start, let's try disabling the AVG Online Security, Malwarebytes, and AVG Anti-Tracking extensions one by one, then refresh the page to see if Google loads correctly. If that solves the problem, you can enable the extensions one at a time to identify which one is causing the issue. Also, ensure you have the latest version of your extensions. If the problem persists, clearing your browser's cache and cookies could help. Give these steps a shot and let us know how it goes.

more options

Hi Anthony

Please can you check for any further updates. We have recently released 116.0.2 that might help.

This support article should help:

https://support.mozilla.org/en-US/kb/update-firefox-latest-release#

more options

Did that. Tried refreshing Firefox and it worked, until I closed Firefox and then opened it again, then it quit working again.

more options

Tried a complete uninstall of Firefox using Revo Uninstaller which gets rid of leftover files and registry keys. Did a clean install of Firefox. The first time I opened it google worked. When I closed Firefox and reopened it, search quit working. I didn't change any of the default settings, just did a clean uninstall/install.

more options

Try changing DNS over HTTPS from "Default Protection" to "Off" (or vice versa) and in Connection Settings change "Use system proxy settings" to "No proxy".

more options

Still no help. Have you heard anything about avg anti-virus or anti-tracking causing problems? It doesn't with Chrome or Edge, but maybe Firefox doesn't like it?

more options

Is https://www.google.com/ the only site affected?

For example, can you load https://duckduckgo.com/ or https://www.bing.com/ ?

What about country-specific sites like https://www.google.ca/ ?

How about if you test in the Microsoft Edge browser, which presumably is installed on your Windows 11?

more options

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet, select "No Proxy" if "Use the system proxy settings" or one of the of the others do not work properly.

See "Firefox connection settings":

Boot the computer in Windows Safe Mode with network support to see if that has effect.

more options

Other search engines don't seem to be affected, even https://www.google.ca loads, just google.com won't load. It works in safe mode with networking

more options

Выбранное решение

Apparently AVG Anti-track is the culprit. If I disable it, google.com loads. I guess it's because it changes the browser fingerprint periodically, I don't know.

more options

Thank you for reporting back. It's odd that other sites aren't affected.