Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How do I get all of my folders and subfolders to have the same columns in v115?

  • 17 ответов
  • 12 имеют эту проблему
  • 116 просмотров
  • Последний ответ от Toad-Hall

more options

I just want all of my folders and sub-folders to have the same display columns! With 115, you can change any folder or sub-folder to any column organization you want, but I want them all the same. 115 changed my display columns - why couldn't you leave them alone, Thunderbird??? I can go in and change them back manually, so why were they changed at all??? I don't want to have to change each folder and its child folders individually - I have a few dozen folders, most with dozens of sub-folders. I tried the "Apply columns to ..." and selected Local Folders to change them all - none of them changed! I saw the video from Castellani claiming that TB tried to make sure that upgrading wouldn't take hours to reconfigure back to a usable state, but that's obviously not true if you have more than the one or two folders shown in the video.

Mozilla/Thunderbird -- Is it so hard to leave things as they are and just TELL us there are new features available, if we want them, instead of DESTROYING our well-used setups and forcing us to come here in hopes that someone can save us from hours of tedium just to be productive again?

Thanks to anyone who can save those of us who just want our setups back the way they were!

I just want all of my folders and sub-folders to have the same display columns! With 115, you can change any folder or sub-folder to any column organization you want, but I want them all the same. 115 changed my display columns - why couldn't you leave them alone, Thunderbird??? I can go in and change them back manually, so why were they changed at all??? I don't want to have to change each folder and its child folders individually - I have a few dozen folders, most with dozens of sub-folders. I tried the "Apply columns to ..." and selected Local Folders to change them all - none of them changed! I saw the video from Castellani claiming that TB tried to make sure that upgrading wouldn't take hours to reconfigure back to a usable state, but that's obviously not true if you have more than the one or two folders shown in the video. Mozilla/Thunderbird -- Is it so hard to leave things as they are and just TELL us there are new features available, if we want them, instead of DESTROYING our well-used setups and forcing us to come here in hopes that someone can save us from hours of tedium just to be productive again? Thanks to anyone who can save those of us who just want our setups back the way they were!

Все ответы (17)

more options

Hey there! I totally understand your frustration with the changes in Thunderbird's display columns. It's definitely not fun when things change unexpectedly. To get all your folders and subfolders to have the same columns in version 115, you can try this: Go to "View" in the menu bar, then "Columns," and select the columns you want. After that, right-click on a folder and choose "Apply columns to" > "All Folders." This should hopefully make all your folders and subfolders match up with the same columns. I get it, change can be tough, but hopefully, this helps you get your setup back on track! If you're still having trouble, don't hesitate to reach out – we're here to help you out.

more options

Wow - not even close! There is no "Columns" entry in the View menu. Attached is a photo of my View menu. Windows 10 TB version 115.0.1, 64-bit

Изменено DucksoupSD

more options

What are the list of steps you last tried that didn't work? (Perhaps they were Castellani's) Knowing that we can provide advice on why it didn't work.

more options

@Wayne - the only steps I've tried since I posted were those of suram080, who suggested a process using a menu item that doesn't exist in my 115, as shown in the photo in my reply on 07 Aug 23. I haven't had time to fix them all individually, so my folders continue to be a jumble of formats, thanks to TB's ease of upgrading.

If that menu item exists only in the 32-bit version and not the 64-bit version, that might be something relatively easy for someone involved with TB to correct.

Castellani's (Product Design Manager for TB) video message (check YouTube) claimed that an effort was made so that upgrading to 115 wouldn't take much time to reconfigure after upgrading (no specifics on my problem). So far, for me, that message has been totally false. I certainly wouldn't have upgraded if someone pointed out that TB was going to scramble the columns and I'd have to fix each subfolder individually, if I wanted my old configuration.

more options

I have a simple (crude) video that I used to help people set unthreaded, but the steps are the same. https://davidkirk.org/SettingDefaultFolderView.mp4 The steps are to - click a folder and set it to all the settings you want - then click the rightside menu on message list pane and click assign columns & folders and continue clicking up the heirarchy to account name . This sometimes takes a little practice. - repeat this for every account

A bit more work initially that I did was to set the config editor where I could and then created a user.js file so I could preset future installs.

more options

Thanks, David, but that doesn't work with mine. The menu items are there this time, but nothing happens when I choose a folder. I can choose a folder or a folder and its children, and none of the columns change to match my inbox setting.

I think this might be a 32-bit vs 64-bit issue. Works for 32-bit, doesn't for 64-bit, because the two suggestions so far work for someone else, but not me.

more options

Once a folder eg: Inbox has been set up with the desired columns. click on far right icon in the column headers Usually you select: 'Apply columns to' > 'Folder and its children' > 'Mail account name' > 'mail account name' At prompt select 'yes'

The above works when you are applying it a mail account name you created. eg: 'Apply columns to' > 'Folder and its children' > 'name@gmail.com' > 'name@gmail.com'

However I did report a bug when the above is applied to 'Local Folders' mail account https://bugzilla.mozilla.org/show_bug.cgi?id=1846127

I note you said " I tried the "Apply columns to ..." and selected Local Folders to change them all - none of them changed! "

Maybe you are experiencing the same bug if you are trying to apply the above action on 'Local Folders' mail account and not on another mail account you created.

But although rather boring it does work if you select on a per folder basis. 'Apply columns to' > 'Folder and its children' > 'Local Folders' > 'Local Folders - Folder name'

Изменено Toad-Hall

more options

@Toad-Hall - thanks, it does sound like the bug you reported. I know I can do it for each folder individually, but I really don't have the time to crank through them all. Supposedly, I shouldn't have to, based on the hype from TB when it launched 115. I know I wouldn't have bothered to upgrade if I thought I'd have to retouch everything by hand.

I also have an unusual combination of accounts. I have all my old Cox ISP email accounts and my new GMX account combined under the Local Folders and two accounts, left over from their passing, for my late mom and late aunt that are separate. I'm maintaining those two accounts for a little while longer, in case someone needs to contact someone in our family and doesn't have another contact method. Eventually, I'll get rid of the Cox accounts, too, because they want to phase out their email system. None of that should make a difference, but maybe it does...

more options

vs 115.3.1 I have exactly the same problem. And it is also a 32 bit version. The entire column set up I had is gone and there is nothing in the views that says "restore to column defaults" and when I try to check off the "sort by" It only allows one at a time. I have to go back to View each time, I have no header that offers the column choices I had before, nor is there a drop down box to make choices to add/remove. Where are my columns...any columns?

As a user for nearly 20 years and a donor, I usually wait a long time before updating, having experienced strange things in the past. But this one is really annoying.

Simply Stated Columns have disappeared and no where is there a restore or change drop down. All the columns from all my folders are gone as well as the "apply to all folders" or "any folder" for that matter.

I have a i5, 3.4hz, 16 gig of Ram, Windows 10 latest update.

more options

bmarx1 said

vs 115.3.1 I have exactly the same problem. And it is also a 32 bit version. The entire column set up I had is gone and there is nothing in the views that says "restore to column defaults" and when I try to check off the "sort by" It only allows one at a time. I have to go back to View each time, I have no header that offers the column choices I had before, nor is there a drop down box to make choices to add/remove. Where are my columns...any columns? As a user for nearly 20 years and a donor, I usually wait a long time before updating, having experienced strange things in the past. But this one is really annoying. Simply Stated Columns have disappeared and no where is there a restore or change drop down. All the columns from all my folders are gone as well as the "apply to all folders" or "any folder" for that matter. I have a i5, 3.4hz, 16 gig of Ram, Windows 10 latest update.

You do not have the same issue as the people in this question.

Hang on - maybe you are viewing the new 'Card View' and not the 'Table view' which you are used to seeing. Above the list of emails on the right side is 'Quick Filter' button and to the right of that button is a new icon - click on it and select 'Table Vew' from the drop down options.

If you are viewing Table view then: Try the following and if it does not fix - please ask your question. Help > TRoubleshooting Mode Click on 'REstart' Select 'Reset toolbars and controls' Click on 'Make chnages and restart'

more options

Wow. Are there multiple Thunderbird downloads out there, all labeled 115? Toad-Hall is the second person telling me to click on non-existent buttons or menus. I have no "Card View" or "Table View" anything. I can't find those views in menus, and there are certainly no buttons for selecting them. Attached is a capture of the top of my TB 115.

This seems more and more like apples and oranges - I have a version that is nothing like other users, even though I just downloaded the latest version from Mozilla. This is far from the seamless transition that TB promised with 115!

I have an AMD Ryzen 7 3700, 3.59 GHz, 32 GB RAM, with Windows 10 Home, 64-bit

Toad-Hall said

bmarx1 said

vs 115.3.1 I have exactly the same problem. And it is also a 32 bit version. The entire column set up I had is gone and there is nothing in the views that says "restore to column defaults" and when I try to check off the "sort by" It only allows one at a time. I have to go back to View each time, I have no header that offers the column choices I had before, nor is there a drop down box to make choices to add/remove. Where are my columns...any columns? As a user for nearly 20 years and a donor, I usually wait a long time before updating, having experienced strange things in the past. But this one is really annoying. Simply Stated Columns have disappeared and no where is there a restore or change drop down. All the columns from all my folders are gone as well as the "apply to all folders" or "any folder" for that matter. I have a i5, 3.4hz, 16 gig of Ram, Windows 10 latest update.

You do not have the same issue as the people in this question.

Hang on - maybe you are viewing the new 'Card View' and not the 'Table view' which you are used to seeing. Above the list of emails on the right side is 'Quick Filter' button and to the right of that button is a new icon - click on it and select 'Table Vew' from the drop down options.

If you are viewing Table view then: Try the following and if it does not fix - please ask your question. Help > TRoubleshooting Mode Click on 'REstart' Select 'Reset toolbars and controls' Click on 'Make chnages and restart'

more options

DucksoupSD said : Toad-Hall is the second person telling me to click on non-existent buttons or menus.

Hi DucksoupSD My response was not to you- I think if you read my comment it specifically says it's in response to a comment posted by bmarx1.  :)

more options

DucksoupSD: I just want all of my folders and sub-folders to have the same display columns!

There is a problem with 'Local Folders' when it comes to applying a one process to act on entire account - aka 'Local Folders'. But it does work when applying to any top level folder in 'Local Folders' that has subfolders.

It does work for any mail account set up as an independent mail account with own folders.

Here is some full instructions on setting up specific defaults to use when creating new folders. Followed by instructions on how to apply a selected correct folder column choice to other folders within same account or another account. Some people may have a particial issue with the 'Local Folders' mail account.

You can set up some default settings which get applied to new folders. Switch off threading by default:

  • Settings > General
  • Scroll to bottom
  • click on 'Config Editor' button - It opens in a new tab
  • In search type: default_view
  • You will see this line: mailnews.default_view_flags - It will have a numerical value of 1
  • click on the 'pencil' icon on the right to allow an edit.
  • Remove the number 1 and type in a zero 0
  • click on the 'tick' icon to save your settings.

You will now have: mailnews.default_view_flags - It will have a numerical value of 0 This will now mean any new folders you create, they will not have threading by default.

I have created some images which will help you to see what is required before you do it and help you step by step all the way. It will show you the exact process so you can feel confident that this is not as difficult as you may have imagined. If you need to see the images much larger - in this forum question click on the thumbnail of image and it will become much larger.

How to Force the use of 'FROM' column and not 'CORREPONDENTS'

It is in the 'Config Editor' - same process as mentioned previously.

  • In top search type: threadpane
  • look for this line: mail.threadpane.use_correspondents
  • It is set as 'True' by default.
  • click on the far right icon - it's like a two line double arrow icon - to toggle the 'True' to 'False'


How to set 'Sort by Date' and 'Sort by Descending' as default sort options.

It is in the 'Config Editor' - same process as mentioned previously.

  • In top search type: default_sort

This is the Sort by Date setting:

  • look for this line: mailnews.default_sort_type
  • It has a value of 18 by default to sort by date.

Usually this is ok, but if it does not have 18 :

  • click on the far right pencil icon to get 'edit mode'
  • Remove whatever number is in that location and type in number: 18
  • Click on the tick icon to save

Now set default to descending:

  • look for this line: mailnews.default_sort_order
  • It has a value of 1 by default to sort by ascending.
  • click on the far right pencil icon to get 'edit mode'
  • Remove the number '1' and type in number: 2
  • Click on the tick icon to save


How to set up all chosen columns to appear in all folders ina selected account. First select 'Inbox' folder of mail account.

  • Using icon on far right of column headers, select the column headers you want to see.
  • eg: Select 'From' and uncheck 'Correspondents'

Then set up the sort view you want to see.

  • 'View' > 'Sort by' and choose 'Date' and 'Descending' and 'Unthreaded'

Apply column selection to all folders in that mail account:

  • Click on icon on far right of column headers to see drop down options
  • Hover over 'Apply columns to' > Hover over 'Folders and it's children' > hover over the actual 'mail account name' - not a folder > finally click on the 'mail account name' not a folder.

Apply the sort view to all folders in the mail account:

  • Hover over 'Apply current view to' > Hover over 'Folders and it's children' > hover over the 'mail account name' - not a folder > finally click on the 'mail account name' not a folder.

You would need to repeat the above for each mail account.

NOTE: When it comes to the 'Local Folders' mail account, you may find the above works, but you may be one of those - like me - see a bug. So if the usual process stated above fails, then you are seeing the bug. However, the process still works if you select a top level folder. It's more bothersome but it does work.

For example lets pretend in 'Local Folders' you have a top level folder called 'Friends' and it has a couple of subfolders. 'Apply columns to' > Hover over 'Folders and it's children' > hover over the actual 'mail account name' > hover over mail account name and then locate and click on 'Friends' folder.

Friends folder and it's sub folders should now column headers like 'Inbox' then repeat the same process but using the 'Apply current view to' option to set up the Sort by view.

more options

@Toad-Hall: Thank you for trying, but I've been using TB for over 20 years, and, unfortunately, none of my folders were created under the individual mail accounts - they are all just in the Local Folders. When I started using TB, it let us combine all of the accounts (Unified?) into a single Inbox and set of folders. I set up my accounts and immediately combined them into the single Inbox with folders back then. I use color tagging to note which account the mail was originally directed at and Message Filters to put them into folders. This has worked great, until now. When I go through your steps, usually the only folders I see under a mail account name are Inbox and Trash. The Local Folders bug has killed any chance of quickly changing all my folders back to what I want.

Also - while I know your earlier remarks weren't directed specifically at me, I'm here grasping at straws trying to find anything that might move things forward, so I'll look at and/or try anything that someone posts. My point was, that when I did that, the button you mentioned didn't exist, so it continues to be baffling how others have items in their menus (or buttons) that don't exist in my version (the latest update) of the program.

more options

In your case - Normally you would select 'Apply columns to' > Hover over 'Folders and it's children' > hover over 'Local Folders to see next menu> Select 'Local Folders'

But you will have some top level folders in 'Local Folders' An image of what you see would help, but it should work if you select a top level folder 'Apply columns to' > Hover over 'Folders and it's children' > hover over'Local Folders' > hover over 'Local Folders' again and then click on 'a top level' folder.

more options

The first hover over Local Folders gives me a list of all of my top level folders and another Local Folders at the very top of the list. Hovering over that Local Folders does nothing (see attached photo); if I click on it, it asks to apply the changes to Local Folders.

If I just choose my Thunderbird and Firefox folder from the list, I get a dialog box when I select it from the Local Folders folder list, asking to confirm my changes (attached). I click OK and nothing happens to the folder columns.

more options

re :The first hover over Local Folders gives me a list of all of my top level folders and another Local Folders at the very top of the list.

Do not click on the second 'Local Folders' which is at the top because the bug does not work on it - instead select - click on the 'Friends' folder which has subfolders.

The pop up will appear to apply to friends folder and its subfodlers - click on OK then check the 'Friends' folder and it's subsfolders. It should have worked.

Изменено Toad-Hall