Avatar for Username

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Clicking/popping in Audio streams in FF, not in Edge

  • 15 ответов
  • 0 имеют эту проблему
  • 1 просмотр
  • Последний ответ от zeroknight

more options

I've noticed forever in FF (v115) that whenever I try to play an audio stream on a web page, like a soundcloud or other stream (that shows a waveform and a play button, not video) that I always get clicking and popping at regular intervals. I've always suspected it is due to a sample rate mismatch between FF and my MOTU UltraLite Hybrid MK3, which is always set at 48kHz. I've tried myriad settings to remedy the issue to no avail. Here is an example - scroll down to the Demos: section and play one of the streams.

Today, I tried opening the same web page in Edge and all of the streams I tried played PERFECTLY without the clicking and popping. I click back over to FF and play the streams and there is the clicking and popping. This leads me to believe that this is a FF problem, and not with the audio interface or Windows 10 Sound. Sometimes, rarely, I experience the same issue with YouTube videos, but it is always with audio streams.

Does anyone know why this occurs and if there is a way to fix it. It is so frustrating that I'm seriously considering giving up on FF after 20+ years. This has been happening as long as I can remember, and I kept hoping it would get resolved at some point, or I'd find a fix or hidden setting, but that doesn't look likely. Maybe somebody can help?

I've noticed forever in FF (v115) that whenever I try to play an audio stream on a web page, like a soundcloud or other stream (that shows a waveform and a play button, not video) that I always get clicking and popping at regular intervals. I've always suspected it is due to a sample rate mismatch between FF and my MOTU UltraLite Hybrid MK3, which is always set at 48kHz. I've tried myriad settings to remedy the issue to no avail. Here is an example - scroll down to the Demos: section and play one of the streams. Today, I tried opening the same web page in Edge and all of the streams I tried played PERFECTLY without the clicking and popping. I click back over to FF and play the streams and there is the clicking and popping. This leads me to believe that this is a FF problem, and not with the audio interface or Windows 10 Sound. Sometimes, rarely, I experience the same issue with YouTube videos, but it is always with audio streams. Does anyone know why this occurs and if there is a way to fix it. It is so frustrating that I'm seriously considering giving up on FF after 20+ years. This has been happening as long as I can remember, and I kept hoping it would get resolved at some point, or I'd find a fix or hidden setting, but that doesn't look likely. Maybe somebody can help?
Приложенные скриншоты

Все ответы (15)

more options

Can you provide a publicly accessible url that others can test? This article may help.

https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

more options

Aw, crap. Sorry! I meant to add the link at the end of the first paragraph. Here it is. Thanks!

https://www.minimal.audio/products/fuse-compressor

more options

Hi Shane,

I understand the frustration you're facing with the audio popping and clicking issue in Firefox. As a Firefox support volunteer, I'd recommend trying a few troubleshooting steps to resolve the problem. First, make sure Firefox and your audio drivers are up to date. Then, try disabling any extensions that might be interfering with audio playback. If the issue persists, you can try resetting Firefox to its default settings. Also, check your system's audio settings and ensure they match your audio interface's sample rate (48kHz). If nothing works, you can consider using Firefox's Safe Mode or testing with a new Firefox profile. Hopefully, one of these steps will help fix the audio problem and improve your experience with Firefox. Let me know how it goes!

more options

Hi, thanks for the suggestions. I disabled all Extensions but that made no difference. I did recently update the driver for the MOTU (released Oct 2022 for Win 11/10) which did give me a new capability (I discovered). In Windows' legacy Sound Control Panel's Advance Properties for the device I'm listening on, when I set the Default Format to 2 ch, 16b, 44.1kHz, it actually changes the sample rate on the MOTU as well (the older driver did not). What happens is, I found after refreshing the page I linked, the audio played without issue. If I change it back to 48K in Windows, which changes the MOTU back to 48k as well, and after a page refresh, the clicks/pops return.

What this tells me is that FF is not correctly resampling the audio to match Window's sample rate set by the user. It shouldn't be left to the user to determine what sample rate a page is sending, and then change Windows to match it because FF can't resample it correctly (assuming that I'm correct in my interpretation of what is happening here). Edge has no problem doing this.

Perhaps there is something else amiss here that is causing this disconnect, but that is the only thing that makes sense to me (that FF isn't resampling to match Windows). Any thoughts?

more options
more options

Hi Terry, thanks for the suggestions. I tried all the suggestions in all three links and nothing fixed the issue. Perhaps this is just a FF Windows issue? Cheers.

more options

Shane said

If I change it back to 48K in Windows, which changes the MOTU back to 48k as well, and after a page refresh, the clicks/pops return.

The linked example are mp3 files with 48000Hz sample rate though, so there is no mismatch?

  • Test a different audio output device or configuration.
  • Uninstall audio drivers and reinstall latest version.
  • Disable any audio effects (eg reverb) in Windows or your sound driver settings.
  • Test in a new profile by installing Developer Edition or refresh your existing profile.
  • Test older versions with mozregression to see if it is a new issue.
  • Visit about:support#media in the address bar to see audio driver details and sample rates.
more options

Hi,

Test a different audio output device or configuration.

I did that for a monitor speaker device that does not utilize my MOTU audio interface and the audio plays correctly.

Uninstall audio drivers and reinstall latest version.

Did that, no change.

Disable any audio effects (eg reverb) in Windows or your sound driver settings.

There are none.

Test in a new profile by installing Developer Edition or refresh your existing profile. & Test older versions with mozregression to see if it is a new issue.

Too much disruption.

Visit about:support#media in the address bar to see audio driver details and sample rates.

This is interesting. FF indicates the Audio Backend is WASAPI, not ASIO which is what my MOTU uses.

It's interesting because I discovered another app that played sounds with the same glitch effect. It was the XO (standalone version) from XLN Audio. When I checked the default settings on that app, though, it was also set at WASAPI. After changing it to ASIO and selecting the correct device (MOTU) at 48kHz, the sounds played correctly.

So, it appears that it may or may not be a sample rate mismatch issue, bit an issue with WASAPI being used instead of the user-defined default device MOTU on ASIO. Is there a way in FF to tell it to use ASIO instead of WASAPI?

I'm going to see if I can find what Edge uses.

Thanks!

more options

You can override the sample rate by going to about:config in the address bar and creating media.cubeb.force_sample_rate (Number) (Hz). Note that the privacy.resistFingerprinting setting locks the sample rate to 44100.

It is possible to override the backend with media.cubeb.backend (String) but "asio" is not listed:

unknown, audiounit, audiounit_rust, aaudio, opensl, wasapi, winmm, alsa, jack, oss, pulse, pulse_rust, sndio, sunaudio

More hidden audio settings can be found in the source: https://searchfox.org/mozilla-central/source/dom/media/CubebUtils.cpp#44

WARNING from the moderator team: Changing Firefox preferences from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing. Please read Firefox Advanced Customization and Configuration Options to learn more.

Изменено Paul

more options

I appreciate everyone who responded, and I tried all that was suggested. Unfortunately, nothing solved the issues I am experiencing. The problem seems to be with the WASAPI interface. Ideally, FF would have an ASIO interface built in, but according to someone on the mozilla/cubeb github where I reported this issue, the ASIO SDK is not consistent with FF FOSS approach, and that is why it isn't in the list you provided, @zeroknight. THAT would be the correct solution, and I suspect what MS Edge does (but I couldn't find anything about it) - it just works correctly in Edge (and probably Chrome too, but I refuse to install it). So I am, at least as long as I continue to use FF, forced to use the Windows sound control panel app to change my sample rate on my MOTU every time I want to stream audio using FF, and then back.

Thanks again everyone for the help/advice. Cheers.

more options

Hey there! It looks like you're experiencing some clicking and popping issues with audio streams in Firefox, right? From what you've described, it might be related to a sample rate mismatch between Firefox and your MOTU audio interface. One thing you can try is to go to "about:config" in your Firefox address bar and create a preference called "media.cubeb.force_sample_rate" with the sample rate your MOTU is set at (like 48000Hz). This could help force Firefox to match the correct sample rate. If that doesn't do the trick, it might be worth checking if there are any available driver updates for your MOTU. Hopefully, one of these steps will help you enjoy those audio streams without the annoying clicking and popping.

more options

I'm experiencing the same thing on youtube. I don't get this on MS edge. Whenever I start a video it pops and then the audio plays. Skipping through a video produces 2 pops before the audio plays as well. I noticed this only happens when I'm playing only one video. If I open up two videos and play only one the popping disappears.

more options

S61 said

this only happens when I'm playing only one video.

The pop sound is due to your audio device leaving power saving mode. To make it stay on:

Device Manager > right-click audio device > Properties > Power Management > Untick "Allow the computer to turn off this device to save power".

more options

zeroknight said

S61 said

this only happens when I'm playing only one video.

The pop sound is due to your audio device leaving power saving mode. To make it stay on:

Device Manager > right-click audio device > Properties > Power Management > Untick "Allow the computer to turn off this device to save power".

There's no power management tab for that device. However, I did send feedback to microsoft about the issue. Hope it gets resolved.

more options

Some audio drivers have a registry key for disabling power saving mode but you might be able to avoid it by simply changing your Windows power plan to "High performance".