Avatar for Username

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox is using a Chinese font for Japanese text

  • 3 ответа
  • 1 имеет эту проблему
  • 1 просмотр
  • Последний ответ от tsuyoshi3

more options

My preferred languages are set to: en-us, en, ja My preferred fonts for Japanese are set to: proportional: Sans Serif, Serif: IPA 明朝, Sans Serif: IPA ゴシック For web pages that set the language to Japanese (using lang="ja" or similar), the correct (Japanese) font is selected. However, for web pages that do not indicate the language, Firefox selects a Chinese font, ignoring my preferred language and fonts.

My preferred languages are set to: en-us, en, ja My preferred fonts for Japanese are set to: proportional: Sans Serif, Serif: IPA 明朝, Sans Serif: IPA ゴシック For web pages that set the language to Japanese (using lang="ja" or similar), the correct (Japanese) font is selected. However, for web pages that do not indicate the language, Firefox selects a Chinese font, ignoring my preferred language and fonts.

Все ответы (3)

more options

Well, in the meantime, I have set all the Chinese font preferences (simplified, traditional Hong Kong, traditional Taiwan) to Japanese fonts.

more options

Oh, that didn't work. I had to set Latin to a Japanese font, too. I guess that must be the problem: Firefox is using a Chinese font for any CJK characters in text that it decides is Latin.

more options

Using a Japanese font for Latin text was untenable. I uninstalled the Chinese font.

I feel sorry for anyone who has to view Chinese, Japanese and Latin text in Firefox.