Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Disable Firefox Spell Check Underline

  • 15 ответов
  • 0 имеют эту проблему
  • 361 просмотр
  • Последний ответ от bhendrix2

more options

Is there a way to permanently disable red underlining from Firefox spell check? This has only started occurring since an update to Firefox 110 (now on 112), but there seems to be no way to make it go away. I've unchecked the spelling box in preferences, and killed off things in about:config:

extensions.spellcheck.inline.max-misspellings 0 layout.spellcheckDefault 0 services.sync.prefs.sync.layout.spellcheckDefault false services.sync.prefs.sync.spellchecker.dictionary false

I'm using Mac Monterey, and have the global spell check turned off for that. This seems to be a problem specific to Firefox, as it doesn't happen in Chrome (spellcheck off) or Safari. I'd like to remove this entirely, since it's distracting to have it second guessing me whenever I'm typing. The main reason I use Firefox is that it gives me the ability to control many things, particularly in combination with UBlock, but I'm unable to make any progress in removing this persistent work disruption.

Is there a way to permanently disable red underlining from Firefox spell check? This has only started occurring since an update to Firefox 110 (now on 112), but there seems to be no way to make it go away. I've unchecked the spelling box in preferences, and killed off things in about:config: extensions.spellcheck.inline.max-misspellings 0 layout.spellcheckDefault 0 services.sync.prefs.sync.layout.spellcheckDefault false services.sync.prefs.sync.spellchecker.dictionary false I'm using Mac Monterey, and have the global spell check turned off for that. This seems to be a problem specific to Firefox, as it doesn't happen in Chrome (spellcheck off) or Safari. I'd like to remove this entirely, since it's distracting to have it second guessing me whenever I'm typing. The main reason I use Firefox is that it gives me the ability to control many things, particularly in combination with UBlock, but I'm unable to make any progress in removing this persistent work disruption.

Выбранное решение

ui.SpellCheckerUnderline is the color of the underlining (#FF0000)

On what pages does this happen ? It should work in the text editor used on this website.

Setting layout.spellcheckDefault to 0 and ui.SpellCheckerUnderlineStyle to 0 should disable the spell checking and hide the underlining.

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

Прочитайте этот ответ в контексте 👍 1

Все ответы (15)

more options

You can leave services.sync.prefs.sync.* prefs at their true default, those prefs specify whether to include specific prefs in syncing prefs.

You can try these prefs:

  • layout.spellcheckDefault = 0 [0:disable; 1:multi-line; 2:single-line]
  • ui.SpellCheckerUnderlineStyle = 0
more options

Thanks for this. Very much appreciated.

I've reversed the services.sync.prefs settings. I did have the layout.spellcheckDefault set to 0, it turns out. I don't seem to have the iu.SpellCheckerUnderlineStyle setting, however. Is there a different title that now goes under, perhaps?

more options

cor-el said

You can leave services.sync.prefs.sync.* prefs at their true default, those prefs specify whether to include specific prefs in syncing prefs. You can try these prefs:
  • layout.spellcheckDefault = 0 [0:disable; 1:multi-line; 2:single-line]
  • ui.SpellCheckerUnderlineStyle = 0


Thanks for this. Very much appreciated.

I've reversed the services.sync.prefs settings. I did have the layout.spellcheckDefault set to 0, it turns out. I don't seem to have the iu.SpellCheckerUnderlineStyle setting, however. Is there a different title that now goes under, perhaps?

Изменено bhendrix2

more options

ui.SpellCheckerUnderlineStyle is one of the many ui.* prefs that you can use to modify look and feel settings, most do not exist by default and need to be created.

See StyleTextDecorationStyle:

more options

cor-el said

ui.SpellCheckerUnderlineStyle is one of the many ui.* prefs that you can use to modify look and feel settings, most do not exist by default and need to be created. See StyleTextDecorationStyle:

Cool, thanks. Entirely outside of my previous experience! But I'll try things out and see what can be achieved that way. Much appreciated.

more options

If you’re wondering how to spell check, Firefox’s default settings have your spell checker enabled. When you’ve typed a misspelled word, it will underline the misspelled word and suggest the correct word to choose. To fix misspelled words, here’s what you have to do:

Using your Firefox browser, enter text into a text box. Right-click on the misspelled word. Select the correct word from the suggested words in the menu.


Regards, James

more options

techguy150 said

If you’re wondering how to spell check, Firefox’s default settings have your spell checker enabled. When you’ve typed a misspelled word, it will underline the misspelled word and suggest the correct word to choose. To fix misspelled words, here’s what you have to do: Using your Firefox browser, enter text into a text box. Right-click on the misspelled word. Select the correct word from the suggested words in the menu. Regards, James

Thanks James. I'm asking how to turn off spell check entirely, however, and eliminate the red line underneath. I have no interest in robots trying to second-guess my spelling.

more options

You can check it out in the settings section go to the language section uncheck the correct spelling setting

more options

AzZA said

You can check it out in the settings section go to the language section uncheck the correct spelling setting

Thanks, but that's already been tried prior to asking the question here.

more options

Setting ui.SpellCheckerUnderlineStyle = 0 should disable the underlining whether spell checking is enabled or not.

more options

cor-el said

Setting ui.SpellCheckerUnderlineStyle = 0 should disable the underlining whether spell checking is enabled or not.

The setting it gives me is true/false, and setting it to false doesn't seem to make a difference. Perplexing.

more options

The ui.SpellCheckerUnderlineStyle pref should be a Number pref (0-6) and not a Boolean pref (true/false). The main control pref layout.spellcheckDefault is also a Number pref (0-2).

more options

cor-el said

The ui.SpellCheckerUnderlineStyle pref should be a Number pref (0-6) and not a Boolean pref (true/false). The main control pref layout.spellcheckDefault is also a Number pref (0-2).

Strange. I've got things set this way now, and it still doesn't make a difference.

extensions.spellcheck.inline.max-misspellings 0 layout.spellcheckDefault 0 services.sync.prefs.sync.layout.spellcheckDefault true services.sync.prefs.sync.spellchecker.dictionary true spellchecker.dictionary ui.SpellCheckerUnderline 0 ui.SpellCheckerUnderlineStyle 0

more options

Выбранное решение

ui.SpellCheckerUnderline is the color of the underlining (#FF0000)

On what pages does this happen ? It should work in the text editor used on this website.

Setting layout.spellcheckDefault to 0 and ui.SpellCheckerUnderlineStyle to 0 should disable the spell checking and hide the underlining.

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

more options

cor-el said

ui.SpellCheckerUnderline is the color of the underlining (#FF0000) On what pages does this happen ? It should work in the text editor used on this website. Setting layout.spellcheckDefault to 0 and ui.SpellCheckerUnderlineStyle to 0 should disable the spell checking and hide the underlining. You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark. You can enable or disable spell checking globally:

Well, this is embarrassing, but the question of where this happens is something I should have thought about earlier. The main place it happens is on Google search, which is where I'm mostly likely to be typing something on the web (rather than an on-machine email program, Excel, Word, that sort of thing). It doesn't happen here. Everything has been unchecked globally, etc., so it's probably some annoying Google test of involuntary spellcheck. It doesn't replicate on other web browsers, but it may be something specific to Google nonetheless.

In short, I'm afraid I may have wasted your time on this one by barking up the wrong tree. Probably not Firefox at all, but something specific to Google Search. Dang it. Thanks for the time spent trying to solve this, which has at least led to learning some new things about Firefox controls.