Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Intune ExtensionSettings Policy No Longer Working in Firefox

  • 9 ответов
  • 1 имеет эту проблему
  • 906 просмотров
  • Последний ответ от cor-el

more options

Hello, in Firefox browser, my organization has always blocked all extensions except for ones we allow through OMA-URI ./Device/Vendor/MSFT/Policy/Config/Firefox~Policy~firefox~Extensions/ExtensionSettings.

About a month ago this stopped working and our end users can now install any extension in the Firefox browser that they choose, without approval, creating a security risk.

When checking in about:policies, there is a policy error: Unable to parse JSON for ExtensionSettings. We have checked with Microsoft Intune support and they verified that the policy looks to be configured and targeted correctly.

Here is a snippet of our JSON, this is a test policy where microsoft support had us remove "about:addons" from the 'install sources'. Both test and production policies are not working.

<enabled/>
<data id="ExtensionSettings" value='
{
    "*": {
        "blocked_install_message": "Contact Service Line",
        "install_sources": ["https://addons.mozilla.org/*"],
        "installation_mode": "blocked",
        "allowed_types": ["extension"]
    },
    "cloudmetering@snowsoftware.com": {
        "installation_mode": "force_installed",
        "install_url": "file:///C:/Program Files/Snow Software/Inventory/Agent/FFCloudmetering.xpi"
    },
    "fpdlpffext2@forcepoint.com": {
        "installation_mode": "force_installed",
        "install_url": "file:///C:/Program Files/Websense/Websense Endpoint/winFFext.xpi"
    },
    "jid1-5AULKXLKGyjuLQ@jetpack": {
        "installation_mode": "allowed"
    },
    "abb@amazon.com": {
        "installation_mode": "allowed"
    },
    "ciscowebexstart1@cisco.com": {
        "installation_mode": "allowed"
    },
    "linkedinConverted@firefox-extension": {
        "installation_mode": "allowed"
    },
    "{7bc53591-5218-45a0-b572-4366979097fd}": {
        "installation_mode": "allowed"
    },
    "queryamoid@kaply.com": {
        "installation_mode": "allowed"
    },
    "jid1-93WyvpgvxzGATw@jetpack": {
        "installation_mode": "allowed"
    },

Is this a bug? Or something wrong with our configuration? Has firefox changed the requirements of the extensionsettings OMA-URI?

Thanks for any help in advance.

Hello, in Firefox browser, my organization has always blocked all extensions except for ones we allow through OMA-URI ./Device/Vendor/MSFT/Policy/Config/Firefox~Policy~firefox~Extensions/ExtensionSettings. About a month ago this stopped working and our end users can now install any extension in the Firefox browser that they choose, without approval, creating a security risk. When checking in about:policies, there is a policy error: Unable to parse JSON for ExtensionSettings. We have checked with Microsoft Intune support and they verified that the policy looks to be configured and targeted correctly. Here is a snippet of our JSON, this is a test policy where microsoft support had us remove "about:addons" from the 'install sources'. Both test and production policies are not working. <pre><nowiki><enabled/> <data id="ExtensionSettings" value=' { "*": { "blocked_install_message": "Contact Service Line", "install_sources": ["https://addons.mozilla.org/*"], "installation_mode": "blocked", "allowed_types": ["extension"] }, "cloudmetering@snowsoftware.com": { "installation_mode": "force_installed", "install_url": "file:///C:/Program Files/Snow Software/Inventory/Agent/FFCloudmetering.xpi" }, "fpdlpffext2@forcepoint.com": { "installation_mode": "force_installed", "install_url": "file:///C:/Program Files/Websense/Websense Endpoint/winFFext.xpi" }, "jid1-5AULKXLKGyjuLQ@jetpack": { "installation_mode": "allowed" }, "abb@amazon.com": { "installation_mode": "allowed" }, "ciscowebexstart1@cisco.com": { "installation_mode": "allowed" }, "linkedinConverted@firefox-extension": { "installation_mode": "allowed" }, "{7bc53591-5218-45a0-b572-4366979097fd}": { "installation_mode": "allowed" }, "queryamoid@kaply.com": { "installation_mode": "allowed" }, "jid1-93WyvpgvxzGATw@jetpack": { "installation_mode": "allowed" }, </nowiki></pre><br> Is this a bug? Or something wrong with our configuration? Has firefox changed the requirements of the extensionsettings OMA-URI? Thanks for any help in advance.

Изменено cor-el

Выбранное решение

Hello, was actually just missing an additional closing bracket.

Прочитайте этот ответ в контексте 👍 0

Все ответы (9)

more options

Hi, according to the doc it looks OK, except that the last bracket is missing.

more options

Hi, yes followed this doc. And las bracket is not missing in actually policy, this was just a snippet.

more options

Your JSON code ends with e comma (,) and is missing the closing curly bracket (})

{
    "*": {
        "blocked_install_message": "Contact Service Line",
        "install_sources": ["https://addons.mozilla.org/*"],
        "installation_mode": "blocked",
        "allowed_types": ["extension"]
    },
    "cloudmetering@snowsoftware.com": {
        "installation_mode": "force_installed",
        "install_url": "file:///C:/Program Files/Snow Software/Inventory/Agent/FFCloudmetering.xpi"
    },
    "fpdlpffext2@forcepoint.com": {
        "installation_mode": "force_installed",
        "install_url": "file:///C:/Program Files/Websense/Websense Endpoint/winFFext.xpi"
    },
    "jid1-5AULKXLKGyjuLQ@jetpack": {
        "installation_mode": "allowed"
    },
    "abb@amazon.com": {
        "installation_mode": "allowed"
    },
    "ciscowebexstart1@cisco.com": {
        "installation_mode": "allowed"
    },
    "linkedinConverted@firefox-extension": {
        "installation_mode": "allowed"
    },
    "{7bc53591-5218-45a0-b572-4366979097fd}": {
        "installation_mode": "allowed"
    },
    "queryamoid@kaply.com": {
        "installation_mode": "allowed"
    },
    "jid1-93WyvpgvxzGATw@jetpack": {
        "installation_mode": "allowed"
    }
}

more options

OK, I missed that you posted a snippet.

I've moved the thread to Firefox for Enterprise since this is about Intune

Изменено cor-el

more options

Thank you for moving the thread. Am I responding in the correct place?

I am also receiving the error in the screenshot below when navigating to about:policies in firefox browser and selecting 'errors'.

Here is the complete JSON:

<enabled/> <data id="ExtensionSettings" value=' {

   "*": {
       "blocked_install_message": "Contact Service Line",
       "install_sources": ["about:addons","https://addons.mozilla.org/*"],
       "installation_mode": "blocked",
       "allowed_types": ["extension"]
   },
   "cloudmetering@snowsoftware.com": {
       "installation_mode": "force_installed",
       "install_url": "file:///C:/Program Files/Snow Software/Inventory/Agent/FFCloudmetering.xpi"
   },
   "fpdlpffext2@forcepoint.com": {
       "installation_mode": "force_installed",
       "install_url": "file:///C:/Program Files/Websense/Websense Endpoint/winFFext.xpi"
   },
   "jid1-5AULKXLKGyjuLQ@jetpack": {
       "installation_mode": "allowed"
   },
   "abb@amazon.com": {
       "installation_mode": "allowed"
   },
   "ciscowebexstart1@cisco.com": {
       "installation_mode": "allowed"
   },
   "linkedinConverted@firefox-extension": {
       "installation_mode": "allowed"
   },
   "{7bc53591-5218-45a0-b572-4366979097fd}": {
       "installation_mode": "allowed"
   },
   "queryamoid@kaply.com": {
       "installation_mode": "allowed"
   },
   "jid1-93WyvpgvxzGATw@jetpack": {
       "installation_mode": "allowed"
   },
   "WalkmeExtension@walkme.com": {
       "installation_mode": "allowed"
   },
   "{73a6fe31-595d-460b-a920-fcc0f8843232}": {
       "installation_mode": "allowed"
   },
    "@testpilot-containers": {
       "installation_mode": "allowed"
   },
    "uBlock0@raymondhill.net": {
       "installation_mode": "allowed"
   },
    "extension@redux.devtools": {
       "installation_mode": "allowed"
   },
    "jid1-ZAdIEUB7XOzOJw@jetpack": {
       "installation_mode": "allowed"
   },
    "{5caff8cc-3d2e-4110-a88a-003cc85b3858}": {
       "installation_mode": "allowed"
   },
    "{d634138d-c276-4fc8-924b-40a0ea21d284}": {
       "installation_mode": "allowed"
   },
    "jid1-MnnxcxisBPnSXQ@jetpack": {
       "installation_mode": "allowed"
   },
    "{806cbba4-1bd3-4916-9ddc-e719e9ca0cbf}": {
       "installation_mode": "allowed"
   },
    "{c9b5d073-47b4-40df-b9b9-d80601a5ab76}": {
       "installation_mode": "allowed"
   },
    "foxyproxy@eric.h.jung": {
       "installation_mode": "allowed"
   },
    "{943b8007-a895-44af-a672-4f4ea548c95f}": {
       "installation_mode": "allowed"
   },
    "{c4b582ec-4343-438c-bda2-2f691c16c262}": {
       "installation_mode": "allowed"
   },
    "langpack-en-GB@firefox.mozilla.org": {
       "installation_mode": "allowed"
   },
    "addon@darkreader.org": {
       "installation_mode": "allowed"
   },
    "{ef462a4f-5c3a-4781-a453-23ad6fb08fd1}": {
       "installation_mode": "allowed"
   },
    "{506e023c-7f2b-40a3-8066-bc5deb40aebe}": {
       "installation_mode": "allowed"
   },
    "{3507f56d-2ef5-45c1-b6d7-5297a0ba7642}": {
       "installation_mode": "allowed"
   },
    "display-anchors@robwu.nl": {
       "installation_mode": "allowed"
   },
    "https-everywhere@eff.org": {
       "installation_mode": "allowed"
   },
    "@react-devtools": {
       "installation_mode": "allowed"
   },
    "Tab-Session-Manager@sienori": {
       "installation_mode": "allowed"
   },
    "keepassxc-browser@keepassxc.org": {
       "installation_mode": "allowed"
   },
    "{80276c2b-b76c-4f9a-9b8f-8862dead8c3d}": {
       "installation_mode": "allowed"
   },
    "firefox@libraryextension.com": {
       "installation_mode": "allowed"
   },
    "opentabsnexttocurrent@sblask": {
       "installation_mode": "allowed"
   },
    "{d04b0b40-3dab-4f0b-97a6-04ec3eddbfb0}": {
       "installation_mode": "allowed"
   },
    "{79091463-df78-4dc0-a258-fb3724141b5c}": {
       "installation_mode": "allowed"
   },
    "{c5f935cf-9b17-4b85-bed8-9277861b4116}": {
       "installation_mode": "allowed"
   },
    "firefox@ghostery.com": {
       "installation_mode": "allowed"
   },
    "{32af1358-428a-446d-873e-5f8eb5f2a72e}": {
       "installation_mode": "allowed"
   },
    "{e4a12b8a-ab12-449a-b70e-4f54ccaf235e}": {
       "installation_mode": "allowed"
   },
    "multipletab@piro.sakura.ne.jp": {
       "installation_mode": "allowed"
   },
    "targetvechelper@adobe.com": {
       "installation_mode": "allowed"
   },
    "extension@requestly.in": {
       "installation_mode": "allowed"
   },
    "87677a2c52b84ad3a151a4a72f5bd3c4@jetpack": {
       "installation_mode": "allowed"
   },
    "{d7742d87-e61d-4b78-b8a1-b469842139fa}": {
       "installation_mode": "allowed"
   },
    "@contain-facebook": {
       "installation_mode": "allowed"
   },
    "{446900e4-71c2-419f-a6a7-df9c091e268b}": {
       "installation_mode": "allowed"
   },
    "{fc2b8f80-d9a5-4f51-8076-7c7ce3c67ee3}": {
       "installation_mode": "allowed"
   },
    "languagetool-webextension@languagetool.org": {
       "installation_mode": "allowed"
   },
    "keefox@chris.tomlinson": {
       "installation_mode": "allowed"
   },
    "support@lastpass.com": {
       "installation_mode": "allowed"
   },
    "{16a49f65-1369-4839-a5ef-db2581e08b16}": {
       "installation_mode": "allowed"
   },
    "progress_teststudio_extension@telerik.com": {
       "installation_mode": "allowed"
   },
    "{e4a8a97b-f2ed-450b-b12d-ee082ba24781}": {
       "installation_mode": "allowed"
   },
    "{3c078156-979c-498b-8990-85f7987dd929}": {
       "installation_mode": "allowed"
   },
    "{9d4683ff-8d9c-40ad-adb4-9fa895a3a0d7}": {
       "installation_mode": "allowed"
   },
    "uMatrix@raymondhill.net": {
       "installation_mode": "allowed"
   },
    "{201338d1-1eb4-4fa9-8a36-f58959ef9d2f}": {
       "installation_mode": "allowed"
   },
    "{E0B8C461-F8Fb-49B4-8373-FE32E9252800}": {
       "installation_mode": "allowed"
   },
    "svwe@oracle.com": {
       "installation_mode": "allowed"
   },
    "Clipper@OneNote.com": {
       "installation_mode": "allowed"
   },
    "jsonview@brh.numbera.com": {
       "installation_mode": "allowed"
   },
    "{2d2026b3-3b4f-4c50-83a1-0cabb4d1fdfa}": {
       "installation_mode": "allowed"
   },
    "de-CH@dictionaries.addons.mozilla.org": {
       "installation_mode": "allowed"
   },
    "simple-tab-groups@drive4ik": {
       "installation_mode": "allowed"
   },
    "firefox@tampermonkey.net": {
       "installation_mode": "allowed"
   },
    "{0d92d791-1db2-4181-a017-f309b99a620c}": {
       "installation_mode": "allowed"
   },
    "{a6fd85ed-e919-4a43-a5af-8da18bda539f}": {
       "installation_mode": "allowed"

}'/>

more options

You need to remove this line: ``

      "install_sources": ["about:addons","https://addons.mozilla.org/*"],

```

more options

Выбранное решение

Hello, was actually just missing an additional closing bracket.

more options

I am having a similar issue but in my case it has never worked since I am onboarding the browser at this time. Can someone take a look at my post? https://support.mozilla.org/en-US/questions/1403897

more options

Hi daniel.david.white

I've moved your question to this Firefox for Enterprise forum, so please continue there.

Изменено cor-el