Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How to get rid of the large space between tabs and the address bar after upgrading to new version 107.

  • 6 ответов
  • 0 имеют эту проблему
  • 237 просмотров
  • Последний ответ от Timtak

more options

After upgrading to version 107, there is a huge space between the open tabs and the address bar. Can't figure out how to remove it. I am thinking it has something to do with the fact that I had enabled multi-row tabs. I can fill up that space with tabs if I open enough of them. In the older version that space was not there and the space would just expand to accommodate the extra row of tabs as needed. Any ideas would be greatly appreciated!

After upgrading to version 107, there is a huge space between the open tabs and the address bar. Can't figure out how to remove it. I am thinking it has something to do with the fact that I had enabled multi-row tabs. I can fill up that space with tabs if I open enough of them. In the older version that space was not there and the space would just expand to accommodate the extra row of tabs as needed. Any ideas would be greatly appreciated!
Приложенные скриншоты

Выбранное решение

Yes!!! That worked perfectly. Thanks so much. For anyone else out there with that problem here is what I did based on the linked thread:

Open your .css file (this is in the 'chrome' folder within your profile folder - your profile folder can be found by clicking the three bars in the upper right>Help>More troubleshooting information then clicking "Open Folder' under the Profile folder tab)

Then just replace the text in the .css file with the text below. It should be near the top so not too hard to find.

Replace this:

#tabbrowser-tabs { 

min-height: unset !important; padding-inline-start: 0px !important }

with this..

#tabbrowser-tabs { 

height: var(--tab-min-height); padding-inline-start: 0px !important }

Прочитайте этот ответ в контексте 👍 1

Все ответы (6)

more options

Do you use the userChrome.css file?

Полезно?

more options

Yes, I do. I used that to bring back the multi-row tabs. That's what makes me think it has something to do with that. But I'm still not sure how I would edit the .css file to fix this issue. I'm not smart enough for that:) I just copied a bunch of text from another user to get the multi-row tab thing to work.

Полезно?

more options

See this thread:

Полезно?

more options

Выбранное решение

Yes!!! That worked perfectly. Thanks so much. For anyone else out there with that problem here is what I did based on the linked thread:

Open your .css file (this is in the 'chrome' folder within your profile folder - your profile folder can be found by clicking the three bars in the upper right>Help>More troubleshooting information then clicking "Open Folder' under the Profile folder tab)

Then just replace the text in the .css file with the text below. It should be near the top so not too hard to find.

Replace this:

#tabbrowser-tabs { 

min-height: unset !important; padding-inline-start: 0px !important }

with this..

#tabbrowser-tabs { 

height: var(--tab-min-height); padding-inline-start: 0px !important }

Изменено joshlukins

Полезно?

more options

Trying to address this same "large space" problem that arose beneath the userchrome.css code for multiple row bookmarks see screen captures. The one with the space is the text which worked fine before the 107 update but now shows several lines of space below.

The parameter in the css file that seems to address this is:

root {
 --bookmark_items_height: 22px; /* <- bookmark items - line height */
 --bookmark_items_lines: 4; /* <- maximum amount of lines */

See that I changed it to 4 for maximum amount of lines which produces the desired result in the screen capture with no extra lines. If I left it at the default of 10, the bookmark rows with all of the extra rows appears.

Anyone found the solution to this one yet?

Полезно?

more options

joshlukins said

Replace this: #tabbrowser-tabs { min-height: unset !important; padding-inline-start: 0px !important } with this.. #tabbrowser-tabs { height: var(--tab-min-height); padding-inline-start: 0px !important }

Thank you very much indeed, and to MrOtherGuy for maintaining the code. I am sure he will update his Github soon.

I wish Firefox would see Multirow tabs as, if not part of Firefox, something that they need to test with each release. It is a deal breaker for me. I have about 60 tabs open currently on 4 long rows. I often use my display in portrait mode (A4 paper) when I can easily have 8 rows of tabs.

But then, if Firefox breaks multirow tabs there may be no alternative (Vivaldi offers only two rows, apparently).

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.