Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

DNS question about local names and PiHole.

  • 7 ответов
  • 0 имеют эту проблему
  • 3 просмотра
  • Последний ответ от teeny_weeny

more options

Declarations: FF -> FireFox. IOT -> internet thingy that is an appliance, etc.

Story:

I have PIHOLE as my DNS and run mostly RasPi machines. I have a "smart" TV and other devices that "Call home" a lot. PIHOLE is used to block them and it seems to be working. My main machine is a Ubuntu machine.

All machines point to PIHOLE as their DNS server - rather than the router, as it makes see who is doing what harder.

Things seem to be working, but then "this" happens. Upfront: I have `/etc/host` files on all pi's and the Ubuntu machine. Not sure that is good or bad, but it may be important. It is (for now) only computer names, not any other IOT devices.

PIHOLE supports a DNS thing where I can name devices on my network like with the `etc/host` file, but it is central to all machines on the network. OR SO I THOUGHT!

Now as much as you are now thinking: "That's a PIHOLE problem", it is and it isn't.

Here's why:

I make an entry in the DNS table of PIHOLE for `arlec1 - IP 192.1168.0.1` (I can't remember the exact address, but for the sake of.)

I can now `ping arlec1` and I get replies and it is correct IP address.

The idea (story) is that rather than enter the IP address, I enter the name. Further disclosure: I have NEVER UNTIL NOW used that in the browser. It is more for when I need to access them from a CLI/Terminal. It works.

I'm getting lazy. It dawned on me that I can use the name to get to my device's web page and it would save a lot of typing. (It didn't - it cost me two days or more of confusion.)

`arlec1` is NOT on any of the local machine's `/etc/host` files. I'm trying to use PIHOLE as the main DNS server. (Again: "Why are you asking here?" Sorry, I am putting all the cards on the table so you know the story up to now.)

`ping arlec1`. NOTHING. It just failed. `dig arlec1` went to 8.8.8.9 - or the "main" DNS server I use. It wasn't going through PIHOLE's DNS - for some reason. and it never got an "ANSWER". `dig PIHOLE arlec1` works. I see the correct IP address and pings are working. (skipping a bit here)

Now that it is working I open a FF page and enter `arlec1` into the URL and press enter. It goes to "Mr google". HOWEVER! If I enter: `http://arlec1` it works.

Thought!

I have/had the option to have the search and URL combined. I unticked that and tried. (Didn't exit FF, I have about 40 windows and a few hundred tabs open, it is slow doing that.) I now have a separate (and visible - so I'm guessing it should be handled separately now) URL and search areas.

STILL FAILS and goes to mr google if I don't prefix it with `http://`

Kinda defeats the purpose - doesn't it?

There seems to be an elephant hiding close by, but I don't see it.

Could someone help me get my head around what is going on and what is causing this from a FF point of view?

Declarations: FF -> FireFox. IOT -> internet thingy that is an appliance, etc. Story: I have PIHOLE as my DNS and run mostly RasPi machines. I have a "smart" TV and other devices that "Call home" a lot. PIHOLE is used to block them and it seems to be working. My main machine is a Ubuntu machine. All machines point to PIHOLE as their DNS server - rather than the router, as it makes see who is doing what harder. Things seem to be working, but then "this" happens. Upfront: I have `/etc/host` files on all pi's and the Ubuntu machine. Not sure that is good or bad, but it may be important. It is (for now) only computer names, not any other IOT devices. PIHOLE supports a DNS thing where I can name devices on my network like with the `etc/host` file, but it is central to all machines on the network. OR SO I THOUGHT! Now as much as you are now thinking: "That's a PIHOLE problem", it is and it isn't. Here's why: I make an entry in the DNS table of PIHOLE for `arlec1 - IP 192.1168.0.1` (I can't remember the exact address, but for the sake of.) I can now `ping arlec1` and I get replies and it is correct IP address. The idea (story) is that rather than enter the IP address, I enter the name. Further disclosure: I have NEVER UNTIL NOW used that in the browser. It is more for when I need to access them from a CLI/Terminal. It works. I'm getting lazy. It dawned on me that I can use the name to get to my device's web page and it would save a lot of typing. (It didn't - it cost me two days or more of confusion.) `arlec1` is NOT on any of the local machine's `/etc/host` files. I'm trying to use PIHOLE as the main DNS server. (Again: "Why are you asking here?" Sorry, I am putting all the cards on the table so you know the story up to now.) `ping arlec1`. NOTHING. It just failed. `dig arlec1` went to 8.8.8.9 - or the "main" DNS server I use. It wasn't going through PIHOLE's DNS - for some reason. and it never got an "ANSWER". `dig PIHOLE arlec1` works. I see the correct IP address and pings are working. (skipping a bit here) Now that it is working I open a FF page and enter `arlec1` into the URL and press enter. It goes to "Mr google". HOWEVER! If I enter: `http://arlec1` it works. Thought! I have/had the option to have the search and URL combined. I unticked that and tried. (Didn't exit FF, I have about 40 windows and a few hundred tabs open, it is slow doing that.) I now have a separate (and visible - so I'm guessing it should be handled separately now) URL and search areas. STILL FAILS and goes to mr google if I don't prefix it with `http://` Kinda defeats the purpose - doesn't it? There seems to be an elephant hiding close by, but I don't see it. Could someone help me get my head around what is going on and what is causing this from a FF point of view?

Все ответы (7)

more options

Hi! You may have an issue with DNS over HTTPS (DoH), if you are using your PiHole, you might consider disabling it. Refer to this article: Firefox DNS-over-HTTPS.

more options

(Second attempt to post)

Your reply is saying I need to not use PiHole as my DNS.

I am using PiHole to block any unwanted adverts / sites being able to be accessed determined by me. That is then passed on to the DNS of my choice.

I can't see any relationship between what you said to what I am asking. Your reply is referencing HTTPS which I am not using in this example so I am not seeing the connection.

Изменено teeny_weeny

more options

By "it" I meant DoH. With DoH, Firefox is not using the DNS server set on the system.

more options

> By "it" I meant DoH. With DoH, Firefox is not using the DNS server set on the system.

(Not to you but)

Gee, that's great. So you can have one or the other but not BOTH?

(I've had to update from ubuntu 21.04 to 22.04 as 21.04 is dead in the water. Now screen shot doesn't work.)

I don't have `Enabled DNS on HTTPS` set. I thought that would be shown in my config file I attached with the first post. Oh well.

Now I have to do away and learn how to use Ubuntu 22.04 and get things back to what they were for things like screen shots.

more options

does firefox have hardcoded dns servers? probably google's ?

more options

If you have DoH enabled, then it uses Cloudflare by default (at least in my region), but you can specify an other provider in the settings.

more options

So, sorry, I don't have DoS enabled.

I'm confused to what is happening.

From what I remember happening: if I type the IP I go to that computer's page. if I type the computer's name in the URL bar it goes to google. (I'll get back to that in a second) the only way I can get the name to work is to prefix it with http://

Problem here: Names are supposed to be easier to enter than IP numbers.

Now, getting back to that thing: YES: I had the setting set to make the URL also the search bar/entry.

I have since disabled that and I also have a search box in the top. Problem remains.