Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Restore the "Open in Firefox" WITHOUT asking, and WITHOUT downloading

  • 3 ответа
  • 1 имеет эту проблему
  • 10 просмотров
  • Последний ответ от James

more options

I have read hours of Q&A about this problem here in this forum before posting, and cannot find a solution.

Until very recently, whenever I would click a link in a page, it would "Open in Firefox" in a new tab. Then after reading it or printing it or whatever I wanted to do, I could click the download [Fx98PDFviewer-DownloadButton] button if I wanted to save it, and an Explorer would open up allowing me to select where I want to put it and what I want to call it (if I wanted to change the name it comes with) before downloading/saving.

Now, when I click a link it just downloads (even though most of the time I don't want that). Despite all I've read, I've tried a dozen settings, and I CANNOT get that behavior back.

If I set the browser.download.improvements_to_download_panel to False, and select "Open with Firefox" when it prompts me, I can't get it to STOP prompting me. It prompts me EVERY TIME, even though I have checked the box repeatedly for "Do this automatically for files like this from now on"

And yet it is STILL downloading automatically when it opens for viewing in the new tab, and I am forever now cleaning and deleting crap out of my downloads.

I have my default PDF reader set to the reader I like, and when I'm NOT in Firefox, I do NOT want to have to right-click and select my preferred reader each time.

But when I AM IN FIREFOX, what I need it to do is

- Open in Firefox, in a new tab, 
- DON'T prompt me, just do it, and 
- DON'T download it, unless if I then want to keep it I click the download [Fx98PDFviewer-DownloadButton] button.

HOW CAN I GET IT THIS BEHAVIOR BACK PLEASE?

I have read hours of Q&A about this problem here in this forum before posting, and cannot find a solution. Until very recently, whenever I would click a link in a page, it would "Open in Firefox" in a new tab. Then after reading it or printing it or whatever I wanted to do, I could click the download [Fx98PDFviewer-DownloadButton] button if I wanted to save it, and an Explorer would open up allowing me to select where I want to put it and what I want to call it (if I wanted to change the name it comes with) before downloading/saving. Now, when I click a link it just downloads (even though most of the time I don't want that). Despite all I've read, I've tried a dozen settings, and I CANNOT get that behavior back. If I set the browser.download.improvements_to_download_panel to False, and select "Open with Firefox" when it prompts me, I can't get it to STOP prompting me. It prompts me EVERY TIME, even though I have checked the box repeatedly for "Do this automatically for files like this from now on" And yet it is STILL downloading automatically when it opens for viewing in the new tab, and I am forever now cleaning and deleting crap out of my downloads. I have my default PDF reader set to the reader I like, and when I'm NOT in Firefox, I do NOT want to have to right-click and select my preferred reader each time. But when I AM IN FIREFOX, what I need it to do is - Open in Firefox, in a new tab, - DON'T prompt me, just do it, and - DON'T download it, unless if I then want to keep it I click the download [Fx98PDFviewer-DownloadButton] button. HOW CAN I GET IT THIS BEHAVIOR BACK PLEASE?

Все ответы (3)

more options

Hello Firefox! This has been an issue for thousands of your users for months now and you refuse to acknowledge or revert this feature! Are you even listening to us? Do you even care?

There has to be another about:config setting that reverts this new "feature" because like posted above {browser.download.improvements_to_download_panel to False} simply moves the location, my pc is still filling itself up with worthless pdf's I'd never save in a thousand years. And for someone with low HD space, you can see how extremely frustrating it is to go in every week and clear out hundreds of pdf files.

SERIOUSLY FIX THIS!!!!!

Полезно?

more options

If you just want to open files, there is now a preference in about:config you can change to true to make the file save to your temp folder which is the standard browser requirement and the old Firefox behaviour. browser.download.start_downloads_in_tmp_dir

https://bugzilla.mozilla.org/show_bug.cgi?id=1738574#c133 https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Полезно?

more options

browser.download.improvements_to_download_panel Preference will Not work as it was for Fx 98.0 to 101.0. The Preference for Fx 102.0 to current is browser.download.start_downloads_in_tmp_dir

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.