On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

geo.provider.network.url no longer works

  • 4 ответа
  • 1 имеет эту проблему
  • 12 просмотров
  • Последний ответ от tel2

more options

Noticed geo.provider.network.url setting in about:config no longer works in firefox 102.0 ubuntu. I use it consistently so it was easy to notice that it no longer had any effect after updating.

tested both on https://maps.google.com and https://browserleaks.com/geo

Is it possible to revert to an older version without losing my data?

Noticed geo.provider.network.url setting in about:config no longer works in firefox 102.0 ubuntu. I use it consistently so it was easy to notice that it no longer had any effect after updating. tested both on https://maps.google.com and https://browserleaks.com/geo Is it possible to revert to an older version without losing my data?

Выбранное решение

resolved by also setting geo.provider.use_geoclue to false

Прочитайте этот ответ в контексте 👍 0

Все ответы (4)

more options

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

Полезно?

more options

Thanks for the suggestion. I downloaded firefox-101.0.1 and it works fine there, even after restoring copying over data from the main firefox (http://mzl.la/1xKrzkF) and syncing my firefox account.

I think this may be an issue with firefox-102? Would have to redownload a fresh copy to confirm.

It's either there a bug in 102 or the update process broke something. I've always been wary of updating.

I think i'll just delete the 102 version and continue using 101.

Thanks for your help.

Полезно?

more options

I just downloaded a fresh copy of firefox 102 and i had the same problem. So I think this means there is a bug in 102, or the process for changing location was changed?

Steps: 1. Download 102: https://download-installer.cdn.mozilla.net/pub/firefox/releases/102.0.1/linux-x86_64/en-GB/firefox-102.0.1.tar.bz2

2. Extract to folder

3. Click on firefox

4. Open https://browserleaks.com/geo, and grant permission. It should show the location provided by isp

5. open about:config and edit "geo.provider.network.url" to: data:,{"location":{"lat":84.552145,"lng":8.259976},"accuracy":1000}

6. Go back to https://browserleaks.com/geo and reload multiple times using ctrl+shift+r after granting location access, it still shows location seen previously in step 4, even after restarting browser.

7. The process works as expected in firefox 101

Полезно?

more options

Выбранное решение

resolved by also setting geo.provider.use_geoclue to false

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.