Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

After upgrade to 102 can't send S/MIME signed messages

  • 8 ответов
  • 1 имеет эту проблему
  • 32 просмотра
  • Последний ответ от kaie

more options

Having working before, after upgrade to TB 102 when I try to send an S/MIME signed message I get this:

--- Sending of the message failed. Unable to sign message. Please check that the certificates specified in Mail & Newsgroups Account Settings for this mail account are valid and trusted for mail. ---

I check the account settings and seems to be all fine (as I mention it was working before) nevertheless I clear the selected S/MIME certificates and select them again but still have the issue.

Please help, the company policies is to always sign our messages, so right now I'm not able to send any messages.

((enjoy)) Carlos Rodríguez

Having working before, after upgrade to TB 102 when I try to send an S/MIME signed message I get this: --- Sending of the message failed. Unable to sign message. Please check that the certificates specified in Mail & Newsgroups Account Settings for this mail account are valid and trusted for mail. --- I check the account settings and seems to be all fine (as I mention it was working before) nevertheless I clear the selected S/MIME certificates and select them again but still have the issue. Please help, the company policies is to always sign our messages, so right now I'm not able to send any messages. ((enjoy)) Carlos Rodríguez

Все ответы (8)

more options

I hope this information helps...

mailnews.send: Exception { name: "NS_ERROR_FAILURE", message: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgComposeSecure.finishCryptoEncapsulation]", result: 2147500037, filename: "resource:///modules/MimeMessage.jsm", lineNumber: 86, columnNumber: 0, data: null, stack: "createMessageFile@resource:///modules/MimeMessage.jsm:86:27\n", location: XPCWrappedNative_NoHelper } MessageSend.jsm:130:27

---

mailnews.send: Sending failed; , exitCode=2147500037, originalMsgURI= MessageSend.jsm:335:27

   fail resource:///modules/MessageSend.jsm:335
   createAndSendMessage resource:///modules/MessageSend.jsm:138

---

Uncaught TypeError: this._l10nButtons is undefined

   postLoadInit chrome://global/content/elements/dialog.js:324
   MozDialog chrome://global/content/elements/dialog.js:61
   openWindowPrompt resource:///actors/PromptParent.jsm:161
   receiveMessage resource:///actors/PromptParent.jsm:108
   openPrompt resource://gre/modules/Prompter.jsm:1182
   openPromptSync resource://gre/modules/Prompter.jsm:1046
   alert resource://gre/modules/Prompter.jsm:1329
   fail resource:///modules/MessageSend.jsm:350
   createAndSendMessage resource:///modules/MessageSend.jsm:138

dialog.js:324:11

Полезно?

more options
Please check that the certificates specified in Mail & Newsgroups Account Settings for this mail account are valid and trusted for mail.

Is your cert valid and trusted for mail?

Полезно?

more options

Hi all CAs are trusted, however I notice one missing CA certificate that was not needed before, after I added then it let me sign email agin, but the signature is now invalid.

I notice that the added CA is in the Software Security Device where all others are in the Builtin Object Token.

It I go to then to "Security Devices" and look for Software Security Device, I see that I can click on the "Load" button, that makes me thing it is not loaded. If I click on it, it ask me for a Module filename, but I have no idea where the module is and my expectation was that the device is actually loaded

Any ideas?

Полезно?

more options

"NSS Internal PKCS #11 Module" Path is currently set to null, is that normal or it should point to a .dylib as the "Builtin Roots Module"?

Полезно?

more options

There is no need to mess with Software Security Device or Builtin Object Token. Importing a needed CA cert underneath the 'Authorities' tab will do.

Are you using the Owl add-on by any chance? If so, make sure you do have the version compatible with TB102.

Полезно?

more options

No I do not have Owl.

And BTW this is already an accepted bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1777336

Полезно?

more options

Thanks for posting the link to the bug report. I wasn't aware of this.

Полезно?

more options

The cause has been identified, it's described at https://bugzilla.mozilla.org/show_bug.cgi?id=1777336#c43

That link also describes a workaround, that can be used until Thunderbird is fixed in an update.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.