On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

My self-signed *.local.dev wildcard SSL no longer works in v101.0

  • 3 ответа
  • 1 имеет эту проблему
  • 35 просмотров
  • Последний ответ от Chad Reitsma

more options

After upgrading to v101, Firefox no longer recognizes my Self-signed wildcard SSL for *.local.dev.

Before you tell me not to use the .dev domain, I am aware that Google owns it and we're technically not supposed to do local development with the *.local.dev domain.

I have already tried the following: 1. Set network.stricttransportsecurity.preloadlist to FALSE, and everything was working perfectly fine before v101 2. imported the server.crt into Trusted Root Authorities in Windows, and also imported it in the Certificate manager in Firefox. 3. Tried other wildcard local domains like *.test.site, *.local.ddev and these don't work either.

I even tried following recent guides to issue a new certificate with openssl and SAN, and it still doesn't work.

Screenshot of wildcard SSL attached.

After upgrading to v101, Firefox no longer recognizes my Self-signed wildcard SSL for *.local.dev. Before you tell me not to use the .dev domain, I am aware that Google owns it and we're ''technically'' not supposed to do local development with the *.local.dev domain. I have already tried the following: 1. Set network.stricttransportsecurity.preloadlist to '''FALSE''', and everything was working perfectly fine before v101 2. imported the server.crt into Trusted Root Authorities in Windows, and also imported it in the Certificate manager in Firefox. 3. Tried other wildcard local domains like *.test.site, *.local.ddev and these don't work either. I even tried following recent guides to issue a new certificate with openssl and SAN, and it still doesn't work. Screenshot of wildcard SSL attached.
Приложенные скриншоты

Выбранное решение

Found this guide *Works! https://betterprogramming.pub/trusted-self-signed-certificate-and-local-domains-for-testing-7c6e6e3f9548

Прочитайте этот ответ в контексте 👍 0

Все ответы (3)

more options

Полезно?

more options

Thanks cor-el! That explains it. I will check the release notes next time.

I did try issuing a certificate with the correct SAN, but it's possible I made a mistake. I'll keep trying and report any findings back here.

Полезно?

more options

Выбранное решение

Found this guide *Works! https://betterprogramming.pub/trusted-self-signed-certificate-and-local-domains-for-testing-7c6e6e3f9548

Изменено Chad Reitsma

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.