Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

past searches being saved even while private browsing

  • 6 ответов
  • 1 имеет эту проблему
  • 1 просмотр
  • Последний ответ от amygrams7

more options

Hello!

I always use private browsing so I thought that my history was totally not being saved, but discovered recently that when I started to type within the search field, that many of my past searches were listed in the search field with the type highlighted in purple. I had to manually go in and delete all of these past searches. I don't want any search history to be saved. Is there a setting in preferences that I'm somehow missing? Why is Firefox saving these past searches if I have it set to Always Use Private Browsing?

Thank you!

Hello! I always use private browsing so I thought that my history was totally not being saved, but discovered recently that when I started to type within the search field, that many of my past searches were listed in the search field with the type highlighted in purple. I had to manually go in and delete all of these past searches. I don't want any search history to be saved. Is there a setting in preferences that I'm somehow missing? Why is Firefox saving these past searches if I have it set to Always Use Private Browsing? Thank you!

Выбранное решение

Thanks for the suggestion FredMcD. I finally figured out what the issue was, because I tried browsing in Safari and realized that it was doing the same thing in that browser, too. I use Yahoo as my homepage, and I do my searches through there, so I realized it had something to do with Yahoo. Sure enough, Yahoo was saving my history! I had to switch it off in their settings, and the problem went away!

Прочитайте этот ответ в контексте 👍 0

Все ответы (6)

more options

This isn't possible to save cache or history when one uses private mode. I've done this and no history or cache was saved. Are you really sure your opening in private mode and mistaken standard browser from private mode. And as no one is there when this happens - there no way to verify this.

Полезно?

more options

Hi Dropa,

Thank you for your reply. I have tried both "Never Remember History" and also the custom "Always use private browsing", and I always go to File/New Private Window before I do a search.

I just did a test- I opened a new private window, did a search for Squarespace, and then closed that window. When I opened another new private window, Squarespace was in the search field, remembered by Firefox. I have attached some screenshots of my settings and of the Squarespace example.

Thank you!

Полезно?

more options

That could be the form filler built into Firefox. Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press Shift + Delete

Repeat as needed.

Полезно?

more options

Выбранное решение

Thanks for the suggestion FredMcD. I finally figured out what the issue was, because I tried browsing in Safari and realized that it was doing the same thing in that browser, too. I use Yahoo as my homepage, and I do my searches through there, so I realized it had something to do with Yahoo. Sure enough, Yahoo was saving my history! I had to switch it off in their settings, and the problem went away!

Полезно?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

Полезно?

more options

Thanks, FredMcD! I just clicked the 'Solved' button for that post.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.